mikrolCD debugger is a highly effective tool for real-time debugging at
hardware level. It enables you to view program variable values, Special
Function Registers (SFRs) and EEPROM while the program is running.
This manual contains practical example on how to create a new project,
write and compile code and test the results.
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1.0. mikrolCD® Overview

The mikrolCD (In-Circuit Debugger) is a hardware tool designed for testing and debugging programs on most PIC microcontrollers. It also
enables you to monitor the state of all registers within the microcontroller which operates in real environment. In order for the mikrolCD
debugger to be used, it is necessary to have the appropriate hardware as well as to install additional software.

Hardware

The mikrolCD is an integral part of the PICflash programmer intended for use with PIC16, PIC18, PIC24, dsPIC30 and dsPIC33
microcontrollers. It is built into all PIC® development systems designed by MikroElektronika such as EasyPIC6, EasyPICS5,
BigPIC5, EasydsPIC4, LV 24-33A etc. Thanks to mikrolCD support, the PICflash® programmer is a multifunctional device as
it may be used for programming PIC microcontrollers as well as for debugging programs executed in real time. Besides, the
PICflash programmer is also available as a stand-alone device used for programming chips built into (soldered on) the target device.

development system

PIC microcontrollers are connected to the programmer through the PGC, PGD and MCLR pins. In case that such programmer is used for
the programming only, its hardware will automatically break connection with these pins after loading the HEX code, thus enabling them to
be used for other purposes.

In case that the PICflash programmer is also used for debugging (mikrolCD is enabled), these pins will be used for communication with
the PC and cannot be used for other purposes.
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The process of testing and debugging programs in real environment is performed by monitoring the state of all registers within the
microcontroller. The mikrolCD debugger also offers functions such as running a program step by step (single stepping), pausing the
program execution to examine the state of currently active registers using breakpoints, tracking the values of some variables etc. In
this case the mikrolCD debugger is connected to the PC all the time so that the PGC, PGD and MCLR/Vpp pins cannot be used for the
operation of the target device.

Software

The mikrolCD debugger needs the additional software to be installed on the PC for its operation. Such software includes:

PiCflash v7.02 (or later version) is a program used along with the PICflash programmer’s hardware. It enables you to select the
microcontroller to be programmed and to set up its mode. You can download it for free from our website at www.mikroe.com.

Drivers necessary for the proper operation of the PICflash programmer enable communication between the PC and the PICflash
programmer’s hardware.

Compilers are programs used for compiling programs written in high-level programming languages into executable file (HEX code). Here
is a list of compilers providing the mikrolCD support:

mikroC PRO® 2009;

mikroBasic PRO® 2009;

mikroPascal PRO® 2009;

mikroC® (dsPIC30/33 & PIC24);
mikroBasic® (dsPIC30/33 & P1C24); and
mikroPascal® (dsPIC30/33 & PIC24).

The compilers’ demo versions can be downloaded for free from our website at www.mikroe.com
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2 2.0. Using mikrolCD
The mikrolCD debugger comes with all PIC and dsPIC compilers designed by MikroElektronika. This manual illustrates and describes its
operation in the mikroC PRO for PIC compiler. The principle of the operation is the same for mikroBasic and mikroPascal compilers as well.
Step 1: Writing the Program and Setting up the Project for Debugging
Creating a new project and writing a program in the compiler’s main window should be done first. The next step is to set up the project for
debugging using the mikrolCD debugger. To perform this, it is necessary to select the following options in the Project Settings window:
(€ mikeoC PRO for PIC - C:\Program Files\MikroelektronikalmikreC PRO for PIC\Examples\Development Systems\EasyPIC5\Led BlinkinglLedBlinking.meppi  [= [EIK]
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mikroC PRO for PIC main window Buid Type g
) Releaza +1 ICD Debug
Debugger
) Softwae
Select the mikrolCD option to
T8 Code Explorer enable the mikrolCD debugger
WM to be used for debugging.
¥ Functi
Slobals Gesmgm
TypeDef (O Software & mikselCD
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Step 2: Compiling the Program and Dumping It into the Microcontroller

The program has to be compiled into the machine code before it is downloaded into the microcontroller. In order to start the process of
compiling, click one of the appropriate shortcut icons or select the following option from the compiler’s Project drop-down menu:

Build+Program [Ctrl+F11]
By clicking on this command, the PICflash programmer will be automatically activated after completing the process of compiling and the

compiled program (HEX code) will be immediately loaded into the microcontroller’s program memory. The programming progress will be
shown in the PICflash programmer’s window to appear on the screen:

Project drop-down menu - Build options

[€] mikroC PRO for PIC - C:\Program Files\WikroelektronikalmikroC PRO for PIC\Examples\Development Systems\ERSyS

Eile Edit View |P | Run_Tooks | Help
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Py 3-8 i:b Buid All Projects  Shift+F9 s = o &
& Project seti A= Buid + Program Ciri+F11
Edit Search Paths. . :
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" % Code Protect =
Remave Fils From Project s e ~
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i oo Sicies Tast configuration: Enk-Exk Switchaver  Frubled - OO, - 07PN Pl v 2
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Open Froject Group... Dev.Board: EasyPICS Low Voltage Program  [estisd -
*  Close Project Oscillator: HS, 08.00 In-Circait Debugger 10D Doatiert - ¥ Calloration word Protact ¥ Qo0E
5 oject Group e Cal Wesd CATA [EEPRCH)
Save Project As... 3 —
> mrkrol PR cone OAT
Recent Projects * | wotTEs: 1D Lecations - .
{ WEFWFF | WFF I =
# Functions | 59 Close Project - Turn ON the PORT LEDs at Catien
Globals L o - Frogram Memory Soe: 8K Dewice Statun: bdle Type Progrens:
TypeDef " DATA Sive: 256 Byles Addesn: Oh Bugvion O
Tags
Includes FT| Massages Fiig: ¢ ESWIKROEL - e INKINGLEDBLINL
Device: PICIGFSET Operabon: Mone

PICflash programmer’s main window

NOTE: In addition to the aforementioned build option which causes the program to be automatically compiled and loaded into the
microcontroller memory, there are two other build options in the Project drop-down menu:

Build [Ctrl+F9] If the project consists of one file; and
Build All [Shift+F9] If the project consists of several files;

These options are intended for compiling only and do not start up the programming process. Accordingly, when these are used, the HEX
code has to be loaded into the microcontroller from within the PICflash program using the Load and Write options. More information on
MCU programming using the PICflash program may be found in the PICflash Programmer manual.




Step 3: Starting up the mikrolCD Debugger

After the microcontroller has been successfully programmed, it is time to start up the mikrolCD by selecting the Start Debugger option
from the Run drop-down menu.

Start Debugger option

€ mikroC PRO for PIC - C:\Program Files\MikroelektronikalmikroC PRO for PIC\Examples\Development Syslcms\ia:yplﬁﬂl.gj“ link
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() Softears & mbrolCD 2 . Dev.Board:

As mentioned before, the mikrolCD debugger enables you to directly monitor the state of all registers within the microcontroller. Some of
the most frequently used debugger options are: Step Into, Step Over, Run to Cursor and Step Out. For the Watch Values window to appear
on the screen, select the View > Debug Windows > Watch Window option.

Icon commands
Watch Values

TC and PORTD. -}} |—'-]J _:h o0 % 0o oI B = . .
¥ ) _1__| Click on some of these options to
d Add ¥ Remove < Properties g AddAll add/remove selected registers on the list
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®

Peripherals Freeze ) ) )
wrn ON the PORT LE R — Alist of selected registers to be monitored.
Name Value Address The state of these registers change
TRISC 265 0x0087 during the program execution, which can
= givald-nknl) [ porTc [ (D ox0007 be viewed in this window
* TRISC
. - PORTC = Ox00;
Sk w Double click on the Value field enables
. . PORTC = OxFF: you to change data format
» . Delay ms{1000):
. PORTC = 0x00: . o PC= 0x000003
s = bel (1000) 2 13 ¢ . .
. 3 .,M::;T:; P NuAlass Topm The Watch Values window showing the state of the
. ’ microcontroller’s registers and program variables
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3.0. Practical Example of Using mikrolCD

Here is a step-by-step illustration of the operation of the mikrolCD:

Step 1: Writing the Program and Setting up the Project for ICD Debugging

void main() {

} while(1);

TRISC = 0x00;
PORTC = 0x00;
do {

PORTC = OxFF;
Delay ms (1000);

PORTC = 0x00;
Delay ms (1000);

/7
/7

/7

/7

/7
/7

/* Here 1is a simple program to demonstrate the operation of the microcontroller.
pins are configured as digital outputs and their logic state changes once per second. Establishing
connection between such port and LEDs will cause LEDs to blink simultaneously */

Configure PORTC pins as outputs

Turn OFF LEDs on PORTC

Turn ON LEDs on PORTC
1 second delay

Turn OFF LEDs on PORTC
1 second delay
Endless loop

! Program Example '_

The PORTC port’s

When the program has been written, it is necessary to select the appropriate debugging mode before it is compiled into the HEX code, in
order to perform debugging using the mikrolCD debugger.

Build Type

) Release (% ICD Debug
Debugaer

() Software () mikrolCD

First, to debug program, select the ICD Debug option from the Project Settings window.

Then, select the mikrolCD option to enable the mikrolCD debugger to be used for debugging.
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Step 2: Compiling the Program and Dumping It into the Microcontroller

In order to compile the program into the HEX code and automatically dump it into the microcontroller, select the Build+program option
[Ctrl+F11] from the Project drop-down menu.

Run Tools Help

Build

‘% Build + Program

o View Assembly
iew Statistics

Yiew Listing

Egt Search Paths...
Clegn Project Folder...
Add Ele To Profec...
Remove Fle From Project
uv;pmom,.. C am
1Y MewPropect..  ShEHCUHN
% OpenProject.. Shift+Quho
¥ EdtPropct..  ShteCrHE
% Open Projed Growp...

S Chose Project Grouwp

Save Project As...
-Bﬂf-ﬂlﬁ-uwﬁ‘;

Clase Praject

20080930:

initial release;

Des
This 35 & simple 'Mello World' project.
PORTA, PORTS, PORTC and PORTD.

Test configuration:
Moy

iption:

It turns on/off LEDs connect

v1.miccochip, downloads/en/DeviceDoc/412
Dev.Board:
BEEp: /S ., . com/an/ tools/ easypics/
Oscillator: BE, 08.0000
Ext, Modules: -
SW: »C PRO for PI
S wwwr. mikroe /en/compilers/mikroc/pro/
NOTES:

- Turn ON the PORT LEDs at SWé. (board specific)

Immediately after completing the compiling process, the PICflash programmer’s window will appear on the screen. In the right bottom corner
thereof, there is the Progress bar showing the programming progress. If the Tools > Options > Tools > PICflash Options > Close when finished
option is ticked off the PIC flash programmer’s window will be automatically closed after programming.

PicFLASH [v7.13] with mikrolCD

Device:
Configuration Bits [
e . PICIEFEET
ey IS I o Nooe s
Watchdag Timer  Cisabled > 0000k - 1FFFh { A1) = + .
- Masibpod oo Bdanis
Pawer Up Timer  Duabled =, - el - ]
Master Clear  Enabled - Write Enable i | St |
Daka EE Protect  Deabied x @ ‘Write protection Off HEX P Options
Brown Dut Detect 500 Enabled - 0000k - 0OFFh Probected i =
Int-Ext Switchover  Erabled - 0000k - O7FFh Protected | |
000Ch - OFFFh Protected
Fail-safe Clic. Monitor  Ersbled - [ SRR
[o— Aeosdnin |
Low Voltage Program  [esbied - h
Tn-ChEN Dk S = ¥ Calbration word Protect ¢ CODE
Cal Word
Brown-out Reset Sel.  set o 4.0v b Lty
10 Locations | i
IFFF 3FFF IFFF IFFF Clear r
l_ arprlaGie J
Program Memory Size: B K Device Status: Programming CODE Memory Tvpe PICIGFBE7 Progress:
DATA Sze: 266 Bytes Address: DBBOK Revision 2 T L.
ORPIC\ERAM VELOPMENT SYSTEMSIEA INKINGREDSLING. | g
Operation: Pragramming.. Press <ESC>toAbortOperation..  HW: PICFLASH prog vE7.68.0L00 PICflash programmer’s main window
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Step 3: Starting up mikrolCD and Line-by-Line Program Execution

When the program is loaded into the microcontroller, its execution in real time can be monitored by using the mikrolCD debugger. To start
it up, select the Start Debugger option from the Run drop-down menu or click the [F9] button.

- C:\Program Files\Mikroelektrd

shift+F4

Shift4F5

Osc.

Ext.

e

7 Board:

ns\EasyP IC5W ed Blinking\Le dBlinkil

Bi%2% & Ram 20AES
G | Whidbey w| | Debuglayout

name:
linking (Simple °"Hello World' project)
ht:

1kroelektronika, 2008,

n History:

830:

nitial release;

simple *Hello World' project. It turns on/off LEDs
. PORTB, PORTC amd PORTD.

nfiguration:

PICI16F8aT

wl, microchip. &

dowril cads/ en/DeviceDoc/

hetp://www. mikroe. com/en
lator: HS, 08.0000 MHz
Modules: -

ik DDA #an DTS

Now, the program within the microcontroller will be executed line by line by pressing the [F8] button.

During program execution, the program line to be
next executed is highlighted in blue by default

~ * NOTES:

= Turn ON the PORT LEDs at SWé. (board specific)

- Blveid main{) {

27 TRISC = : set PORTC e o
L . PORTC = 0x00: // Turn OFF LEDs on PORTC
WwE do |
- . PORTC = OxFF: // Turn ON LEDs on PORTC
. Delay_ms(1000) ; // 1 second delay
. PORTC = Ox00: // Tucn OFF LEDs on PORTC
- - Delay_ms(1000) ; // 1 second delay
. } while(1): // Endless loop
- H]

Only two registers are selected here to be
monitored. Use the Add All option to add all
registers within the microcontroller to the list of
selected registers to be monitored.

Watch Values

o0 Sy 00 ol | @ [
e add W Remove < Properties g Add Al
Select vanisble from list:
[RORLS. " ¥
Search for variable by assembly name:
[¥] Peripherals Freeze
| Name Value Address
TRISC 255 ec0087
PORTC o ba0007
PC= 0000003
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execution.
In this example, the first instruction is executed using the Step Over option. In higher programming languages such option executes the
whole program line regardless of how many assembly instructions it consists of.

- BEvoid main() |

TRISC = Ox00;

28 F C o
0 & do ({
. PORTC = OxFF:

. Delay_ms (1000) ;

. PORTC = 0Ox00;
- Delay ms (1000} ;
. ) while(1):

// Turn ON LEDs

on PORTC
1 second delay

OFF LEDs on PORTC
/ 1 second delay

Turn

Encless loop

Step Over
Command

The Watch Values window enables you to monitor the state of selected registers and to view how their states change during program

90 % 0 oI
d add W Remove ) Pre
Select varable from list:
PORTC v
Search _lot watisble by assmbly name:
Peripherals Freeze
.N-ame Yalue —— Address
TRISC 0 0x0087
PORTC 0 \ 0x0007
| PC= 0x000006

The most recent state of registers is highlighted in red

By executing the same instruction (Step Over [F8]) two more times, the 32nd program line which contains the Delay_ms(1000) command
will be reached. To perform its execution, it is advisable to use the Run to Cursor [F4] option as it executes the program at full speed.

- BElvoid main()

TRISC = Ox00;
PORTC = 0Ox00;

do {

PORTC = 0Ox=00;
Delay_ms (1000} ;
) while(1):

set PORTC pins to be outputs
Turn OFF LEDs on PORTC

Turn OFF LEDs on PORTC

1 second delay

' Endless loop

The Run to Cursor command will cause the program to
be executed at full speed until it encountes the program
line with cursor placed.

E 5y 00 ® 00 o] | @
o Add ¥ Remove O g Addall
Select varable from list:
PORTC v
Search for variable by assembly name:
Peripherals Freeze
.N-ame Yalue —— Address
TRISC 1] 0x0087
PORTC 255 0x0007
|| PC= (000004

Run to Cursor
Command
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4.0. mikrolCD Debugger Options for Advanced Users

The following text describes the advanced options offered by the mikrolCD debugger.

Real-Time Debugging

The Step Into [F7]and Step Over [F8] commands enable the program to be executed line by line. Program execution is a slow process in this
case, and as such, is suitable for short programs. Unlike them, the Run/Pause Debugger [F6] and Run To Cursor [F4] commands enable
the program to be executed in real time and therefore be much faster. The speed of program execution depends on the microcontroller’s
own clock. By pressing [F6] or selecting the Run/Pause Debugger option, the mikrolCD is temporarily halted and the microcontroller
executes the loaded program at full speed. Another pressure on the same button reactivates the mikro/CD and the program execution
stops at reached location. By pressing [F4], the microcontroller will proceed with program execution at high speed until it reaches the line
selected by the cursor.

- Hvoid main() {

[F7]
[F4] [F8]

31 TRISC = 0x00; '/ set PORTC pins to b
C 32 PORTC = 0Ox00; // Turn OFF LEDs on PO
C 33
E:: 34 30 B do {

35 I PORTC = DXFF: .

g | Delay ms({1000); 1 second delay

. PORTC = 0Ox00; // Turn OFF LEDs on PO
Delay_ms (1000); // 1 second delay

- } while(1): // Endless loop

Breakpoints

The mikrolCD enables each program line to be marked with a breakpoint. The breakpoint is an intentional stopping or pausing place in the
program used for the purpose of debugging. Breakpoints are placed in the program by clicking the space to the left of the program line or
by pressing [F5]. By selecting the Run command [F6], the microcontroller will execute the program from the current location (highlighted
in blue) until it reaches a breakpoint (highlighted in red). The debugger halts after reaching the breakpoint.

There are two kinds of breakpoints - hardware and software breakpoints. The only visible difference between them is in the speed of
program execution before it reaches the specified program line. Hardware breakpoints are placed within the microcontroller chip and
provide considerably faster program execution. The number of hardware breakpoints is limited, whereas the total number of software
breakpoints is unlimited. For example, 16-bit PIC microcontrollers have only one, whereas 18-bit PIC microcontrollers have up to 3
hardware breakpoints. When all hardware breakpoints are used, then remaining breakpoints in the program will be used as software
breakpoints.

: o T
] et B[ oo % 00 o1 | @
. caoM bt = 0: a4 B PP —
Swlect varuable ke bt
. Lod_Init i)y Tazs -
Sawch hon wanabie by assembie name:
. Led_Cr{_LED_CLEAR] ¢ TRISE
L4 CURSOR_OFF) 1 I Paichoni Fresin
Nesa Vakoe Aaden
PORTH 140 06,
e ] s
A o ol
TaEs “ o
. B fer(s iee) o Fpem—

Led_Cnd (_LCD_SHIFT_RIGHT) ;
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a mikroICD Debugger

Watch Window Option

The Watch Window option allows you to monitor the values of program variables as well as the contents of SFRs while the program is
running. As soon as the program is loaded into the microcontroller, the Watch Values window appears on the screen. To reopen this
window, when removed, select the option View > Debug Windows > Watch Window.

) for PICAExamples\Develop

B TE R i 4 = PRPR ALD » &

1 m | DebugWindows V| il Ereakponts bl TG
o project ] Boume st Cuber |46 Bhakeh Weelom iy |
Sgalev v Propct Settings BAM Window

. T8 CodeExphorer @ Yew Sopmatch

o Progect Marsger  Shift+Cirl4F1L EEPROM Windowr

CODE Window
=0t Library Manager . .
Rockinarks Watch Window option

Value: |« Hessages Led_Init():

= Budd/ T it Led_Cmd (_LED_CLEAR]

BTy B Wndows Led_Cmd (_LCD_CURSOR_OFF)

: - * Led_Out (1, 6,txtd)

The Watch Values window displays data in three columns: register or variable names, their (ISR
values and memory addresses. Double click on any variable opens the Edit Value window

which allows you to assign it a new value. It is also possible to change data format (decimal, e —
hexadecimal, binary, floating or character) in this window. Obec ®Hx  Obn OFkst  Othar
Dot -

Edit Value window

Step Into [F7] Step Over [F8] Run to Cursor [F4]

Toggle Breakpoint [F5]

Show/Hide Breakpoints Shift + [F4]

Stop Debugger. Step Out [Ctri+F8]

Run/Pause Debugger-

atch Vaiues 3]
Start Debugger 3 g Clear Breakpoints Shift +Ctrl + F5]
4 Add All &z Remove All
Add selected variable b
to the list - (—Remove all variables from the list
Periphetals Freeze [[] Advanced Breakpoints.
Remove selected I S ———
variable from the list Name Yalue Address LAdd all variables to the list
LATE 7 Ox0F8D ~
OSCTUNE (i} Ox0F9E
PIEL 0 0x0F%0
FiRs g OAYH —Advanced Breakpoints option
1PR1 255 0x0F9F
PIEZ 0 0x0FAD
PIRZ o OxOFAL
IPRZ 223 Ox0FAZ
Selected variable | Eeconi  Jed (o veorms Change format of the selected variable
EECONZ 0 OxOFAT &
|pc= 0000076 cyce=0.00
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Advanced Breakpoints Option

The mikrolCD provides the means for using the Advanced Breakpoints option with PIC18 and PIC18FJ microcontrollers. To enable it, tick
the Advanced Breakpoints checkbox within the Watch Values window. To configure the Advanced Breakpoints option it is necessary to
start up mikrolCD [F9] and select the View » Debug Windows » Advanced Breakpoints option or to use the [Ctrl+Shift+A] shortcut icon.

Enhanced Breakpoints Page

Breakpoint #1

[“Irrogram Memory Break

File Register Break
Address
Qoo

(*)Read Access
() Write Access

[]File Register Equal

Passcount |1

Breakpoint #2 Breakpoint #3
["]Program Memory Break []Program Memory Break
File Register Break File Reqister Break
Address (%) Read Access Address (5) Read Access
040 () Write Access 000 ) Write Access
[CJFile Register Equal [IFile Register Equal

Passcount 1 Passcount |1

OK

| | concel | [ aeny

X

Program Memory Break Option

The Program Memory Break option is used for placing breakpoints at specified addresses in the program memory. The value entered in

the Address field must be in the .hex format.

File Register Break Option

The File Register Break option is used for stopping code execution when read/write access to the specified data memory location occurs.
If the Read Access option is selected, the File Register Equal option can be used for setting the appropriate value in the Value field. The
program execution will be stopped when the value read from the specified data memory location matches the value written in the Value
field. All the values entered in the Value field must be in the .hex format.

When the Advanced Breakpoints option is enabled, mikrolCD operates in real-time mode, thus supporting only the following set of
commands: Start Debugger [F9], Run/Pause Debugger [F6] and Stop Debugger [Ctrl+F2]. After reaching the first breakpoint, the Advanced
Breakpoints option can be disabled and the process of debugging can be continued with a full set of commands. The number of advanced
breakpoints is equal to the number of hardware breakpoints and depends on the microcontroller in use.
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View Assembly Option

During the process of compiling, each program line written in a high-level programming language is replaced with one or more assembly
instructions. To display program in the assembly language, select the View Assembly option from the Project drop-down menu. In this case,
the process of simulating and debugging is performed in the same way as if the program is written in a high-level programming language.

Program written
in the high level
programming
language...

SRUTHHHTTTTRER

[ Ty P

...the same program compiled in the assembly language

EEPROM Watch Window

The EEPROM Watch window will appear by selecting the View » Debug Windows > EEPROM Window option. It shows the values
currently stored in the PIC internal EEPROM memory.

LEPROM Watch )
Read EEPROM rize M

UJIOI Iﬂllﬂlcﬁ %IIITIHIW]MIWIKICDICGIEFI‘ I"
Coo| 00 00 00 \O0O 00 00 0 00 0 O 00 00 00 00 - ocorersraracans
m W w0 0w W oW 0 00 o 0 00 00 0 0 cicececens
wolw w0 w w w w @ 00 00 @ 0 e Pressing the Write EEPROM button causes data from
o0 0 © 0 o oo © . % the EEPROM Watch window to be loaded into internal
237 Pl Mol Bl B Bl £l ol et - 8 EEPROM memory of the microcontroller.
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; w w o o0 oo w w o L) o o o m .
E o 00 00 00 00 © 00 00 (] 00 00 00 0 @ .
; o 00 00 00 00 0 00 00 00\ 00 00 00 00 o0
E o 00 00 00 00 00 00 00 00 00 00 00 00 00 00
E o 00 00 00 00 0O 00 00 00 00 00 00 00 00 00
B R e B B BRI Q R Rad Pressing the Read EEPROM button causes the
ooco| oo wm L] oo oo w o oo o0 o L) oW o0 o w
77 R ) IOV e oy o [Py ) oy e IO e e ey ey contents of the EEPROM memory to be read and
o] 0 o o o o o o 0 m w ® @ o m oo m shown in the EEPROM Watch window.
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ﬁ o0 00 00 0 00 0 00 00 0 0 ™ 00 0w MW W oW P

EEPROM Watch window
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RAM Window

The mikrolCD allows you to view the contents of the microcontroller’'s RAM memory in the RAM window by clicking the View > Debug
Windows > RAM Window option. Unlike the Watch Window option, all memory locations are displayed in a table. The content of each
RAM location is displayed in the hexadecimal format and may be changed at any time during the operation of the microcontroller. Changed
values are directly written into the microcontroller by clicking Enter.

One Wire\DneWire

Frequet v Quick Converter CuhQ C10M bit = O: Disable compacators
| v o CZON_bit = Oz
Shup  Maeroldter Led_Inie():
Buld Ty (@ Windows Led_Cmd (_LCD_CLEAR) :
B (sgen Led_Cmd(_LCD_CURSOR_OFF) :
Deb ® 103 at (1 1, "

/ Priat degree character,

Led Chr2,13,223):2

- - £
etter try typing 178 :nn:' 3
L Led _Chr(2,14,'C');
110 ff-—= main loop RAN
AN [ £ Y Y Y Y Y EA Y EY EY Y A EY
Ou_Reset (§PORTE, 2): 0000| OO FF | 99 1E FF 00 | OC 00 OO OO OO ©2 OO OO0 20 OO
| owesewronmm 2 0 ool oo 00 00 EF w0 FF R 0 0 0 ® F F 0 0 ®
0020] 20 54 |65 60 70 66 |72 6 | M V5 72 65 3 20 20 20
O_WT 00 32 30 |30 30 X 30 W0 30 0 00 09 B B/ 9 K
m b BF F3 AD 78 23 JF Db S0 E3 70 OC DB BS 60 E7
E A7 X ¥ F! CA B Db EF | F5 A Fl1 C7 CF 47 3 5SE
E A6 SB | BF BF DB |DF E4 F7 6D DF 8 | AC SE FD | IF D7
E & (FF EF |97 SF FD OC AF |53 | C4 [EF (FC (00 00 | 73 O
E 00 | FF | 9% |IE | FF |FF | 40 (FF | FF | OF |00 | 02 (OO0 | 00 |10 | 6C
E 0 00 FF 00 00 FF OO 00 O2 00 00 OO OO Ol OO OO
;llr EA 87 (CF |75 FEF |30 A F5 DB DB BB  E7 F E7 BB B7
E DB FF 95 AF 49 FC DD  G&F 17 |8 Dl |53 F2 D7 BE FF
E ED BE 3 E7 7 | C7 DE DF D4 B4 EO SF O A7 P FD 4
< >
RAM window
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Here is a list of the most frequently used mikro/CD options:

Name Description Function key
Start Debugger Start up debugger [F9]
Run/Pause
Debugger Run or pause debugger [F6]
Stop Debugger Stop debugger [Ctrl+F2]

Execute the current program line, then halts. If the program line executed
Step Into calls another routine, the debugger steps into the routine and halts after [F7]
executing the first instruction within it.
Execute the current program line, then halts. If the program line executed
Step Over calls another routine, the debugger will not step into it. The whole routine [F8]
P will be executed and the debugger halts at the first instruction following the
call.
Execute all remaining program lines within the subroutine. The debugger
halts immediately upon exiting the subroutine. This option is provided with
Step Out the PIC18 microcontroller family, but not with the PIC16 microcontroller [Ctri+F8]
family.
Run To Cursor Execute the program until reaching the cursor position. [F4]
Toadle During the process of debugging, the program executes until reaching a
ggle breakpoint. The Toogle Breakpoints option sets new breakpoints or [F5]
Breakpoint S
removes those already set at the current cursor position.
Show/Hide To view all the breakpoints in the program, select the Show/Hide
Breakpoints Breakpoints option from the Run drop-down menu or use the Shift +F4 [Shift+F4]

P shortcut. Double click a breakpoint from the list to locate it.

Clear Breakpoints | Clear all breakpoints from the program. [Ctrl+Shift+F5]

MikroElektronika




DISCLAIMER

All the products owned by MikroElektronika are protected by copyright law and international copyright treaty.
Therefore, this manual is to be treated as any other copyright material. No part of this manual, including product
and software described herein, may be reproduced, stored in a retrieval system, translated or transmitted in
any form or by any means, without the prior written permission of MikroElektronika. The manual PDF edition
can be printed for private or local use, but not for distribution. Any modification of this manual is prohibited.

MikroElektronika provides this manual ‘as is’ without warranty of any kind, either expressed or implied,
including, but not limited to, the implied warranties or conditions of merchantability or fithess for a particular
purpose.

MikroElektronika shall assume no responsibility or liability for any errors, omissions and inaccuracies that may
appear in this manual. In no event shall MikroElektronika, its directors, officers, employees or distributors be
liable for any indirect, specific, incidental or consequential damages (including damages for loss of business
profits and business information, business interruption or any other pecuniary loss) arising out of the use
of this manual or product, even if MikroElektronika has been advised of the possibility of such damages.
MikroElektronika reserves the right to change information contained in this manual at any time without prior
notice, if necessary.

HIGH RISK ACTIVITIES

The products of MikroElektronika are not fault—tolerant nor designed, manufactured or intended for use or
resale as on-line control equipment in hazardous environments requiring fail-safe performance, such as in
the operation of nuclear facilities, aircraft navigation or communication systems, air traffic control, direct life
support machines or weapon systems in which the failure of Software could lead directly to death, personal
injury or severe physical or environmental damage (“High Risk Activities”). MikroElektronika and its suppliers
specifically disclaim any expressed or implied warranty of fitness for High Risk Activities.

Copyright 2003 — 2009 by MikroElektronika. All rights reserved.
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