
 2009 Microchip Technology Inc. DS70605A

dsPICDEM™ MCHV
Development System

User’s Guide



Note the following details of the code protection feature on Microchip devices:

• Microchip products meet the specification contained in their particular Microchip Data Sheet.

• Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the 
intended manner and under normal conditions.

• There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our 
knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data 
Sheets. Most likely, the person doing so is engaged in theft of intellectual property.

• Microchip is willing to work with the customer who is concerned about the integrity of their code.

• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not 
mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our
products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts
allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.
Information contained in this publication regarding device
applications and the like is provided only for your convenience
and may be superseded by updates. It is your responsibility to
ensure that your application meets with your specifications.
MICROCHIP MAKES NO REPRESENTATIONS OR
WARRANTIES OF ANY KIND WHETHER EXPRESS OR
IMPLIED, WRITTEN OR ORAL, STATUTORY OR
OTHERWISE, RELATED TO THE INFORMATION,
INCLUDING BUT NOT LIMITED TO ITS CONDITION,
QUALITY, PERFORMANCE, MERCHANTABILITY OR
FITNESS FOR PURPOSE. Microchip disclaims all liability
arising from this information and its use. Use of Microchip
devices in life support and/or safety applications is entirely at
the buyer’s risk, and the buyer agrees to defend, indemnify and
hold harmless Microchip from any and all damages, claims,
suits, or expenses resulting from such use. No licenses are
conveyed, implicitly or otherwise, under any Microchip
intellectual property rights.
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Safety Notice
The safety notices and operating instructions provided should be adhered to, to 
avoid a safety hazard. If in any doubt, consult your supplier.

WARNING – This system must be earthed (grounded) at all times.

CAUTION – The system should not be installed, operated, serviced or modified 
except by qualified personnel who understand the danger of electric shock 
hazards and have read and understood the user instructions. Any service or 
modification performed by the user is done at the user’s own risk and voids all 
warranties.

WARNING – The output terminals are NOT isolated from the incoming AC mains 
supply and may be at up to 410V with respect to ground, regardless of the input 
mains supply voltage applied. These terminals are live during operation AND for 
five minutes after disconnection from the supply. Do not attempt to access the 
terminals or remove the cover during this time.

WARNING – The unit may obtain power through the output terminals if these are 
connected to a rotating motor acting as a generator. If this is the case, then the 
previous warning also applies (i.e., the output terminals are live when connected 
to the generator and for five minutes after the generator has been stopped). Note 
that this case can arise even when the unit has been disconnected from the 
incoming AC mains supply.

CAUTION – If a motor is connected to the output of this unit, the frame should be 
connected to the output protective ground terminal provided. Particular care 
should be taken to mechanically guard such a motor, bearing in mind that 
unexpected behavior is likely to result from the process of code development. 

CAUTION – For continued protection against the risk of fire, replace the fuse with 
one of the same type only (i.e., Fast Act Fuse 15A/250 V).
 2009 Microchip Technology Inc. DS70605A-page iii
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• The system is intended for evaluation and development purposes and 
should only be operated in a normal laboratory environment as defined by 
IEC 61010-1:2001. 

• Clean with a dry cloth only.

• Operate flat on a bench, do not move during operation and do not block the 
ventilation holes.

• The system should not be operated without all the supplied covers fully 
secured in place.

• The system should not be connected or operated if there is any apparent 
damage to the unit.

• The unit is designed to be connected to the AC mains supply via a standard 
non-locking plug. As the unit has no mains switch, this plug constitutes the 
means of disconnection from the supply and thus the user must have 
unobstructed access to this plug during operation. 
DS70605A-page iv  2009 Microchip Technology Inc.
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Preface
INTRODUCTION

This preface contains general information that will be useful to know before using the 
dsPICDEM™ Motor Control High-Voltage (MCHV) Development System. Topics 
discussed in this preface include:

• Document Layout
• Conventions Used in this Guide
• Warranty Registration
• Recommended Reading
• The Microchip Web Site
• Development Systems Customer Change Notification Service
• Customer Support
• Document Revision History

DOCUMENT LAYOUT

This user’s guide describes how to use the dsPICDEM™ MCHV Development System. 
The document is organized as follows:

• Chapter 1. “Introduction” – This chapter introduces the dsPICDEM™ MCHV 
Development System and provides a brief overview of its features.

• Chapter 2. “Getting Started” – This chapter provides information on getting 
started with the dsPICDEM™ MCHV Development System.

• Chapter 3. “Running the Demonstration” – This chapter describes the demon-
stration software that is preloaded on the dsPIC33F device that accompanies the 
dsPICDEM™ MCHV Development System.

• Chapter 4. “Hardware” – This chapter describes the hardware on the 
dsPICDEM™ MCHV Development System.

• Appendix A. “Board Layout and Schematics” – This appendix provides 
diagrams of the hardware layout, as well as schematic diagrams for the 
dsPICDEM™ MCHV Development System.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs and/
or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 
document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. 
Select the Help menu, and then Topics to open a list of available on-line help files.
 2009 Microchip Technology Inc. DS70605A-page 1
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description Represents Examples

Arial font:

Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

“Save project before build”

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK

A tab Click the Power tab

N‘Rnnnn A number in verilog format, 
where N is the total number of 
digits, R is the radix and n is a 
digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>

Courier New font:

Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 
any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly braces and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}

DS70605A-page 2  2009 Microchip Technology Inc.



Preface
WARRANTY REGISTRATION

Please complete the enclosed Warranty Registration Card and mail it promptly. 
Sending in the Warranty Registration Card entitles users to receive new product 
updates. Interim software releases are available at the Microchip web site.

RECOMMENDED READING

This user’s guide describes how to use the dsPICDEM™ MCHV Development System. 
The device-specific data sheets contain current information on programming the specific 
microcontroller or digital signal controller devices. Other useful documents are listed 
below. The following Microchip documents are available and recommended as 
supplemental reference resources:

MPLAB® IDE Simulator, Editor User’s Guide (DS51025)

This user’s guide is a comprehensive guide that describes installation and features of 
Microchip’s MPLAB Integrated Development Environment (IDE), as well as the editor 
and simulator functions in the MPLAB IDE environment.

Readme Files

For the latest information on using other tools, read the tool-specific Readme files in the
Readme subdirectory of the MPLAB IDE installation directory. The Readme files contain
updated information and known issues that may not be included in this user’s guide.

MPASM™ Assembler, MPLINK™ Object Linker, MPLIB™ Object Librarian User’s 
Guide (DS33014)

This user’s guide describes how to use the Microchip MPASM Assembler, the MPLINK 
Object Linker and the MPLIB Object Librarian.

dsPIC33FJ12MC202 PIM Information Sheet (DS70314)

This document provides device specific information for the dsPIC33FJ12MC202 PIM 
device. The dsPIC33FJ12MC202 is a high-performance 16-bit digital signal controller 
within a small 28-pin 6x6 mm QFN package.

dsPIC33FJ32MC204 PIM Information Sheet (DS70316)

This document provides device specific information for the dsPIC33FJ32MC204 PIM 
device. The dsPIC33FJ32MC204 is a high-performance 16-bit digital signal controller 
within a small 44-pin QFN package.

dsPIC33FJ128MC804 PIM Information Sheet (DS70326)

This document provides device specific information for the dsPIC33FJ128MC804 PIM 
device. The dsPIC33FJ128MC804 is a high-performance 16-bit digital signal controller 
within a small 44-pin QFN package.

dsPIC33FJ256MC710 PIM Information Sheet (DS70564)

This document provides device specific information for the dsPIC33FJ256MC710 PIM 
device. The dsPIC33FJ256MC710 is a high-performance 16-bit digital signal controller 
within a 100-pin TQFP package.

dsPIC33FJ12MC201/202 Data Sheet (DS70265)

This data sheet contains device specific information for the dsPIC33FJ12MC201/202 
Digital Signal Controller (DSC) Devices. The dsPIC33F devices contain extensive 
Digital Signal Processor (DSP) functionality with a high performance 16-bit 
microcontroller (MCU) architecture.

dsPIC33FJ32MC202/204 and dsPIC33FJ16MC304 Data Sheet (DS70283)

This data sheet provides device specific information for the dsPIC33FJ32MC202/204 
and dsPIC33FJ16MC304 motor control family of devices. 
 2009 Microchip Technology Inc. DS70605A-page 3
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dsPIC33FJ32MC302/304, dsPIC33FJ64MCX02/X04, and dsPIC33FJ128MCX02/
X04 Data Sheet (DS70291)

This data sheet contains device specific information for the dsPIC33FJ32MC302/304, 
dsPIC33FJ64MCX02/ X04, and dsPIC33FJ128MCX02/X04 motor control family of 
devices.

dsPIC33FJXXXMCX06/X08/X10 Data Sheet (DS70287)

This data sheet contains device specific information for the dsPIC33FJXXXMCX06/
X08/X10 motor control family of devices. 

To obtain any of these documents, visit the Microchip web site at www.microchip.com.

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This web 
site is used as a means to make files and information easily available to customers. 
Accessible by using your favorite Internet browser, the web site contains the following 
information:

• Product Support – Data sheets and errata, application notes and sample 
programs, design resources, user’s guides and hardware support documents, 
latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives

DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip’s customer notification service helps keep customers current on Microchip 
products. Subscribers will receive e-mail notification whenever there are changes, 
updates, revisions or errata related to a specified product family or development tool of 
interest.

To register, access the Microchip web site at www.microchip.com, click on Customer 
Change Notification and follow the registration instructions.

The Development Systems product group categories are:

• Compilers – The latest information on Microchip C compilers and other language 
tools. These include the MPLAB C18 and MPLAB C30 C compilers; MPASM™ 
and MPLAB ASM30 assemblers; MPLINK™ and MPLAB LINK30 object linkers; 
and MPLIB™ and MPLAB LIB30 object librarians.

• Emulators – The latest information on Microchip in-circuit emulators.This 
includes the MPLAB ICE 2000 and MPLAB ICE 4000.

• In-Circuit Debuggers – The latest information on the Microchip in-circuit 
debugger, MPLAB ICD 2.

• MPLAB® IDE – The latest information on Microchip MPLAB IDE, the Windows® 
Integrated Development Environment for development systems tools. This list is 
focused on the MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager 
and general editing and debugging features.

• Programmers – The latest information on Microchip programmers. These include 
the MPLAB PM3 and PRO MATE II device programmers and the PICSTART® 
Plus and PICkit™ 1 development programmers.
DS70605A-page 4  2009 Microchip Technology Inc.
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Preface
CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative

• Local Sales Office

• Field Application Engineer (FAE)

• Technical Support

Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://support.microchip.com

DOCUMENT REVISION HISTORY

Revision A (June 2009)

This is the initial released revision of this document.
 2009 Microchip Technology Inc. DS70605A-page 5
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Chapter 1.  Introduction
1.1 OVERVIEW

The Microchip dsPICDEM™ MCHV Development System is intended to aid the user in 
the rapid evaluation and development of a wide variety of motor control applications 
using a dsPIC® Digital Signal Controller (DSC). This development system is targeted 
to control Brushless DC (BLDC) motors, Permanent Magnet Synchronous Motors 
(PMSM), and AC Induction Motors (ACIM) in sensor or sensorless operation. 

This flexible and cost-effective tool can be configured in different ways for use with 
Microchip’s specialized Motor Control DSCs. The dsPICDEM™ MCHV Development 
System supports the dsPIC33F Motor Control device family, and offers a mounting 
option to connect either a 28-pin SOIC device or a generic 100-pin Plug-In Module 
(PIM). 

The system has a three-phase power module device that contains the motor inverter 
and the gate driver’s circuitry. The circuit drives a BLDC, PMSM, or ACIM motor using 
different control techniques without requiring any additional hardware. It also has 
Power Factor Correction (PFC) circuitry in order to provide a full set of tools used in 
motor control applications. Figure 1-1 provides a photograph of the dsPICDEM™ 
MCHV Development System. A block diagram that shows the main components of the 
system is provided in Figure 1-2.

The rated continuous output current from the inverter is 6.5A (RMS). This allows up to 
approximately 2 kVA output when running from a 208V to 230V single-phase input volt-
age in a maximum 30ºC (85ºF) ambient temperature environment. Therefore, the sys-
tem is ideally suited for running a standard 3-Phase Induction Motor of up to 1.4 kW 
(1.8 HP) rating or a slightly higher rated industrial servo-motor. The power module is 
capable of driving other types of motors and electrical loads that do not exceed the 
maximum power limit and are predominantly inductive. Furthermore, single-phase 
loads can be driven using one or two of the inverter outputs.

The unit is capable of operating from 90V up to a maximum of 265V. A more detailed 
explanation of power limitations is provided in Chapter 4. “Hardware”.

Note: It is recommended to carefully read the hardware section mentioned above 
before attempting to use the system.
 2009 Microchip Technology Inc. DS70605A-page 7
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FIGURE 1-1: dsPICDEM™ MCHV DEVELOPMENT SYSTEM
DS70605A-page 8  2009 Microchip Technology Inc.
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1.1.1 Features

The following are some of the key features of the dsPICDEM™ MCHV Development 
System.

Supported Devices:

• 28-pin to 100-pin dsPIC33FJXXXMC202 PIM (MA330014) with a dsPIC33F Motor 
Control device (U11) socket

• 44-pin to 100-pin dsPIC33FJXXXMCX04 PIM (MA330017 and MA330018) with a 
dsPIC33F Motor Control device (U11) socket

• 100-pin to 100-pin dsPIC33FJXXXMCX10 PIM (MA330013) with a dsPIC33F 
Motor Control device (U11) socket

• dsPIC33FJ12MC202 Motor Control device in a SOIC package (U12) footprint

Motor Control Interfaces:

• Three-phase inverter bridge with a power rating of 400V/6.5A (J17)

• Hall sensors/Quadrature Encoder Interface (QEI) for sensored motor control 
algorithms (J9)

• Phase voltage feedback for sensorless BLDC operation

• DC bus current sense resistor for single shunt vector control

• Phase current sense resistor for dual shunt vector control

• Overcurrent protection

Input/Output Control Switches:

- One isolated push button (S1)

- Isolated reset push button (RESET)

- Isolated 10 k potentiometer (POT1)

- LED indicator for PWM outputs

Isolated Communication Ports:

- UART communication via USB (J6)

- UART communication via RS-232 (J8)

Built-In Isolated Programmer/Debugger (J20):

- Starter Kit-type programmer/debugger (daughter card)

Power Supply Connectors:

- Power Tab Fast-On connectors (BP1 and BP2) for the power stage

- Auxiliary 24V power input connector (J15) for the dsPIC DSC device and 
low-power circuitry (non-populated)

- Auxiliary 15V and 3.3V regulators for regulating auxiliary power supply 
(non-populated)

Programming Connectors:

- ICSP™ connector for programming a dsPIC DSC device (J18), non-isolated

- ICSP connector for programming the PIC18LF2450 USB module to the UART 
Bridge (J1), isolated

- ICSP connector for programming the Starter Kit Programmer/Debugger 
(SKDE), isolated PIC18F67J50 (J4)
DS70605A-page 10  2009 Microchip Technology Inc.
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Power Factor Corrector:

- Maximum input voltage 90 VAC-265 VAC

- Current Feedback circuitry

- VAC input voltage sensing

- Zero-crossing detection

- DC bus sensing

- Overcurrent protection (The maximum power available is specified in 
Section 4.3 “Electrical Specifications”.)

Built-In Power Supplies:

- 15V power supply, maximum power available 11W

- 3.3V power supply, maximum power available 2W

Additional Protection Circuitry:

- 250 VAC/15A fuse

- In-rush current limiter

- EMI filter
 2009 Microchip Technology Inc. DS70605A-page 11



dsPICDEM™ MCHV Development System User’s Guide
NOTES:
DS70605A-page 12  2009 Microchip Technology Inc.
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Chapter 2.  Getting Started
2.1 BOARD COMPONENTS

The dsPICDEM™ MCHV Development System comprises two stages:

• PFC Stage

The first stage is integrated by the Power Factor Correction (PFC) circuitry, the 
full-bridge rectifier, the 15V power supply, and the 3.3V power supply.

• Power Module Stage

The second stage is the power module board. This board contains the dsPIC DSC 
connector, the isolated user interface connectors, and the motor drive.

Figure 2-1 shows an interior view of the system.

FIGURE 2-1: dsPICDEM™ MCHV DEVELOPMENT SYSTEM
 2009 Microchip Technology Inc. DS70605A-page 13
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2.2 USER INTERFACE

The dsPICDEM™ MCHV Development System has the following components to 
interact with the user. Figure 2-2 shows a photograph of the front of the system. 

• Input/Output Control Switches (Figure 2-2):

- One isolated push button (S1)

- Isolated reset push button (RESET)

- Isolated 10 kΩ potentiometer (POT1)

- LED indicator for PWM outputs

• PWM Outputs (Figure 2-2)

- Enable and disable jumpers (J7)

• Isolated Communication Ports (Figure 2-2):

- UART communication via USB (J6)

- UART communication via RS-232 (J8)

- Communication Ports Selector (J2, J3)

• Built-In Isolated Programmer/Debugger (Figure 2-2)

- Starter Kit type programmer/debugger (J20)

• Motor Connectors (Figure 2-3):

- Three-phase inverter bridge connector with a power rating of 400V/6.5A (J17)

- Hall sensors/Quadrature encoder interface for sensored motor control 
algorithms (J9)

• Power Supply Connector (Figure 2-4)

- AC power inlet specified for 40VAC-220VAC 10Amps max (J1)

FIGURE 2-2: dsPICDEM™ MCHV DEVELOPMENT SYSTEM (FRONT)

J8

J6
J20 S1

POT1

Reset
PWM LED
Indicators

J7

J2,J3
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Getting Started
FIGURE 2-3: dsPICDEM™ MCHV DEVELOPMENT SYSTEM (LEFT SIDE)

FIGURE 2-4: dsPICDEM™ MCHV DEVELOPMENT SYSTEM (RIGHT SIDE)

2.3 CONNECTING THE SYSTEM

2.3.1 Power Connections

It is recommended that cables used for the power connections should be terminated 
with blue or red insulated crimp terminals. If crimp terminals are not used, care should 
be taken to ensure that stray strands of wire do not short to adjacent terminals or the 
enclosure. If possible, all wires should be stripped and tinned with solder before 
connecting to the dsPICDEM™ MCHV Development System terminals.

CAUTION

The user must be aware of the operating procedures outlined below and ensure that 
they are followed. Failure to do so may result in damage to the system.

J1

3-Phase Inverter
Bridge Connector

Hall Sensors/
QEI Connector
 2009 Microchip Technology Inc. DS70605A-page 15



dsPICDEM™ MCHV Development System User’s Guide
For the AC mains supply input, standard double-insulated, 3-core flex cable should be 
used with a minimum current rating of 10A (1 mm2 18 AWG). A computer power cable 
can be used.

The recommended output cable size is 1.0 to 1.5 mm2 (18-16 AWG) and it should have 
a 600V rating. This cable should also be double insulated or have a protective ground 
screen. Access to the terminal screws is provided via holes in the lid of the enclosure. 
A slotted screwdriver should be used.

Figure 2-6 provides the locations of all connectors. Corresponding tables that describe 
each connection are provided in the relevant section.

FIGURE 2-5: dsPICDEM™ MCHV DEVELOPMENT SYSTEM CONNECTIONS

The power connections are listed in Table 2-1.

Note: The system is designed for installation category II. Therefore, the incoming 
mains cable should be wired into a standard non-locking 2-pin in addition 
with a earth ground type plug.

Note: The user should only access the power terminals when the system is fully 
discharged (see the “Safety Notice” on page iii).
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TABLE 2-1: POWER CONNECTIONS

2.3.2 Host/Communication Connections

A mini-USB-to-USB certified cable and a standard DB9 male-to-female cable should 
be used to connect the dsPICDEM™ MCHV Development System to the host 
computer.

The communication port connectors are listed in Table 2-2. Refer to Figure 2-5 for their 
exact location.

TABLE 2-2: COMMUNICATION PORT CONNECTORS

2.3.2.1 CONNECTION SEQUENCE

The recommended connection sequence is listed below. The user should ensure that 
the following sequence is met before connecting the system to the mains, a motor and 
a host computer.

1. Connect the motor terminals R, Y, and B (also known as RWB or 123 or ABC) to 
the connection nodes M1, M2, and M3 (4, 5, and 6 in Figure 2-5), respectively.

2. Follow the next steps if position sensors are utilized to control the motor. If not, 
proceed to step 3.

a) If the motor position is sensed with Hall Sensors, connect the terminals A, B, 
and C to the connection nodes HA, HB, and HC (7, 8, and 9 in Figure 2-5), 
respectively. Also, connect the positive terminal +5V to the connection node 
+5V and the ground terminal to the connection node GND (10 and 11 in 
Figure 2-5).

b) If the motor position is sensed with a Quadrature Encoder, connect the ter-
minals phase A, phase B, and Index to the connection nodes HA, HB, and 
HC (7, 8, and 9 in Figure 2-5), respectively.

Number Name Type

1 Neutral Input

2 Earth Ground Input

3 Live (Fused) Input

4 Motor Phase 1 (M1) Output

5 Motor Phase 2 (M2) Output

6 Motor Phase 3 (M3) Output

7 Hall Sensor A (HA) Input

8 Hall Sensor B (HB) Input

9 Hall Sensor C (HC) Input

10 Hall Sensors, 5V power supply terminal Output

11 Hall Sensors, Ground terminal Output

Number Name Type

12 USB-to-UART connector Input/Output

13 RS-23- to-UART connector Input/Output

14 USB connector for the Starter Kit programmer/debugger Input/Output

15 Non-isolated ICSP™ connector for device programming/debugging Input/Output

Note: Before making any connection, verify that the system is not powered and it 
is fully discharged. The system is completed discharged when the red LED 
D13 is OFF.
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3. Connect the communication ports. 

a) If R-S32 communication is used, connect the DB9 male connector to the 
RS-232 port. Connect the other end to the host PC (12 in Figure 2-5).

b) If USB communication is used, connect the mini-USB male terminal to the 
mini-USB female connector labeled “USB” (12 in Figure 2-5). Connect the 
other end to the host PC.

4. Connect the SKDE cable. Connect the USB cable to the mini USB female 
connector labeled “Program/Debug” (14 in Figure 2-5). Connect the USB male 
terminal to the USB ports of the host PC.

5. Power Cord connection. Make sure the power cord is disconnected from the AC 
mains before connecting the female terminal of the power cable to the AC input 
connector (1, 2, and 3 in Figure 2-53) of the dsPICDEM™ MCHV Development 
System.

Note: The Microchip serial emulator driver (mchpcdc.inf) should be installed on 
you PC in order to activate the USB-to-Serial emulator. The emulator driver 
is contained in the CD shipped with the dsPICDEM™ MCHV Development 
System.

Note: The built-in programmer/debugger is supported in MPLAB IDE 8.33 or 
higher.

Note: The unit is designed to be connected to the AC mains supply via a standard 
non-locking plug. As the unit has no mains switch, this plug constitutes the 
means of disconnection from the supply. Therefore, the user must have 
unobstructed access to this plug during operation.
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2.4 POWER SEQUENCES

The user should ensure that the following power sequences are adhered to.

2.4.1 Power-up Sequence

The unit is powered-up when the power cable is connected to the AC mains. To verify 
that the unit is powered make sure that the LEDs D6, D13, D17 and D18 are ON.

2.4.2 Power-down Sequence

1. Stop firing all power devices by removing the PWM OUTPUTS shunt jumper.

2. Turn OFF the incoming AC supply by disconnecting the power cord from the 
mains.

3. Wait until the red DC bus LED indicator (D13) located next to the DC bus P 
connector has gone out (this will take 5 minutes or less).

2.4.3 Programming/Debugging an Application Code Using the 
Built-in Starter Kit Programmer/Debugger

The MPLAB Starter Kit Programmer/Debugger for the dsPICDEM™ MCHV Develop-
ment System may be used with MPLAB IDE, the free integrated development environ-
ment, which is available from Microchip’s web site (www.microchip.com). MPLAB IDE 
allows the Starter Kit to be used as an in-circuit debugger as well as a programmer for 
the following devices.

• dsPIC33FJ12MC202
• dsPIC33FJ32MC204
• dsPIC33FJ128MC804
• dsPIC33FJ256MC710

In-circuit debugging allows you to run, examine and modify your program for the device 
embedded in the Starter Kit hardware. This greatly assists you in debugging your 
firmware and hardware together.

Special Starter Kit software interacts with the MPLAB IDE application to run, stop, and 
single-step through programs. Breakpoints can be set and the processor can be reset. 
Once the processor is stopped, the register’s contents can be examined and modified.

For more information on how to use MPLAB IDE, reference the following 
documentation:

• “MPLAB IDE User’s Guide” (DS51519)
• “MPLAB IDE Quick Start Guide” (DS51281)
• MPLAB IDE Online Help

2.4.4 Setting Up an Application for Debug

To prepare the application for debug:

1. Launch MPLAB IDE, and then open the application project. The related work-
space will be open. For information on projects and workspaces, see the MPLAB 
IDE documentation mentioned at the beginning of this chapter.

2. Select Project>Build All to build the application code. The build’s progress will be 
visible in the Build tab of the Output window.

Note: The unit is designed to be connected to the AC mains supply via a standard 
non-locking plug. As the unit has no mains switch, this plug constitutes the 
means of disconnection from the supply and thus the user must have 
unobstructed access to this plug during operation.
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3. Select Debugger>Select Tool>Starter Kits. MPLAB IDE will change to add Starter 
Kit debug features (Figure 2-6): (1) the status bar will show Starter Kits as the 
debug tool, (2) a Starter Kit debug toolbar will be added, (3) the Debugger menu 
will change to add Starter Kit debug functions and (4) the Output window will dis-
play communication status between MPLAB IDE and the stater kit on the Starter 
Kit Debugger tab.

FIGURE 2-6: STARTER KIT AS A DEBUG TOOL
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4. Select Debugger>Program to program the application code into the dsPIC33F 
DCS device on the Starter Kit. The debug programming progress will be visible 
in the Starter Kit tab of the Output window.

2.4.4.1 RUNNING THE APPLICATION

The Starter Kit executes in either real-time (Run) or steps (Step Into, Step Over, and 
Animate) real-time execution occurs when you select Run in MPLAB IDE. Once the 
device code is halted, either by Halt or a breakpoint, you can step. 

Toolbar buttons can be used for quick access to commonly used debug operations. 
Refer to Section 3.3 “Running the Example Application” in the “MPLAB Starter Kit 
for dsPIC® Digital Signal Controllers User’s Guide” (DS51700).

To see how these options function, do the following:

1. Select Debugger>Reset>Processor Reset or click the Reset button to reset the 
program.

2. Select Debugger>Run or click the Run button. Observe how the application 
operates.

3. Select Debugger>Halt or click the Halt button to stop the program execution. A 
green solid arrow will mark the line of code in the File window where the program 
halted.

4. Select Debugger>Step Into or click the Step Into button to step the program exe-
cution once. The green solid arrow will move down one line of code in the File 
window. Repeatedly click the button to step through the code.

5. Select Debugger>Reset>Processor Reset click the Reset button to reset the 
program again. The arrow will disappear, meaning the device is reset.

Note: Debug executive code is automatically programmed in the upper program 
memory of the Starter Kit device when the Starter Kit is selected as a 
debugger. Debug code must be programmed into the target device to use 
the in-circuit debugging capabilities of the Starter Kit.

Note: All the peripherals are frozen when the “Halt” button is pressed to stop the 
program execution.
 2009 Microchip Technology Inc. DS70605A-page 21



dsPICDEM™ MCHV Development System User’s Guide
2.4.4.2 DEBUGGING THE APPLICATION

MPLAB IDE provides an editor and several debug features such as breakpoints and 
Watch windows to aid in application code debugging.

2.4.4.2.1 Editing Application Code

To view application code so it may be edited, do one of the following:

Select Edit>New to create new code or Edit>Open to search for and open an existing 
code file, or double click a file in the Project window to open an existing code file. See 
an example Project window in Figure 2-7.

FIGURE 2-7: PROJECT EXAMPLE

For more information on using the MPLAB Editor to create and edit code, see the 
MPLAB Editor Help.

Existing Code
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2.4.4.2.2 Using Breakpoints and Mouseovers

To set a breakpoint in code:

1. Double click the gutter: Double click in the window gutter next to the line of code 
where you want the breakpoint. Double click again to remove the breakpoint.

2. Pop-up Menu: Place the cursor over the line of code where you want the break-
point. Then, right-click to pop up a menu and select Set Breakpoint. Once a 
breakpoint is set, “Set Breakpoint” will become “Remove Breakpoint” and “Dis-
able breakpoint”. Other options on the popup menu under Breakpoints are for 
deleting, enabling, or disabling all breakpoints.

3. Breakpoint Dialog: Open the Breakpoint dialog (Debugger>Breakpoints) to set, 
delete, enable, or disable breakpoints. See the MPLAB IDE Help for more 
information on this dialog.

A breakpoint set in code will appear as a red hexagon with a “B” as shown in Figure 2-8.

FIGURE 2-8: BREAKPOINT EXAMPLE

Note: Double click must be set up for breakpoints. Select the Edit>Properties, and 
click the ASM/C/BAS File Type tab, and then select the “Double-click Tog-
gles Breakpoint” check box.
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Once code is halted, hovering over a variables opens a tool tip window that contains 
the current value of the variable.

2.4.4.2.3 Using Watch Windows

To use a Watch window:

1. The Watch window is made visible on the desktop by selecting View>Watch. It 
contains four selectable Watch views (via tabs) in which to view variables (SFRs, 
symbols and absolute addresses).

2. Select an SFR or Symbol from the list and click the related Add button to add it 
to the Watch window. Or click in the “Address” column and enter an absolute 
address.

A Watch window populated with an SFRs and Symbols will look like Figure 2-9. For 
more on using Watch windows, see MPLAB IDE Help.

FIGURE 2-9: WATCH WINDOW EXAMPLE

2.4.5 Programming an Application

When the program is successfully debugged and running, the next step is to program 
the device for stand-alone operation in the finished design. When doing this, the 
resources reserved for debug are released for use by the application. To program the 
application, use the following steps: 

1. Disable Starter Kits as a debug tool by selecting Debugger>Select Tool>None.

2. Select Starter Kits as the programmer in the Programmer>Select Programmer 
menu.

3. Select Programmer>Program.

At this point, the application code will run independently.

Note: This feature must be configured. Select Edit>Properties and click the 
Tooltips tab, and select the “Enable Variable Mouseover Values” check 
box.
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2.4.6 Determining Device Support and Reserved Resources

Due to the built-in in-circuit debugging capability of ICD devices and the ICSP function 
offered by the debugger, the Starter Kit uses some on-chip resources when debugging. 
It also uses program memory and file register locations in the target device during 
debugging. These locations are not available for use by user code. In the MPLAB IDE, 
registers marked with an “R” in the register display represents reserved registers.

For information on device resources that are needed for in-circuit debugging, please 
refer to the MPLAB ICD 2 Help, found in MPLAB IDE under Help>Topics. The device 
reserved resource information found under “Resources Used By MPLAB ICD 2” is the 
same for the Starter Kit.

2.4.7 Troubleshooting

2.4.7.1 DEBUG CONNECTION PROBLEMS

While using the Starter Kit as a debugger, you may receive the error “Starter Kit not 
connected to this computer” when programming the device. This can result from 
communication being lost between the Starter Kit and MPLAB IDE. To resolve this:

1. Unplug the USB cable from the Starter Kit.

2. Plug the USB cable back into the Starter Kit.

MPLAB IDE should automatically reconnect to the Starter Kit. If this does not work, do 
the following:

1. Check the USB connection between the PC and Starter Kit at both ends.

2. If using a USB hub, make sure it is powered.

3. Make sure the USB port is not in use by another device.

2.4.7.2 PROGRAMMING PROBLEMS

If during the course of developing your own application you can no longer program the 
device on the Starter Kit, you may have set device configuration bits to code protect or 
some other state that prevents programming. To view the settings of the configuration 
bits, select Configure>Configuration bits.

2.4.8 Settings Dialog and Info Tab

When you select Debugger>Settings or Programmer Settings, you will open the Starter 
Kit Settings dialog.

Currently, there is only one tab (Info) on this dialog, which provides the following 
information:

• Firmware Version: The version of firmware on the Starter Kit board.

• Debug Exec Version: The version of the debug executive that is loaded into the 
dsPIC33F device program memory to enable debug operation.
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Chapter 3.  Running the Demonstration
This chapter describes the demonstration software that is preloaded on the dsPIC33F 
device. This  application software, which is based on application note AN984, demon-
strates how to use the dsPICDEM™ MCHV Development System for controlling an AC 
induction motor (ACIM). For more information on this application note please refer to 
the following Microchip web page: www.microchip.com/dscmotor

To run the demo, follow these basic steps:

1. Connect the system by connecting the AC Induction Motor to the motor 
connector. 

2. Power up the dsPICDEM™ MCHV Development System by connecting the 
power cord to the mains. To verify that the unit is powered, make sure that the 
LEDs D6, D13, D17, and D18 are ON. The very first time you connect the system 
to any host PC, you should briefly see a popup balloon in the system tray (lower 
right of desktop) that states (1) new hardware has been found, (2) drivers are 
being installed, and (3) new hardware is ready for use. If you do not see these 
messages and the Starter Kit does not work, try reconnecting the USB. If this 
does not work, see Section 2.4.7 “Troubleshooting”.

3. When powered up, the application will turn on the LEDs PWM1L1, PWM1L2 and 
PWM1L3.

To use the application, follow these steps:

a) Make sure the PWM OUTPUT shunt jumper is installed.

b) To start/stop the motor, press the switch labeled “PUSHBUTTON”.

c) To increase the motor speed, rotate the potentiometer labeled “POT” 
clockwise. To reduce the speed, rotate the potentiometer counterclockwise.

Note: Before making any connection, verify that the system is not powered and it 
is fully discharged. The system is completed discharged when the red LED 
D13 is off.

Note: The unit is designed to be connected to the AC mains supply via a standard 
non-locking plug. As the unit has no mains switch, this plug constitutes the 
means of disconnection from the supply. Therefore, the user must have 
unobstructed access to this plug during operation.
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Chapter 4.  Hardware
This chapter describes the hardware components of the dsPICDEM™ MCHV 
Development System.

Topics covered include:

• Power Factor Correction (PFC) Stage Board

• Power Module Stage

• Electrical Specifications

4.1 POWER FACTOR CORRECTION (PFC) STAGE BOARD

This board has two main functions; the first one is to provide the required power sup-
plies to the power module board stage. The second function is to create the power bus 
rail that will be used to energize the motor through the power module.

4.1.1 AC Supply Input 

The AC supply input stage of the board consists of the following components,:

• F1 –15A/250 VAC fast acting fuse (only replace with a part of the same rating)

• C1, C2 – Film capacitors to aid in the suppression of AC supply transients and to 
also provide a low impedance return path for any currents that flows from the 
power device tabs to the heat sink and enclosure due to capacitive coupling

• C3 – Film capacitor to aid in the suppression of AC supply transients.

• R1 – A metal oxide varistor located across the incoming supply lines to suppress 
high energy transients.

• L1 – 2.3 mH/15A Choke inductor for suppressing EMI

• C4 – Film capacitor to aid in the suppression of EMI

• C5, C6 – Film capacitors to aid in the suppression of AC supply transients and to 
also provide a low impedance return path for any currents that flow from the 
power device tabs to the heat sink and enclosure due to capacitive coupling

• R7 – A 1W high-voltage resistor, which acts to discharge C4

• R6 – A resistor with a negative temperature coefficient that acts to limit the surge 
of input current that would occur at initial application of power due to the dis-
charged DC bus capacitance. The initial nominal cold resistance is 1 Ohm, which 
reduces once current flows and the device heats up. 

• BR1 – A single-phase bridge rectifier to convert the incoming AC into DC suitable 
for input to the power conditioning stage.

Note: The circuits for the hardware described in this section are shown in 
Appendix A. “Board Layout and Schematics”.
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4.1.2 Active Power Factor Correction (PFC)

The active PFC circuit is essentially a simple boost chopper with the control aimed at 
shaping the input current to follow the incoming mains supply waveform. The purpose 
of the different parts of the circuit is described below.

• L6 – A high frequency axial inductor with a single layer winding on a ferrite core. 
This component is in series with the main inductor (L7) to reduce the effect of the 
self-capacitance of its winding. Without L6, significant high frequency (15 MHz) 
ringing of the inductor current occurs at every transistor turn-on, which would 
increase EMI and the PFC transistor switching loss.

• L7 – A power inductor with three stacked toroidal cores made from a 
powdered-iron material to limit the core loss while maintaining good energy 
storage density. The particular cores used are Magnetics 0077083A7. A simple 
multi-layer winding is used which results in moderate copper loss but significant 
self-capacitance. Sixty-six turns of 1.5 mm diameter enameled copper wire is 
used. The design offers a good compromise between cost, core loss and size for 
this application. The nominal inductance is 1 mH at 10A.

• Q2 – A 600V TO-247 IGBT. As the tab of the device is not isolated, a thermally 
conductive insulator is used. When closed, Q2 increase the energy stored in the 
inductor L7. When open, energy stored in the inductance is transferred to the DC 
bus capacitors (C30-C32). Energy is also drawn from the AC supply during this 
time. By appropriate control of the switches, the input current waveform can be 
profiled to obtain good power factor and low harmonic distortion.

• D12 – A 600V TO-247 diode optimized for use at high switching frequency. As the 
tab of the device is not isolated, a thermally conductive insulator is used.

• C28, R31, R32, R33, D11 – A “snubber” that acts to damp high frequency 
oscillations and limit the rate of change of voltage across Q2

• C30, C31, C32 – 470 µF/450V electrolytic capacitors which act as the main DC 
bus energy storage capacitors.

• R25, R26, C25, D8, Q1, R27, R28 – A lever shifter to boost the PWM signal com-
ing from the dsPIC DSC

• U19 – Microchip TC4421A gate drive IC. This contains a low resistance comple-
mentary push-pull MOSFET pair and input circuitry suitable for interfacing to a 
wide range of input voltages. It is an ideal choice for this application allowing up to 
10A of peak gate drive current to switch Q2 rapidly and therefore achieve low 
switching loss. It also has a small footprint allowing it to be located physically 
close to the transistors allowing a low inductance gate circuit layout.

• D9, C26, C27 – These components act to provide a dynamic level shifting circuit 
to U19 while Q2 switch. Inductance of the power tracking between the source of 
Q2 due to the physical board layout means there is a substantial transient voltage 
between the +15V supply point reference at R28 and the source of Q2. This 
simple low cost circuit allows the power supply of U19 to move transiently. 

• R75, R29 and D10 – These components control the current and voltage to turn on 
and turn off the IGBT. R29 controls the rising time and the di/dt when the IGBT is 
turned on. R29 in parallel with R75 control the falling time and the di/dt when the 
IGBT is turned off.

• The power factor corrector design is based on the application note AN1106, for 
more information on this application note please refer to one of the following 
Microchip Web sites: 

- www.microchip.com/smps

- www.microchip.com/dscmotor
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4.1.3 PFC Feedback Circuitry

In a DSC-based PFC, the relevant analog parameters and the control loops need to be 
redefined and discretized. This enables changeover from existing hardware to its digital 
counterpart easier and more logical.

The PFC is an AC-to-DC converter, which converts the AC input voltage to a DC volt-
age and maintains sinusoidal input current at a high input power factor. In a DSC-based 
PFC, three inputs signals are required to implement the current control.

The input rectifier (BR1) converts (shown in Section 4.1.1 “AC Supply Input ”) the 
alternating voltage at power frequency into unidirectional voltage. This rectified voltage 
is fed to the chopper circuit to produce a smooth and constant DC output voltage to the 
load. The chopper circuit is controlled by the PWM switching pulses generated by the 
dsPIC DSC device, based on three measured feedback signals:

• Rectified input voltage

• AC input voltage zero-crossing event

• Rectified input current

• DC bus voltage

The rectified input voltage is measured in two stages:

• Signal conditioning: R22, R23, R24, C24, and D7 convert and filter the AC input 
voltage waveform from 90-265 VAC to 0-3.3 VAC. D7 limit the maximum voltage 
to 3.3V. C24 along with R22, R23 form a low-pass filter. The circuit is shown in 
Appendix A.

• Amplification: the operational amplifier MCP6024 (U13B) amplifies the condi-
tioned AC input voltage; R45, R46, R47, R48, R49 and R51 set the gain. The 
MC6024 also shifts the conditioned AC input voltage to a 1.65V DC level. There-
fore, the voltage applied to the dsPIC DSC ADC channel varies within 0-3.3V. The 
offset is controlled by R50, R53, and R54. R39 and C39 filter out the 
high-frequency noise.

AC input voltage zero-crossing event is sensed using a voltage divider (R2-R5) and two 
opto-couplers (U1 and U2). The circuit is shown in Appendix A.

Rectified input current is measured using the shunt resistor R34 and the operational 
amplifier MCP6024 (U13A); R38, R39, R40, R41, R42 and R43 set the gain. R43 shifts 
the voltage present at the shunt resistor to a 1.65V DC level. Therefore, the voltage 
applied to the dsPIC DSC ADC channel varies within 0-3.3V. The offset is controlled by 
R43, R53, and R54. R44 and C37 filter out the high-frequency noise. The circuit is 
shown in Appendix A.

DC bus voltage, the DC bus voltage is sensed at the power module stage. Please refer 
to Section 4.2.4 “Feedback Circuitry”.

4.1.4 Power Supplies

The PFC stage board provides the 15 volts power supply required to fire the power 
module IGBTs. The 15 volts power supply is built using a low power off-line SMPS pri-
mary switcher. The switching frequency is fixed to 60 kHz, the feedback signal to the 
power supply is provided by and opto-coupler. The output voltage is regulated at 15V 
with a maximum output current of 0.750 A, the resultant maximum power is 11.25 W. 
The input voltage range for this power supply is from 90 VAC to 260 VAC.

The PFC stage board also provides the 3.3 volts to powering-up the dsPIC DSC, the 
isolation circuitry, the communication ports, the Starter Kit programmer, etc. It also gen-
erates the 3.3 volts for powering the analog circuits and the analog reference for the 
Analog-To-Digital converter.
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The 3.3 volts rail is created using a step-down regulator which is attached to the 15 
volts regulator. The maximum output current is 0.650 A, thus the resultant maximum 
power is 2.145 W.

The 3.3 volts rail required for the analog circuits such as the current feedback and the 
Analog-to-digital converter is generated by a decoupling circuitry attached to the 3.3 
volts regulator.

4.1.5 Fault Circuitry

Given the development nature of the system, robust independent FAULT protection is 
provided on the PFC Stage Board. Two different fault categories are used to indicate a 
FAULT to the dsPIC® DSC. 

DC Bus Overcurrent, this fault signal is generated when the maximum current limit of 
15A is reached. The comparison of the threshold value and the actual current is done 
by comparator U8. The threshold limit is set by R56 and R57. R69 is a shunt jumper 
resistor that can disconnect the overcurrent fault to the dsPIC DSC.

DC Bus Overvoltage, this fault signal is generated when the maximum voltage limit on 
the DC bus rails is reached. The threshold value is set to 432 V. The comparison of the 
threshold value and the actual DC bus voltage is done by comparator U7. The thresh-
old limit is set by R60, R61 and R62. R66 is a shun jumper resistor that can disconnect 
the overvoltage fault to the dsPIC DSC.

4.1.6 Board Connectors

The PFC stage board has four tab fast-on connectors, one AC inlet and one 14-pin 
keyed connector for attaching a flat cable.

For the AC mains supply input, standard double-insulated, 3-core flex cable should be 
used with a minimum current rating of 10A (1 mm2 18 AWG). A computer power cable 
can be used. The recommended cable size is 1.0 to 1.5 mm2 (18-16 AWG) and it 
should have a 600V rating. This cable should also be double insulated or have a 
protective ground screen.

The tab fast-on connectors AC_N and AC_L provides the connections to the bridge 
rectifier BR1. The recommended cable size is 16-18 AWG or 1.0 to 1.5mm2. It is also 
recommended that cables used for the power connections should be terminated with 
blue or red crimp terminals. If crimp terminals are not used, care should be taken to 
ensure that stray strands of wire do not short to adjacent terminals or the enclosure. If 
possible, all wires should be stripped and tinned with solder before connecting to the 
dsPICDEM MCHV development board terminals.

Note: Both comparators are open-drained and need an external pull-up resistor. 
Both circuits share this pull-up resistor creating an OR condition at the 
output.

Note 1: The system is designed for installation category II. Therefore, the 
incoming mains cable should be wired into a standard non-locking 2-pin 
in addition with an earth ground type plug.

2: The unit is designed to be connected to the AC mains supply via a 
standard non-locking plug. As the unit has no mains switch, this plug 
constitutes the means of disconnection from the supply. Therefore, the 
user must have unobstructed access to this plug during operation.
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The fast-in connectors PFC_OUT “+” and PFC_OUT “-” provide DC bus voltage to the 
Power Module Stage. The recommended cable size is 16-18 AWG or 1.0 to 1.5mm2. It 
is also recommended that cables used for the power connections should be terminated 
with blue or red crimp terminals. If crimp terminals are not used, care should be taken 
to ensure that stray strands of wire do not short to adjacent terminals or the enclosure. 
If possible, all wires should be stripped and tinned with solder before connecting to the 
dsPICDEM MCHV development board terminals.

The 14-pin keyed connector provides the signals and power supply rails from and to 
the Power Stage. These signals are shown in Table 4-1.

TABLE 4-1: 14-PIN KEYED CONNECTORS

4.2 POWER MODULE STAGE

This board has two main functions; the first is to control the motor using a dsPIC DSC 
and a Power Module and the associated feedback signals for each control algorithm. 
The second is to provide the safety means to interact with the user.

4.2.1 Plug-In Module Configuration

This section summarizes the resistor configuration required to connect the PIM pins to 
dsPIC DSC pins. The following PIMs can be configured on the dsPICDEM™ MCHV 
Development System:

• dsPIC33FJ256MC710 PIM (MA330013)

• dsPIC33FJ12MC202 PIM (MA330014)

• dsPIC33FJ32MC204 PIM (MA330017)

• dsPIC33FJ128MC804 PIM (MA330018)

Note: The user should only access the power terminals when the system is fully 
discharged (see the “Safety Notice” on page iii).

Number Name Type

1 3.3V, digital rail Output

2 Not Connected NC

3 3.3V, analog rail Output

4 AC input voltage feedback Output

5 Ground, analog rail Output

6 AC input current feedback Output

7 Fault (Overcurrent OR Overvoltage condition) Output

8 VAC zero crossing signal Output

9 Ground, digital rail Output

10 PWM signal for the PFC IGBT Input

11 Ground, digital rail Output

12 Not Connected NC

13 15V Output

14 Not Connected NC

Note: The circuits for the hardware described in this section are shown in 
Appendix A. “Board Layout and Schematics”.

Note: When using PIMs, make sure that the 28-pin SOIC dsPIC DSC is removed 
from the dsPICDEM™ MCHV Development System.
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Table 4-2, Table 4-3, and Table 4-4 describe the PIM configuration details.

TABLE 4-2: dsPIC33FJ12MC202 PIM CONFIGURATION DETAILS

PIM Pin 
Number

Labels on the 
dsPICDEM™ MCHV 

Development System

dsPIC33FJ12MC202
dsPIC33FJ32MC202
dsPIC33FJ64MC202

dsPIC33FJ128MC202
dsPIC33FJ32MC302
dsPIC33FJ64MC802

dsPIC33FJ128MC802

PIM Resistor 
Configuration

Pin 
Number

Pin Name

93 PWM1L1 23 PWM1L/RP15/CN11/RB15 R19

94 PWM1H1 22 PWM1H1/RP14/CN12/RB14 R18

98 PWM1L2 21 PWM1L2/RP13/CN13/RB13 R17

99 PWM1H2 20 PWM1H2/RP12/CN14/RB12 R16

100 PWM1L3 19 TMS/PWM1L3/RP11/CN15/RB11 R15

3 PWM1H3 18 TDI/PWM1H3/RP10/CN16/RB10 R12

71 PWM2L1 15 TDO/PWM2L1/SDA1/RP9/CN21/RB9 R14, Remove R13

18 FAULT 14 TCK/PWM2H1/SCL1/RP8/CN22/RB8 R11

19 PFC_FLT 15 TDO/PWM2L1/SDA1/RP9/CN21/RB9 Remove R13

26 PGC 9 PGEC3/SOSCO/T1CK/CN0/RA4 Not applicable

27 PGD 8 PGED3/SOSCI/RP4/CN1/RB4 Not applicable

63 OSI 6 OSCI/CLKI/CN30/RA2 Not applicable

64 OSO 7 OSCO/CLKO/CN29/RA3 Not applicable

25 IPFC 27 PGED2/AN0/VREF+/CN2/RA0 R24, Remove R27

24 VACZX_VAC_POT 28 PGEC2/AN1/VREF-/CN3/RA1 R25, Remove R26

35 VBUS 1 PGED1/AN2/RP0/CN4/RB0 R20, Remove R28

41 MONITOR_1 2 PGEC1/AN3/RP1/CN5/RB1 R21, Remove R31

42 MONITOR_2 3 AN4/RP2/CN6/RB2 R22, Remove R30

43 MONITOR_3 4 AN5/RP3/CN7/RB3 R23, Remove R29

— HA/QEA — Not connected Not applicable

— HB/QEB — Not connected Not applicable

— HC/INDX — Not connected Not applicable

— VA — Not connected Not applicable

— VB — Not connected Not applicable

— VC — Not connected Not applicable

— IA — Not connected Not applicable

— IB — Not connected Not applicable

— IBUS — Not connected Not applicable

— VAC — Not connected Not applicable

— POT — Not connected Not applicable

— VACZX — Not connected Not applicable

70 RX 70 INT0/RP7/CN23/RB7 R10, Remove R9

84 TX 84 ASCL1/RP6/CN24/RB6 R32, Remove R7 and R8

— USB_RX — Not connected Not applicable

— USB_TX — Not connected Not applicable

68 BTN ASDA1/RP5/CN27/RB5 R6, Remove R5 and R33
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TABLE 4-3: dsPIC33FJ32MC204 AND dsPIC33FJ128MC804 PIM CONFIGURATION DETAILS

PIM Pin 
Number

Labels on the 
dsPICDEM™ MCHV 

Development System

dsPIC33FJ32MC204
dsPIC33FJ64MC804

dsPIC33FJ128MC804 PIM Resistor 
Configuration

Pin 
Number

Pin Name

93 PWM1L1 15 PWM1L1/RP15/CN11/RB15 R11

94 PWM1H1 14 PWM1H1/RP14/CN12/RB14 R10

98 PWM1L2 11 PWM1L2/RP13/CN13/RB13 R9

99 PWM1H2 10 PWM1H2/RP12/CN14/RB12 R7

100 PWM1L3 9 PGEC2/PWM1L3/RP11/CN15/RB11 R8

3 PWM1H3 8 PGED2/PWM1H3/RP10/CN16/RB10 R6

78 PWM2L1 3 PWM2L1/RP23/CN17/RC7 R31

18 FAULT 44 SCL1/RP8/CN22/RB8 R4

19 PFC_FLT 1 SDA1/RP9/CN21/RB9 R1

26 PGC 42 PGEC3/ASCL1/RP6/CN24/RB6 Not applicable

27 PGD 41 PGED3/ASDA1/RP5/CN27/RB5 Not applicable

63 OSI 30 OSCI/CLKI/CN30/RA2 Not applicable

64 OSO 31 OSCO/CLKO/CN29/RA3 Not applicable

25 IPFC 19 AN0/VREF+/CN2/RA0 R12

24 VACZX_VAC_POT 20 AN1/VREF-/CN3/RA1 R13

35 VBUS 21 PGED1/AN2/C2IN-/RP0/CN4/RB0 R14

41 MONITOR_1 22 PGEC1/AN3/C2IN+/RP1/CN5/RB1 R22

42 MONITOR_2 23 AN4/RP2/CN6/RB2 R25

43 MONITOR_3 24 AN5/RP3/CN7/RB3 R21

72 HA/QEA 37 RP20/CN25/RC4 R29

76 HB/QEB 38 RP21/CN26/RC5 R30

77 HC/INDX 2 PWM2H1/RP22/CN18/RC6 R32

— VA — Not connected Not applicable

— VB — Not connected Not applicable

— VC — Not connected Not applicable

— IA — Not connected Not applicable

— IB — Not connected Not applicable

— IBUS — Not connected Not applicable

— VAC — Not connected Not applicable

— POT — Not connected Not applicable

— VACZX — Not connected Not applicable

70 RX 43 INT0/RP7/CN23/RB7 R3, Remove R26

84 TX 33 SOSCI/RP4/CN1/RB4 R20

— USB_RX — Not connected Not applicable

— USB_TX — Not connected Not applicable

68 BTN 4 RP24/CN20/RC8 R2, Remove R18
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TABLE 4-4: dsPIC33FJXXXMC710 PIM CONFIGURATION DETAILS

PIM Pin 
Number

Labels on the 
dsPICDEM™ MCHV 

Development System

dsPIC33FJ64MC710
dsPIC33FJ128MC710
dsPIC33FJ256MC710

PIM Resistor 
Configuration

Pin Number Pin Name

93 PWM1L1 93 PWM1L/RE0 Not applicable

94 PWM1H1 94 PWM1H/RE1 Not applicable

98 PWM1L2 98 PWM2L/RE2 Not applicable

99 PWM1H2 99 PWM2H/RE3 Not applicable

100 PWM1L3 100 PWM3L/RE4 Not applicable

3 PWM1H3 3 PWM3H/RE5 Not applicable

78 PWM2L1 78 OC4/RD3 Not applicable

18 FAULT 18 AN20/FLTA/INT1/RE8 Not applicable

19 PFC_FLT 19 AN21/FLTB/INT2/RE9 Not applicable

26 PGC 26 PGEC1/AN6/OFCA/RB6 Not applicable

27 PGD 27 PGED1//AN7/RB7 Not applicable

63 OSI 63 OSC1/CLKIN/RC12 Not applicable

64 OSO 64 OSC2/CLKO/RC15 Not applicable

25 IPFC 25 PGED3/AN0/CN2/RB0 Not applicable

24 VACZX_VAC_POT 24 PGEC3/AN1/CN3/RB1 Not applicable

35 Not applicable 35 AN11/RB11 Not applicable

23 VBUS 23 AN2/SS1/CN4/RB2 Not applicable

41 Not applicable 41 AN12/RB12 Not applicable

22 MONITOR_1 22 AN3/INDX/CN5/RB3 Not applicable

42 Not applicable 42 AN13/RB13 Not applicable

21 MONITOR_2 21 AN4/QEA/CN6/RB4 Not applicable

43 Not applicable 43 AN14/RB14 Not applicable

20 MONITOR_3 20 AN5/QEB/CN7/RB5 Not applicable

80 HA/QEA 80 IC6/CN19/RD13 Not applicable

47 HB/QEB 47 IC7/U1CTS/CN20/RD14 Not applicable

48 HC/INDX 48 IC8/U1RTS/CN21/RD15 Not applicable

— VA — Not connected Not applicable

— VB — Not connected Not applicable

— VC — Not connected Not applicable

— IA — Not connected Not applicable

— IB — Not connected Not applicable

— IBUS — Not connected Not applicable

— VAC — Not connected Not applicable

33 POT 33 AN9/RB9 Not applicable

79 VACZX 79 IC5/RD12 Not applicable

49 RX 49 U2RX/CN17/RF4 Not applicable

50 TX 50 U2TX/CN18/RF5 Not applicable

— USB_RX — Not connected Not applicable

— USB_TX — Not connected Not applicable

68 BTN 68 IC1/RD8 Not applicable
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4.2.2 Power Supplies

The system default configuration is to get the 15V, 3.3V and 3.3V analog rail voltages 
from the PFC stage board. However, it is also possible to use an external 24V power 
supply to generate these voltages.

U19, C70, C73, C71 and C74 regulate the voltage applied to the system via J15 (28V 
max). The output of the regulator is connected to the system through R109. The circuit 
is shown in Appendix A. “Board Layout and Schematics”.

U18, C67, R110, C68, D16, D15, L3, R111, R112 and C75 regulate the 15 volts to cre-
ate a 3.3V digital rail. This auxiliary 3.3V digital rail is applied to the system through 
R106. The circuit is shown in Appendix A. “Board Layout and Schematics”.

R114, R107, C69, and C72 form a decoupling circuit for generating a 3.3V rail for the 
analog circuitry such as the ADC reference and the current feedback reference. This 
auxiliary 3.3V analog rail is applied to the system through R108.

4.2.3 Power Module

The three-phase inverter is embedded in a power module (U16). This power module 
contains:

• 600V/30A 3-phase IGBT Inverter Bridge

• Gate driver circuitry for each IGBT

• Three Independent connections to the negative DC bus for current sensing

• Short-circuit protection circuitry

• Thermal Shutdown

• Gate Driver Power Supply Undervoltage protection

• Gate Driver Power Supply Overvoltage protection

• Single-grounded power supply

• Isolation of 2.5 kV per minute

• Maximum switching frequency: 20 kHz

The dsPIC DSC provides the PWM signals to this power module in order to turn on/off 
the IGBT, and therefore apply power to the motor phases. 

R95 sets the threshold limit for the overcurrent circuitry. If this voltage is greater than 
0.5 V (typical), a fault signal is asserted and the low-side IGTBs are turned off. R94 and 
C53 form a low-pass RC filter that filters out the frequencies above 88.4 kHz.

C56 sets the fault pulse duration, the value of C56 is given by the following equation: 
C56 = 18.3E-6 x 1.8E-3 seconds. Therefore, the fault pulse duration is 54 µs

The power module fault output pin (VFO) is open-collector configured. R50 pulls up the 
fault output to the analog 3.3V rail. R53 and C40 form a low-pass RC filter that filters 
out the frequencies above 53 kHz.

For more information about this power module please refer to the manufacturer’s data 
sheet. 

Note: It is the responsibility of the user to populate these components if an 
external power supply is used.

Note: It is the responsibility of the user to populate these components if an 
external power supply is used.

Note: It is the responsibility of the user to populate these components if an 
external power supply is used.
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4.2.4 Feedback Circuitry

The Power Module Stage provides three different methods to sense the motor position. 
These signals are also useful to determine the speed, the torque, current consumption 
and the applied voltage.

Hall Sensors, the hall sensors circuitry is designed to attach open-collector configured 
sensors. It has a pull-up resistor at the hall sensor inputs (R23, R24, and R25) and a 
voltage divider (R26-R29, R27-R30, R28-R31) in order to scale the input waveforms to 
the dsPIC DSC logic levels. C25-C27 and R26-R28 form a low-pass RC filter for each 
hall sensor signal.

Phase Voltage Feedback circuitry for each phase is compounded by a voltage divider, 
a current limiter and a low-pass RC filter. R79, R84 and R92 scale the phase M1 volt-
age in order to match the dsPIC DSC logic levels. R85 limits the current going to the 
ADC pin (< 6mA). C51, R79 and R84 form the low-pass filter. The phase M2 and M3 
has the exact same circuitry as shown in the schematic.

DC Bus Voltage Feedback is compounded by a voltage divider and a low-pass RC 
filter. R75, R76 and R81 scale the DC bus voltage in order to match the dsPIC DSC 
logic levels. C47, R75 and R76 form the low-pass filter.

Inverter Leg Shunt Resistor Feedback, a shunt resistor is located between the emit-
ter of the low side switches M1 and M2 and the “-DC bus”. A simple differential amplifier 
circuit is used as shown in Appendix A. The operation of the circuit used for the M1 
phase leg is described below:

The current is measured using the shunt resistor R86 and the operational amplifier 
MCP6024 (U13A); R32, R33, R34, R36, R37 and R38 set the gain. R38 shifts the volt-
age present at the shunt resistor to a 1.65V DC level. Hence the voltage applied to the 
dsPIC DSC ADC channel varies within 0-3.3V. The offset is controlled by R59, R60, 
R38 and U13D. R35 and C34 filter out the high-frequency noise.

The same topology is used for the phase M2.

DC Bus Current Feedback, a shunt resistor is located between the shunt resistors of 
side switches M1 and M2 and the “-DC bus”. A simple differential amplifier circuit is 
used as shown in the schematic. The operation of the circuit used for sensing the DC 
bus current is described as follows:

The current is sensed using the shunt resistor R95 and the operational amplifier 
MCP6024 (U13C); R51, R52 and R49 set the gain. R58 shifts the voltage present 
at the shunt resistor to a 1.65V DC level. Hence the voltage applied to the dsPIC 
DSC ADC channel varies within 0-3.3V. The offset is controlled by R59, R60, R58 
and U13D. R54 and C42 filter out the high-frequency noise.

Note: It is possible to select any of these feedback signals using jumpers J12, J13 
and J14, please refer to Section 4.2.8 “User Interfaces” for more 
information.
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4.2.5 Fault Circuitry

In addition to the fault signal generated by the power module, the system can also 
create a DC bus overcurrent fault.

DC Bus Overcurrent, this fault signal is generated when the maximum current limit of 
15A is reached. The comparison of the threshold value and the actual current is done 
by comparator U14. The threshold limit is set by R42 and R47. R69 is a shunt jumper 
resistor that can disconnect the overcurrent fault from the dsPIC DSC.

4.2.6 Isolation

The power supply used by the push buttons, communication ports, and the SKDE pro-
grammer/debugger is isolated from the power supply used by the power module or the 
dsPIC DSC. An isolated 3.3V rail is generated from the digital 3.3V rail using a 
DC-to-DC converter (U10). This converter provides galvanic isolation rated up to 
1000 VDC/1 second. 

4.2.7 Communication Ports

The power module stage board provides two methods for transmitting/receiving data to 
and from the system. Both communication methods are powered using the isolated 
3.3V rail.

UART-to-USB communication port is based on a PIC18LFJ2450 device with a serial 
emulator firmware. This device translates the USB signals to dsPIC DSC UART com-
patible signals. The firmware used for this serial emulator is enclosed in the CD shipped 
along with the unit. Isolation for the UART-to-USB communication port is provided by 
U25. 

UART-to-RS-232 communication port is based on a RS-232 transceiver (U9). This 
device translates the dsPIC DSC UART signals to UART compatible signals. Isolation 
for the UART-to-RS-232 communication port is provided by U25.

Shunt jumpers J2 and J3 select the communication port. Table 4-5 shows the possible 
configurations.

TABLE 4-5: COMMUNICATION PORT CONFIGURATION

Note: The comparator is open-drained and needs an external pull-up resistor. 
Both the power module output and the comparator output share this pull-up 
resistor creating an OR condition at the output.

Designator Position Description

J2 1-2 Connects UART receive line to RX.

2-3 Connects USB receive line to RX.

J3 1-2 Connects UART transmit line to TX.

2-3 Connects USB transmit line to TX.
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4.2.8 User Interfaces

There are two types of user interfaces, isolated and non-isolated:

• Isolated interfaces:

- Potentiometer labeled “POT” (R14)

- RESET push button 

- PUSH BUTTON (S1) 

- PWM OUTPUT enable shunt jumper (J7) 

- Communication Port Selection shunt jumper (J2 and J3)

- ICSP programmer/debugger connector for SKDE (J4)

- ICSP programmer/debugger connector for UART-to-USB converter (J1)

• Non-Isolated interfaces:

- 15V Power Supply LED (D17)

- 3.3V Power Supply LED (D18)

- PWM2L1, PWM1L1, PWM1H1, PWM1L2, PWM1H2, PWM1L3, PWM1H3 
LEDs

- USB communication LED (D1)

- USB cable connected LED (D3)

- SKDE USB cable connected LED (D21)

- SKDE Power On LED (D19)

- ICSP programmer/debugger connector for dsPIC DSC (J18)

- Feedback Selection Shunt Jumpers J11, J12, J13, and J14. 

Table 4-6 shows the multiple feedback signals that can be selected.

TABLE 4-6: MULTIPLE FEEDBACK SIGNALS

Designator Position Description

J11 1-2 Connects AC input voltage zero-crossing event to 
VACZX_VAC_POT

3-4 Connects AC input voltage to VACZX_VAC_POT

5-6 Connects the POT voltage to VACZX_VAC_POT

J12 1-2 Connects Phase M1 shunt current feedback to MONITOR_1

3-4 Connects Phase M1 voltage feedback to MONITOR_1

5-6 Connects Hall A/QEA sensor signal to MONITOR_1

J13 1-2 Connects Phase M2 shunt current feedback to MONITOR_2

3-4 Connects Phase M2 voltage feedback to MONITOR_2

5-6 Connects Hall B/QEB sensor signal to MONITOR_2

J14 1-2 Connects DC bus shunt current feedback to MONITOR_3

3-4 Connects Phase M3 voltage feedback to MONITOR_3

5-6 Connects Hall C/INDEX sensor signal to MONITOR_3

7-8 Connects the POT voltage to MONITOR_3
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4.2.9 Hardware for Programming and Debugging

The dsPICDEM™ MCHV Development System, with its built-in SKDE debugger/pro-
grammer, provides an all-in-one solution for debugging and programming applications 
using MPLAB IDE. The Starter Kit’s debugging/programming operations are controlled 
by a PIC18F67J50 MCU running at 48 MHz. The PIC18F67J50’s built-in USB engine 
provides the communications interface between the Starter Kit and the host PC.

Power to the Starter Kit is provided via the isolated 3.3V rail. Proper Starter Kit main 
system power is indicated by the green LED D19. The PIC18F67J50 MCU accom-
plishes debugging or programming of the target dsPIC33F by controlling the target’s 
MCLR, PGC1/EMUC1, and PGD1/EMUD1 signals. A Microchip 25LC010A serial 
EEPROM is used to store the Starter Kit’s serial number and debug control information. 
Isolation for the MCLR, PGC1/EMUC1, and PGD1/EMUD1 signals is provided by the 
digital isolators U22, U23, U1 and U3.

4.2.10 Board Connectors

Figure 4-1 provides the locations of the connectors. The Power Module Stage Board 
connectors are listed in Table 4-6.

FIGURE 4-1: POWER MODULE BOARD CONNECTORS
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TABLE 4-7: POWER MODULE STAGE BOARD CONNECTORS

The 14-pin keyed connector provides the signals and power supply rails from and to 
the Power Module Stage. These signals are shown in Table 4-8.

TABLE 4-8: 14-PIN KEYED CONNECTORS

Number Designator Type

1 Motor Phase 1 (M1) Output/Power

2 Motor Phase 2 (M2) Output/Power

3 Motor Phase 3 (M3) Output/Power

4 DC Bus “+” Input/Power

5 DC Bus “-” Input/Power

6 Hall Sensor A (HA) Input

7 Hall Sensor B (HB) Input

8 Hall Sensor C (HC) Input

9 Hall Sensors, 5V power supply terminal Output/Power

10 Hall Sensors, Ground terminal Output/Power

11 UART-to-USB connector Input/Output

12 UART-to-RS-232 connector Input/Output

13 USB connector for the Starter Kit Programmer/Debugger Input/Output

14 Isolated ICSP™ programmer/debugger connector for SKDE 
(J4)

Input/Output

15 Isolated ICSP programmer/debugger connector for 
UART-to-USB converter (J1)

Input/Output

16 ICSP programmer/debugger connector for dsPIC DSC (J18) Input/Output

17 14-pin keyed connector (J16) Input/Output/Power

Number Name Type

1 3.3V, digital rail Output

2 Not Connected NC

3 3.3V, analog rail Output

4 AC input voltage feedback Output

5 Ground, analog rail Output

6 AC input current feedback Output

7 Fault (Overcurrent or Overvoltage condition) Output

8 VAC zero crossing signal Output

9 Ground, digital rail Output

10 PWM signal for the PFC IGBT Input

11 Ground, digital rail Output

12 Not Connected NC

13 15V Output

14 Not Connected NC
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4.3 ELECTRICAL SPECIFICATIONS

The maximum power and current capability of the system is dictated by the allowable 
temperature rise of the different components. Establishing maximum limits is not simple 
given the host of different ways the user may use the system. The voltage and the 
nature of the electrical load used both affects the dissipation that occurs. In determining 
the allowable limits for the power semiconductors, the following assumptions have 
been made: 

• Heat sink is at 70°C (worst case)

• Thermal resistance of the insulating thermal pad is 3°C/W

TABLE 4-9: INVERTER ELECTRICAL SPECIFICATIONS

TABLE 4-10: PFC ELECTRICAL SPECIFICATIONS

Parameter Min Typ Max Units

DC Bus 40 310 400 VDC

Current 0.1 6.5(1) 10(1) A

Power Rating 4 2015(2) 4000(2) Watts

Switching Frequency 0 — 20 kHz

Note 1: The system continuously operated during one hour, 15 kHz switching 
frequency and the PFC boost circuit disabled.

2: It is possible to increase the available maximum output power up to 
4000W by using an external ventilation mechanism attached to system 
near to the power module. To provide additional air flow, a conventional 
AC muffin fan can be used (Comair-rotron part number 028021 or 
028023). An alternative bonded fin heat sink with fans attached is also an 
option (C&H Technology, Inc. part number CH5117F).

Parameter Min Typ Max Units

DC Bus 90 380 400 VDC

Current 0.1 2.6(1) 3.5(1) A

Power Rating 9 1000(2) 1400(2) Watts

Switching Frequency 0 50 100 kHz

Note 1: The system continuously operated during one hour, 50 kHz switching 
frequency.

2: It is possible to increase the available maximum output power up to 
1400W by using an external ventilation mechanism attached to system 
near to the PFC IGBT. To provide additional air flow, a conventional AC 
muffin fan can be used (Comair-rotron part number 028021 or 028023). 
An alternative bonded fin heat sink with fans attached is also an option 
(C&H Technology, Inc. part number CH5117F).
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NOTES:
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Appendix A. Board Layout and Schematics
FIGURE A-1: PFC STAGE BOARD LAYOUT (TOP)
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FIGURE A-2: PFC STAGE SCHEMATIC (SHEET 1 OF 3)
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Board Layout and Schematics
FIGURE A-3: PFC STAGE SCHEMATIC (SHEET 2 OF 3)
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FIGURE A-4: PFC STAGE SCHEMATIC (SHEET 3 OF 3)
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Board Layout and Schematics
FIGURE A-5: POWER MODULE STAGE BOARD LAYOUT (TOP)
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FIGURE A-6: POWER MODULE STAGE BOARD LAYOUT (BOTTOM)
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Board Layout and Schematics
FIGURE A-7: POWER MODULE STAGE SCHEMATIC (SHEET 1 OF 6)
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FIGURE A-8: POWER MODULE STAGE SCHEMATIC (SHEET 2 OF 6)
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Board Layout and Schematics
FIGURE A-9: POWER MODULE STAGE SCHEMATIC (SHEET 3 OF 6)
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FIGURE A-10: POWER MODULE STAGE SCHEMATIC (SHEET 4 OF 6)
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Board Layout and Schematics
FIGURE A-11: POWER MODULE STAGE SCHEMATIC (SHEET 5 OF 6)
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FIGURE A-12: POWER MODULE STAGE SCHEMATIC (SHEET 6 OF 6)
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