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FEATURES 
Supports the detection of UART 
UDP transfer capability 
ADPD105 full configuration 

Register level 
High level 

Graph view 
Time graph 
Frequency graph 

 EVALUATION KIT CONTENTS 
EVAL-ADPD105Z-GEN evaluation board 
Mini USB cable 

ADDITIONAL EQUIPMENT NEEDED 
PC running Windows 7 operating system 

ONLINE RESOURCES 
ADPD105 data sheet 
ADPD103_ADPD105 OpenMarket WaveTool software 

GENERAL DESCRIPTION 
The EVAL-ADPD105Z-GEN evaluation board provides users 
with a simple means of connecting optics to the ADPD105 
photometric front end to evaluate the ADPD105 in a number of 
different applications, from vital signs monitoring to industrial 
sensing. The evaluation board includes the ADPD103_ADPD105 
OpenMarket WaveTool graphical user interface (GUI) that 
provides users with low level and high level configurability, real-
time frequency and time domain analysis, and user datagram 
protocol (UDP) transfer capability so the evaluation board can 
easily interface to the user development system. 

The USB port powers the EVAL-ADPD105Z-GEN. On-board 
voltage regulators provide voltage supplies for the ADPD105, 
ADuCM360, and FTDI Chip FT232. There are on-board regulators 
that provide 3.3 V and 4.3 V LED supplies, as well as a selectable 
option to add an external LED supply. The evaluation board 
provides an LED and photodiode (PD) for a finger photople-
thysmography (PPG) measurement that is useful for a quick 
functionality check of the evaluation system. 

The schematic and board layout as well as the board itself, see 
Figure 1, indicate signal names for easy identification. For 
additional information on the functionality of the ADPD105, 
refer to the ADPD105 data sheet. 

EVAL-ADPD105Z-GEN EVALUATION BOARD PHOTOGRAPH 
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Figure 1.  
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GETTING STARTED 
INSTALLING THE ADPD103_ADPD105 
OPENMARKET WAVETOOL 
Download the ADPD103_ADPD105 OpenMarket WaveTool 
software package from the EVAL-ADPD105Z-GEN product 
page. Unzip the folder and run the ADPD103_ADPD105_ 
OpenMarket_WaveTool_Setup.exe file found in the 
WaveTool_x_x_x folder. Follow the prompts, beginning with 
Figure 2, for software installation. 
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Figure 2. ADPD103_ADPD105 OpenMarket WaveTool Setup Window 

CHECKING THE USB SERIAL CONNECTION IN 
WINDOWS 7 
Connect the USB cable to the EVAL-ADPD105Z-GEN 
evaluation board. Ensure the COM port driver is installed 
correctly. To verify proper installation, go to Control Panel > 
All Control Panel Items > System > Device Manager, as 
shown in Figure 3. In this case, the proper COM port selection 
is USB Serial Port (COM16). 

The EVAL-ADPD105Z-GEN evaluation board uses an FT232 
USB UART IC. If the USB driver installation does not install 
properly, refer to the corresponding FTDI Driver Installation 
guide to the operating system in use, found on the FTDI website.  
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Figure 3. USB Serial Port in Windows® 7 

 

 

 

RUNNING THE ADPD103_ADPD105 OPENMARKET 
WAVETOOL  
To start the ADPD103_ADPD105 OpenMarket WaveTool 
application, navigate to the ADPD103_ADPD105 OpenMarket 
WaveTool from the Start menu and click 
ADPD103_ADPD105_Tool (see Figure 4).  
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Figure 4. Navigate to ADPD103_ADPD105_Tool from the Start Menu 

At startup, the application automatically checks whether the 
installed ADPD103_ADPD105 OpenMarket WaveTool version 
is up to date. If there is a newer version available, the user is 
prompted to download the newest version, shown in Figure 5.  
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Figure 5. Automatic Version Update Prompt 

http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN-?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN-?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN-?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf


UG-1021 EVAL-ADPD105Z-GEN User Guide 
 

Rev. 0 | Page 4 of 26 

USB UNIVERSAL ASYNCHRONOUS 
RECEIVER/TRANSMITTER (UART) CONNECTION 
After the application opens, select File > Connect (see Figure 6). 
From the drop-down menu, select either Auto Connect or 
Select Port, depending on if the specific COM port selection is 
necessary.  
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Figure 6. UART Connect 

If a specific COM port selection is not needed, select Auto 
Connect to automatically connect the ADPD103_ADPD105 
OpenMarket WaveTool to the device.  

Choose Select Port to connect the ADPD103_ADPD105 
OpenMarket WaveTool to the device via a particular COM port, 
shown in Figure 7.  
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Figure 7. Port Selection 
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ADPD103_ADPD105 OPENMARKET WAVETOOL MAIN WINDOW 
The main window has two different modes: register level 
(RegisterLevel) and high level (HighLevel), shown in Figure 8 
and Figure 16, respectively. 

The RegisterLevel configuration window accesses each register 
or can load a complete list of registers that are stored in a 
configuration file on the PC. 

The high level configuration performs a high level 
configuration of the ADPD105 without individual register 
writes. The high level configuration screen sets up parameters, 
for example, such as LED current, number of LED pulses, and 
AFE integration time. 

USING THE REGISTERLEVEL CONFIGURATION 
Figure 8 shows the ADPD105 configuration window in the 
RegisterLevel window. The following controls and descriptions 
are listed in the configuration window: 

• Firmware Version shows the firmware version.  
• Config File in Use shows information about the 

configuration file that is in use. 

• Register View shows the current register values of the 
device. Change register values by entering a hexadecimal 
value into the value column of the register view list and 
press the Enter key. 

• Register Field View shows how the register is subdivided 
into fields that determine how each bit field is used. For 
example, Figure 8 shows the PAD_IO_CTRL, Register 0x02, is 
composed of the bit fields INT_POL, INT_DRV, and 
INT_ENA to configure the operation of the INT pin.  

• Single Register Control allows reading and writing of 
individual registers. 

• Load a configuration file (.dcfg) by selecting File > 
LoadCfg and selecting a .dcfg file included with the 
software installation or a custom .dcfg file developed by the 
user for a desired configuration. 

• Save a configuration file (.dcfg) by selecting File > SaveCfg. 
• The Go to HighLevel button switches to the 3 LED’s High 

Level Control view. 
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Figure 8. RegisterLevel Window 
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Register View 

The Name column in the Register View list displays the register 
name as defined by the register map, followed by (in parentheses) 
the address in abbreviated hexadecimal format (see Figure 9). 
The Value column displays the register value of the corresponding 
register in the Name column in full hexadecimal format. 
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Figure 9. Register View List 

Clicking any register in the Register View list reveals the 
register categories in the Register Field View list, as shown in 
Figure 10. The Register Field View is read only.  
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Figure 10. Register Field View List 

Enter data in cells in the Value column of the Register View list 
in either hexadecimal or decimal format. A hexadecimal 
number is entered with a 0x prefix to the number, whereas a 
decimal number does not include these prefix characters. For 
example, entering 0xFF (hexadecimal) or 255 (decimal), results 
in the same value written to the register. 

Hovering over a cell in the Value column in the Register View 
list shows the delineation of the register fields for that cell (see 
Figure 11), whereas hovering over a cell in the Name column 
shows a description of the corresponding register. 
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Figure 11. Register Value List Selection Hover Description  

The Register View list has a context-sensitive menu available by 
right-clicking anywhere in the Register View list (see Figure 12). 
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Figure 12. Register View Context-Sensitive Menu 

By using the context-sensitive menu, it is possible to refresh the 
selected register, refresh all registers, or set the selected register 
to display in hexadecimal or decimal format. The selected format 
remains set, even when the ADPD103_ADPD105 OpenMarket 
WaveTool is opened and closed, until the format is reset.  

For example, in Figure 13, the Time Slot B offset registers 
(CHx_OFFSET_B) display in decimal format but others, such 
as LED drive settings (LEDx_DRV), display in hexadecimal 
format. 
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Figure 13. Register View List Values in Decimal and Hexadecimal Format 

Register Field View 

The Register Field View list is a read-only view to see specific 
register field value(s). It automatically tracks the selected 
register in the Register View list. 

The Register Field View list is composed of two columns, 
shown in Figure 14. 
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Figure 14. Register Field View List 

The Register Field View list shows each register field, where the 
Name column shows the register name (start bit:length in bits) and 
the Value column shows the hexadecimal value (without the prefix 
characters 0x) of the corresponding register. 

Single Register Control 

The Single Register Control pane includes controls to read or 
write an individual register. 

The Read Register button reads and displays the value of the 
register entered in the Register Address field. 

The Write Register button writes the register with the value 
entered in the Register Value field. 
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Figure 15. Single Register Control Pane 
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HIGH LEVEL 
Figure 16 shows the ADPD103_ADPD105 OpenMarket WaveTool 
HighLevel configuration window. This window offers an entire 
set of high level parameter controls. The configurable 
parameters are as follows:  

 Sampling Frequency—adjusts the sampling rate. 
 Internal Average (identical for both timeslots in the 

ADPD105)—controls the output data rate, which is equal 
to the sampling frequency divided by the internal average. 
For example, a sampling frequency of 400 Hz and an 
internal average setting of 4, as shown in Figure 16, results in 
an output data rate of 100 Hz.  

 ADPD Slot Mode—specifies all the ADPD105 slot modes. 
 Slot A Control and Slot B Control 

 LED Control 
 LED—selects an LED from the drop-down menu. 
 LED Status—specifies whether the selected LED 

is in the on or off state. 
 Number Of Pulses—sets the number of LED 

pulses. 
 TIA Gain—sets the gain of the transimpedance 

amplifier (TIA) via a drop-down menu. 

 Timing Control—see the ADPD105 data sheet for 
detailed descriptions of the timing controls. 
 AFE Width (us)—sets the AFE integration time in 

microseconds. 
 Pulse Width (us)—sets the LED pulse width in 

microseconds. 
 Pulse Offset (us)—sets the LED pulse offset in 

microseconds. 
 AFE Offset (us)—sets the coarse AFE integration 

offset in microseconds. 
 AFE Fine Offset (ns)—sets the fine AFE 

integration offset in nanoseconds. 
 LED 1, LED 2, and LED 3 current controls  

 I_LED Coarse—coarse setting for the LED current 
via the I_LED Coarse drop-down menu. 

 Scale Factor—100% or 40% scale factor applied to 
the coarse LED current setting. 

 Final I_LED—sets Final I_LED current in the 
Final I_LED field by using the slider. The field 
displays in milliamps. 

To switch to the RegisterLevel configuration, click the Go to 
RegisterLevel button. 
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Figure 16. HighLevel Window 

 

http://www.analog.com/EVAL-ADPD105Z-GEN?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/ADPD105?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/ADPD105?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf
http://www.analog.com/ADPD105?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf


EVAL-ADPD105Z-GEN User Guide UG-1021
 

Rev. 0 | Page 9 of 26 

ADPD SLOT MODE 
The ADPD Slot Mode contains Slot A, Slot B, and the sum and 
digital integration modes.  
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Figure 17. ADPD Slot Mode Drop-Down Menu 

Slot A (16 Bits) 

The 4-channel, 16-bit data displays in the Time View tab for 
Time Slot A only. When in the Frequency View tab, see Figure 39, 
use the Channel Select drop-down menu to display the FFT for 
the selected channel. 

Slot B (16 Bits)  

The 4-channel, 16-bit data displays in the Time View tab for 
Time Slot B only. When in the Frequency View tab, see Figure 39, 
use the Channel Select drop-down menu to display the FFT for 
the selected channel. 

Slot AB (16 Bits)  

The 4-channel, 16-bit data displays in the Time View tab for 
both Time Slot A and Time Slot B. When in the Frequency View 
tab, see Figure 39, use the Channel Select drop-down menu to 
display the FFT for the selected channel. 

Slot A (32 Bits)  

The 4-channel, 32-bit data displays in the Time View tab for 
Time Slot A only. When in the Frequency View tab, see Figure 39, 
use the Channel Select drop-down menu to display the FFT for 
the selected channel. 

Slot B (32 Bits)  

The 4-channel, 32-bit data displays in the Time View tab for 
Time Slot B only. When in the Frequency View tab, see Figure 39, 
use the Channel Select drop-down menu to display the FFT for 
the selected channel. 

Slot AB (32 Bits)  

The 4-channel, 32-bit data displays in the Time View tab for 
both Time Slot A and Time Slot B. When in the Frequency View 
tab, see Figure 39, use the Channel Select drop-down menu to 
display the FFT for the selected channel. 

Slot A Sum (16 Bits) 

The sum of 4-channel, 16-bit data displays in the Time View 
tab for Time Slot A only. When in the Frequency View tab, see 
Figure 39, use the Channel Select drop-down menu to display 
the FFT for the selected channel. 

Slot B Sum (16 Bits) 

The sum of 4-channel, 16-bit data displays in the Time View 
tab for Time Slot B only. When in the Frequency View tab, see 
Figure 39, use the Channel Select drop-down menu to display 
the FFT for the selected channel. 

Slot AB Sum (16 Bits) 

The sum of 4-channel, 16-bit data displays in the Time View 
tab for both Time Slot A and Time Slot B. When in the Frequency 
View tab, see Figure 39, use the Channel Select drop-down 
menu to display the FFT for the selected channel. 

Slot A Sum (32 Bits) 

The sum of 4-channel, 32-bit data displays in the Time View 
tab for Time Slot A only. When in the Frequency View tab, see 
Figure 39, use the Channel Select drop-down menu to display 
the FFT for the selected channel. 

Slot B Sum (32 Bits) 

The sum of 4-channel, 32-bit data displays in the Time View 
tab for Time Slot B only. When in the Frequency View tab, see 
Figure 39, use the Channel Select drop-down menu to display 
the FFT for the selected channel. 

Slot AB Sum (32 Bits)  

The sum of 4-channel, 32-bit data displays in the Time View tab 
for both Time Slot A and Time Slot B. When in the Frequency 
View tab, see Figure 39, use the Channel Select drop-down 
menu to display the FFT for the selected channel. 

Slot A Dig Int-1 (16-Bits) 

16-bit digital integrated sample data displays in the Time View tab 
for Time Slot A only. When in the Frequency View tab, see 
Figure 39, use the Channel Select drop-down menu to display 
the FFT for the selected channel. 

Slot B Dig Int-1 (16 Bits) 

16-bit digital integrated sample data displays in the Time View tab 
for Time Slot B only. When in the Frequency View tab, see 
Figure 39, use the Channel Select drop-down menu to display 
the FFT for the selected channel. 
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Slot AB Dig Int-1 (16 Bits) 

16-bit digital integrated sample data displays in the Time View 
tab for Time Slot A and Time Slot B. When in the Frequency 
View tab, see Figure 39, use the Channel Select drop-down 
menu to display the FFT for the selected channel. 

Slot A Dig Int-2 (16 Bits)  

16-bit digital integrated sample and background data displays in 
the Time View tab for Time Slot A only. When in the 
Frequency View tab, see Figure 39, use the Channel Select drop-
down menu to display the FFT for the selected channel. 

Slot B Dig Int-2 (16-Bits) 

16-bit digital integrated sample and background data displays in 
the Time View tab for Time Slot B only. When in the Frequency 
View tab, see Figure 39, use the Channel Select drop-down 
menu to display the FFT for the selected channel. 

Slot AB Dig Int-2 (16 Bits) 

16-bit digital integrated sample and background data displays in 
the Time View tab for Time Slot A and Time Slot B. When in the 
Frequency View tab, see Figure 39, use the Channel Select drop-
down menu to display the FFT for the selected channel. 

Slot A Dig Int-1 (32 Bits) 

32-bit digital integrated sample data displays in the Time View tab 
for Time Slot A only. When in the Frequency View tab, see 
Figure 39, use the Channel Select drop-down menu to display 
the FFT for the selected channel. 

Slot B Dig Int-1 32 Bits:  

32-bit digital integrated sample data displays in the Time View tab 
for Time Slot B only. When in the Frequency View tab, see 
Figure 39, use the Channel Select drop-down menu to display 
the FFT for the selected channel. 

Slot AB Dig Int-1 (32 Bits) 

32-bit digital integrated sample data displays in the Time View tab 
for Time Slot A and Time Slot B. When in the Frequency View 
tab, see Figure 39, use the Channel Select drop-down menu to 
display the FFT for the selected channel. 

Slot A Dig Int-2 (32 Bits) 

32-bit digital integrated sample and background data display in 
the Time View tab for Time Slot A only. When in the Frequency 
View tab, see Figure 39, use the Channel Select drop-down 
menu to display the FFT for the selected channel. 

Slot B Dig Int-2 (32 Bits) 

32-bit digital integrated sample and background data display in 
the Time View tab for Time Slot B only. When in Frequency 
View tab, see Figure 39, use the Channel Select drop-down 
menu to display the FFT for the selected channel. 

Slot AB Dig Int-2 (32 Bits)  

32-bit digital integrated sample and background data display in 
the Time View tab for Time Slot A and Time Slot B. When in 
the Frequency View tab, see Figure 39, use the Channel Select 
drop-down menu to display the FFT for the selected channel. 

LOAD AND SAVING CONFIGURATIONS 
To load and save device configuration files, use File > Load Cfg 
and File > Save Cfg, respectively, as shown in Figure 18 and 
Figure 19. The load configuration option (Load Cfg) loads the 
set of registers contained in the user selected .dcfg file to the 
ADPD105. The save configuration option (Save Cfg) saves all 
writable registers of the ADPD105 to a .dcfg file via the Open file 
dialog box. 

Find sample configuration files installed with the 
ADPD103_ADPD105 OpenMarket WaveTool application in the 
SampleCfgs folder.  
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Figure 18. Load Configuration 
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Figure 19. Save Configuration 

Selecting Load Cfg opens a file dialog box. Device 
configuration files have the extension .dcfg. Once loaded, the 
configuration file used by the evaluation board displays in the 
RegisterLevel window in the Config File in Use pane, shown 
in Figure 8 and Figure 20. The full path of the .dcfg file is shown 
when the mouse hovers over the file name. If no file is loaded, 
the Config File in Use pane displays None. 
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Figure 20. Config File in Use Pane 

A configuration file uses the following format: 

Address Data #(comment optional) 

The address is an 8-bit address and the data must be in 16-bit 
format, as follows: 

14 0555 #setup input PD configuration 

15 0220 #number of averages = 4 

18 1F80 #slot A channel 1 ADC offset 

19 1F80 #slot A channel 2 ADC offset 

APPLY CONFIGURATION 
A previously loaded configuration remains in the memory of 
the ADPD103_ADPD105 OpenMarket WaveTool software until 
overwritten by a new configuration file using File > Load Cfg, 
shown in Figure 18. Therefore, to return to a previously loaded 
configuration quickly, it is not necessary to reload the 
configuration. Instead, select File > Apply Config. 
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Figure 21. Apply Configuration 

 

DUMP REGISTERS 
With the ADPD103_ADPD105 OpenMarket WaveTool 
software, the user can dump all the registers to a single file by 
selecting File > Register Dump, shown in Figure 22. A file 
dialog box opens, prompting the user to save the file to a 
specific location with a specific name. Register contents are 
then dumped to the specified file. 
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Figure 22. Dumping Registers 

The following is an example of a register dump: 

PD_SELECT (14) 0555 

INT_AVG_MODE (15) 0220 

CH1_OFFSET_A (18) 1F80 

CH2_OFFSET_A (19) 1F80 

The register is listed by name and the address is listed in the 
corresponding hexadecimal value. 
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GRAPH VIEW 
Use Graph View for real-time frequency and time domain 
analysis of the ADPD105 raw data. Access Graph View from the 
main window via the View menu, shown in Figure 23.  
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Figure 23. View Menu 

When the Graph View opens, it defaults to the time domain 
view (Time View tab) as shown in Figure 24. There is also a 
Frequency View tab for frequency domain analysis. 
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Figure 24. Time View Tab 

 

http://www.analog.com/ADPD105?doc=EVAL-ADPD105Z-GEN-UG-1021.pdf


EVAL-ADPD105Z-GEN User Guide UG-1021 
 

Rev. 0 | Page 13 of 26 

Time View 

The Time View tab displays the raw data from the ADPD105 in 
time domain format. Plot or send the raw data through the 
UDP to the host system that is controlled by the UDP Transfer 
checkbox in the Time View, which has three controls:  

• The UDP on/plot off mode, where the UDP Transfer 
checkbox is checked (see Figure 25). In this mode, the data 
is sent through the UDP and does not display in the graph. 
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Figure 25. UDP On/Plot Off Mode 

• The UDP off/plot on mode, where the UDP Transfer 
checkbox is not selected (see Figure 26). In this mode, the 
data displays in the graph but is not sent through the UDP. 
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Figure 26. UDP Off/Plot On Mode 

• The UDP on/plot on mode, where the UDP Transfer 
checkbox fill is solid by selecting three consecutive times 
(see Figure 27). In this mode, the data is sent through the 
UDP and also displays in the graph. 
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Figure 27. UDP On/Plot On Mode 

The UDP Transfer Tool is set up within the 
ADPD103_ADPD105 OpenMarket WaveTool package; see the 
UDP Transfer Tool section. The UDP Transfer Tool receives the 
data from ADPD103_ADPD105 OpenMarket WaveTool and 
transfers the data to the assigned UDP port. 

To save the raw data into a file, check the Save Raw Data 
checkbox, as shown in Figure 28. When the box is checked, the 
user is prompted to save the file. 
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Figure 28. Checkbox to Save Sensor Raw Data to a File 

 

Configure the x-axis sample count for graph plotting through 
the X-Axis Sample Counts spin box (see Figure 29). 
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Figure 29. X-Axis Sample Counts Spin Box 

Note the minimum value for sample count is limited to 100. If 
the sample count is assigned with values smaller than 100, it 
automatically corrects to 100. 

The Time View tab shows the raw data graph that plots Sample 
(Index) vs. LSBs (10^3) data. 

The plot of each individual channel is controlled using the 
checkboxes, shown in Figure 30. By clicking any checkbox in 
the Slot A or Slot B panes, the corresponding channel data is 
plotted with the specified color in the Raw Data Channels graph. 
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Figure 30. Channel Display Controls 

The auto scaling of the Time View graph can be enabled or 
disabled by the AutoScaleEnable checkbox (see Figure 31). The 
minimum and maximum scale range can also be adjusted while 
the auto scale option is disabled. 
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Figure 31. AutoScaleEnable Control and Scale Range Setting 

The average and standard deviation for every channel and sum 
of all channels are displayed in the Slot A and Slot B panes (see 
Figure 32). These statistics are enabled or disabled by the checkbox 
preceded by each label. 
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Figure 32. Average and Standard Deviation Controls 
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General Controls 

Using standard controls, the user can start (see Figure 33), stop 
the current mode and return to idle mode (see Figure 34), and 
pause the device in the current operating state (see Figure 35), 
no longer updating the graphs but still receiving data from the 
device.  
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Figure 33. Start Button 
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Figure 34. Stop and Return to Idle Button 
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Figure 35. Pause and Resume Button 

FREQUENCY VIEW 
The Frequency View tab shows the fast fourier transform (FFT) 
of the raw data in the form of a graph that plots Amplitude vs. 
Frequency (Hz). The user can select the x-axis scale type as 
linear or logarithmic in the XAxis Scale Type drop-down list, 
shown in Figure 36. 
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Figure 36. X-Axis Scale Type Drop-Down Menu 

The FFT Samples spin box provides the number of samples 
that calculate the FFT.  
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Figure 37. FFT Samples Spin Box 

The minimum value for sample count is limited to 50 samples. 
If the FFT Samples spin box is assigned with values smaller 
than 50, it automatically corrects to 50. 

The Frequency View tab displays any one of the enabled 
channels from the Channel Select drop-down list. For example, 
if Slot A is enabled, the user can select any channel within Slot A, 
shown in Figure 38. 
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Figure 38. Slot A Channels 

The linear scale of the FFT Spectrum graph is shown in Figure 39 
and the logarithmic scale of the FFT Spectrum graph is shown 
in Figure 40. 
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Figure 39. Linear FFT Spectrum Graph 
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Figure 40. Logarithmic FFT Spectrum Graph
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TOOLS DROP-DOWN MENU OPTIONS 
OPTIONS 
The Options selection from the Tools drop-down menu shows 
the general board settings as well as the UDP configuration. 

General 

The General tab contains information about the device, the 
platform, and the firmware version. 
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Figure 41. General Tab in Options Dialog Box 

UDP Configuration 

The UDP Configuration tab allows the user to configure the 
port numbers for UDP communication. The UDP transfer tool 
sends the raw data to the client via the specified port numbers. 
The IP address field must display the IP address the UDP 
transfer tool is running. 

Use the Raw Data Transfer Port field to assign the port 
number for sending raw data from ADPD103_ADPD105 
OpenMarket WaveTool to the UDP transfer tool (see Figure 42). 
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Figure 42. UDP Configuration Tab in Options Dialog Box 

AUTOMATIC UPDATE 
The Tools > Auto Update function enables/disables the 
automatic software update functionality at the time of tool start 
(see Figure 43). When Auto Update is enabled, it checks for the 
availability of a new ADPD103_ADPD105 OpenMarket 
WaveTool update and prompts the user to update the tool with 
the latest version. 
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Figure 43. Auto Update Option 

CHECK FOR UPDATES 
Use the Tools > Check For Updates function to manually check 
for the availability of a new software update (seeFigure 44). 
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Figure 44. Check For Updates Option 

FIRMWARE UPDATE 
Use the Tools > Firmware Update function to start the 
firmware update process (see Figure 45). 
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Figure 45. Firmware Update Option 

Note the ADPD103_ADPD105 OpenMarket WaveTool must be 
connected with the evaluation board to perform the firmware 
update; otherwise, the ADPD103_ADPD105 OpenMarket 
WaveTool shows a disconnect message (see Figure 46). 
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Figure 46. Connection Status for Firmware Update 
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When Firmware Update is selected, the CM3WSD firmware 
flashing tool opens. To flash the firmware, the user must ensure 
that the correct path and file name are selected in the 
CM3WSD dialog box, shown in Figure 47.  
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Figure 47. Firmware Flashing Tool 

With the correct path name and file name entered in the File to 
download field and the correct USB serial port selected from 
the Serial Port drop-down menu, click Start. The user is 
prompted to pulse the reset button while holding down the 
download button on the evaluation board (circled in Figure 48). 
The firmware download starts when this step is completed. 

 
Figure 48. Serial Download and Reset Buttons to Flash Firmware 

When the firmware download completes, click the Reset button 
in the CM3WSD dialog box and click the Exit button. The user 
can now return to the ADPD103_ADPD105 OpenMarket 
WaveTool and reconnect the device via File > Connect to 
commence testing with the updated firmware. 

SEND REPORT 
If the software update failed for ten times continuously, the 
OpenMarket WaveTool opens the dialog box shown in Figure 49. 
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Figure 49. Update! Dialog Box 

When the user clicks Yes, the Email Request dialog box appears 
(see Figure 50). 
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Figure 50. Email Request Dialog Box 

Enter the user name in the Enter Your Name field and email ID 
(this is the email address used when registering to receive the 
software package) in the Enter Your Email ID field. After entering 
a user name and email ID, click Send to initiate the report to 
Analog Devices, Inc. 
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EXITING THE ADPD103_ADPD105 OPENMARKET WAVETOOL APPLICATION 
Follow the subsequent two step process to exit the application: 

1. Disconnect the device via File > Disconnect Ctrl+D, 
shown in Figure 51. 
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Figure 51. Disconnecting the EVAL-ADPD105Z-GEN 

2. Exit the application via File > Exit, shown in Figure 52. 
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Figure 52. Exiting the Application 
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UDP TRANSFER TOOL 
This section explains the raw data reception and data format for 
various modes from the UDP transfer tool over UDP. 

UDP TRANSFER TOOL SETUP 
To setup the the UDP transfer tool, follow these steps: 

1. Open the ADPD103_ADPD105 OpenMarket WaveTool 
and go to Tools > Options > UDP Configuration. Enter 
the IP address of the remote PC where the UDP transfer 
tool is running. 
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Figure 53. UDP Configuration Tab 

2. Connect the hardware (File > Connect > Auto Connect or 
File > Connect > Select Port) using the UART bridge on 
the host PC. 
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Figure 54. Selecting Auto Connect 

3. Open Graph View and check the UDP Transfer box in the 
Time View tab. 
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Figure 55. Enable UDP Transfer 

4. Click the Start button (see Figure 33) to send the raw data 
through the UDP. 

To save the raw data being transferred via the UDP to a data 
file, open the receiver tool (UDPTransferTool.exe) and enter 
the IP address of the system (see Figure 56). 
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Figure 56. UDP Receiver Tool 

5. Enter a file name to save the raw data from the 
ADPD103_ADPD105 OpenMarket WaveTool and press 
enter (see Figure 57). 
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Figure 57. Entering a File Name to Store Data 

6. The received packet count is continuously displayed in the 
ADPD103_ADPD105 OpenMarket WaveTool tool and the 
raw data is stored in the file (see Figure 58). 
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Figure 58. Receiving Raw Data 

7. Press the ESC key to stop receiving the data and close the 
current file (see Figure 59). 
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Figure 59. Closing the File 
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RAW DATA FORMAT 
Before using the UDP transfer tool, ensure the 
ADPD103_ADPD105 OpenMarket WaveTool is opened and 
running with the UDP transfer enabled. See Figure 60 for an 
example of stored sample raw data. 
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Figure 60. Sample Data 

The sample data transmits in the form of ASCII bytes in 
hexadecimal characters. The sample data format is 
F0136CFC0000000FE90000105000000EA000000FCC. 

The hexadecimal data is formatted with the following 
characteristics:  

• The first two characters (F0) represent sync.  
• Next two characters (13) represent size. 
• Next two characters (6C) represent the sequence number. 
• Next four characters (FC00) represent the time stamp. 
• The remaining characters represent the hexadecimal 

channel raw data and its count (based on the slot modes of 
the ADPD103_ADPD105 OpenMarket WaveTool). 

Table 1. UDP Data Count for Various Modes 
Slot Mode Data Format Data Count 
Slot A Sum, 16 bits 00000FE9 1 
Slot B Sum, 16 bits   
Slot A Sum, 32 bits   
Slot B Sum, 32 bits   
Slot A Dig Int, 16 bits   
Slot B Dig Int, 16 bits   
Slot AB Sum, 32 bits 00000FE9 00001050 2 
Slot A Dig Int, 32 bits   
Slot B Dig Int, 32 bits   
Slot A, 16 bits 00000FE9 00001050 00000EA0 00000FCC 4 
Slot B, 16 bits   
Slot A, 32 bits   
Slot B, 32 bits   
Slot AB, 16 bits 00000F7E 0000105C 00000EA8 00000FCC 00000FE9 00001064 00000EAD 00000FCE 8 
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UDP CONTROLLER TOOL 
Open the UDPControllertool (see Figure 61) and complete the 
Enter your Host IP Address field. This is the IP address of the 
host PC where the ADPD103_ADPD105 OpenMarket 
WaveTool is running. 

After entering the corresponding IP address, the user can send and 
receive commands between the controller and the 
ADPD103_ADPD105 OpenMarket WaveTool. 
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Figure 61. UDPControllertool Window 

 

UDP CONTROLLER APPLICATION TESTING 
PROCEDURE 
Port Connection 

To use the read register or write register functions, the port 
must be connected in the ADPD103_ADPD105 OpenMarket 
WaveTool. Connect the port using the following steps: 

1. Open the ADPD105 OpenMarket WaveTool application.  
2. Connect the port by selecting File > Connect. Select either 

Auto Connect to automatically select the port or Select 
Port to manually select the port.  

3. Ensure the UDP control IP address is assigned correctly. 

Read Register 

After connecting the port, send the register read command as 
00 01 <reg address>, for example, send as 00 01 01 to read from 
register 0x01 (see Figure 62). The following are the defined read 
command components: 

• 00 = register read command 
• 01 = number of parameters 
• 01 = register address 

The response is received with the register value. 

14
76

4-
05

9

 
Figure 62. Read Register Operation 
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Write Register 

After connecting the port following the instructions in the Port 
Connection section, send the register write command as 00 03 
<reg address> <Value>, for example, send as 00 03 01 00 01 
(see Figure 63). 

 

 

The following are the defined write command components: 

• 00 = register write command 
• 03 = number of parameters 
• 01 = register address 
• 00 01 = register value 

The response is received with the register value.  
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Figure 63. Write Register Operation 
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Run 

Open the ADPD103_ADPD105 OpenMarket WaveTool 
application and connect the port (see the Port Connection 
section). If the bridge is connected, then open the graph view by 
selecting View > Graph. 

Next, send the play command as 02 00, where 

02 = play command 
00 = number of parameters 

Stop 

Open the ADPD103_ADPD105 OpenMarket WaveTool 
application and connect the port (see the Port Connection 
section). If the bridge is connected, then open the graph view: 
View > Graph. 

Next, send the stop command as 03 00, where 

03 = stop command 
00 = number of parameters 

Load Configuration 

Open the ADPD103_ADPD105 OpenMarket WaveTool 
application and connect the port (see the Port Connection 
section). If bridge is connected, then a command can be sent to 
the ADPD103_ADPD105 OpenMarket WaveTool through the 
UDP. 

Next, send the load configuration file command as 0D 00, 
which gives a list of available configuration file names, shown in 
Figure 64. Select the particular configuration file from the list 
shown. 

Likewise, commands can be given for connect, disconnect, 
open view, and raw data by referring to the command list in 
Table 2. 

COMMANDS SUMMARY 
Table 2 summarizes the list of commands, command code and 
example formats for various functions that are currently 
available in the ADPD103_ADPD105 OpenMarket WaveTool. 

Table 2. Commands Summary 
Command Command Code1 Example 
Connect 0A 00 0A 00 
Disconnect 0B 00 0B 00 
Open view 0C 00 0C 00 
Load configuration (Load Cfg) 0D 00 0D 00 
Read 00 01  

<reg address> 
00 01 40 

Write 01 03  
<reg address> <Value> 

01 03 41 00 01 

Run 02 00 02 00 
Stop 03 00 03 00 
Raw data 06 01 <ON/OFF> 06 01 01 (or) 06 01 00 
 

 
1 See Figure 64. 
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Figure 64. List of .dcfg Files Available in the ADPD103_ADPD105 OpenMarket WaveTool Configuration Directory 
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EVALUATION BOARD SCHEMATICS AND ARTWORK 
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Figure 65. EVAL-ADPD105Z-GEN Schematic, ADPD105 Interface 
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Figure 66. EVAL-ADPD105Z-GEN Schematic, UART/M360 Interface 
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Figure 67. EVAL-ADPD105Z-GEN Primary Layer 
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Figure 68. EVAL-ADPD105Z-GEN Secondary Layer 
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Figure 69. EVAL-ADPD105Z-GEN Ground Layer 
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Figure 70. EVAL-ADPD105Z-GEN Power Layer 
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ESD Caution  
ESD (electrostatic discharge) sensitive device. Charged devices and circuit boards can discharge without detection. Although this product features patented or proprietary protection 
circuitry, damage may occur on devices subjected to high energy ESD. Therefore, proper ESD precautions should be taken to avoid performance degradation or loss of functionality. 

Legal Terms and Conditions 
By using the evaluation board discussed herein (together with any tools, components documentation or support materials, the “Evaluation Board”), you are agreeing to be bound by the terms and conditions 
set forth below (“Agreement”) unless you have purchased the Evaluation Board, in which case the Analog Devices Standard Terms and Conditions of Sale shall govern. Do not use the Evaluation Board until you 
have read and agreed to the Agreement. Your use of the Evaluation Board shall signify your acceptance of the Agreement. This Agreement is made by and between you (“Customer”) and Analog Devices, Inc. 
(“ADI”), with its principal place of business at One Technology Way, Norwood, MA 02062, USA. Subject to the terms and conditions of the Agreement, ADI hereby grants to Customer a free, limited, personal, 
temporary, non-exclusive, non-sublicensable, non-transferable license to use the Evaluation Board FOR EVALUATION PURPOSES ONLY. Customer understands and agrees that the Evaluation Board is provided 
for the sole and exclusive purpose referenced above, and agrees not to use the Evaluation Board for any other purpose. Furthermore, the license granted is expressly made subject to the following additional 
limitations: Customer shall not (i) rent, lease, display, sell, transfer, assign, sublicense, or distribute the Evaluation Board; and (ii) permit any Third Party to access the Evaluation Board. As used herein, the term 
“Third Party” includes any entity other than ADI, Customer, their employees, affiliates and in-house consultants. The Evaluation Board is NOT sold to Customer; all rights not expressly granted herein, including 
ownership of the Evaluation Board, are reserved by ADI. CONFIDENTIALITY. This Agreement and the Evaluation Board shall all be considered the confidential and proprietary information of ADI. Customer may 
not disclose or transfer any portion of the Evaluation Board to any other party for any reason. Upon discontinuation of use of the Evaluation Board or termination of this Agreement, Customer agrees to 
promptly return the Evaluation Board to ADI. ADDITIONAL RESTRICTIONS. Customer may not disassemble, decompile or reverse engineer chips on the Evaluation Board. Customer shall inform ADI of any 
occurred damages or any modifications or alterations it makes to the Evaluation Board, including but not limited to soldering or any other activity that affects the material content of the Evaluation Board. 
Modifications to the Evaluation Board must comply with applicable law, including but not limited to the RoHS Directive. TERMINATION. ADI may terminate this Agreement at any time upon giving written notice 
to Customer. Customer agrees to return to ADI the Evaluation Board at that time. LIMITATION OF LIABILITY. THE EVALUATION BOARD PROVIDED HEREUNDER IS PROVIDED “AS IS” AND ADI MAKES NO 
WARRANTIES OR REPRESENTATIONS OF ANY KIND WITH RESPECT TO IT. ADI SPECIFICALLY DISCLAIMS ANY REPRESENTATIONS, ENDORSEMENTS, GUARANTEES, OR WARRANTIES, EXPRESS OR IMPLIED, RELATED 
TO THE EVALUATION BOARD INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, TITLE, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT OF INTELLECTUAL 
PROPERTY RIGHTS. IN NO EVENT WILL ADI AND ITS LICENSORS BE LIABLE FOR ANY INCIDENTAL, SPECIAL, INDIRECT, OR CONSEQUENTIAL DAMAGES RESULTING FROM CUSTOMER’S POSSESSION OR USE OF 
THE EVALUATION BOARD, INCLUDING BUT NOT LIMITED TO LOST PROFITS, DELAY COSTS, LABOR COSTS OR LOSS OF GOODWILL. ADI’S TOTAL LIABILITY FROM ANY AND ALL CAUSES SHALL BE LIMITED TO THE 
AMOUNT OF ONE HUNDRED US DOLLARS ($100.00). EXPORT. Customer agrees that it will not directly or indirectly export the Evaluation Board to another country, and that it will comply with all applicable 
United States federal laws and regulations relating to exports. GOVERNING LAW. This Agreement shall be governed by and construed in accordance with the substantive laws of the Commonwealth of 
Massachusetts (excluding conflict of law rules). Any legal action regarding this Agreement will be heard in the state or federal courts having jurisdiction in Suffolk County, Massachusetts, and Customer hereby 
submits to the personal jurisdiction and venue of such courts. The United Nations Convention on Contracts for the International Sale of Goods shall not apply to this Agreement and is expressly disclaimed. 

©2016 Analog Devices, Inc. All rights reserved. Trademarks and  
 registered trademarks are the property of their respective owners. 
  UG14764-0-7/16(0)  
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