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• 10-pin header to DB9 programming cable with integrated level-matching circuitry.

• Getting Started instructions.

• Plastic and metal standoffs with 4-40 screws.

• A bag of jumpers and jumper wires for use on the 
Prototyping Board.

• Rabbit 4000 Processor Easy Reference poster.

• Registration card.

Starting Dynamic C
Once the RCM4110 is connected as described in the preceding pages, start Dynamic C by double-clicking on 
the Dynamic C icon on your desktop or in your Start menu. Dynamic C uses the serial port specified during 
installation.
If you are using a USB port to connect your computer to the RCM4110, choose Options > Project 
Options and check “Use USB to Serial Converter” in “Serial Options.” Click OK to save the settings.

Run a Sample Program
Use the File menu to open the sample program ROTATELED.C in the Dynamic C SAMPLES\RIO folder. 
Press function key F9 to compile and run the program.The four LEDs on the Prototyping Board will flash on 
and off in a rotating sequence, and the Dynamic C STDIO window will open on your PC to display the status 
of the Rabbit RIO chip’s Channel 1.
This sample program uses Channel 1 with the Rabbit RIO chip operating in the SPI clocked serial communi-
cation mode. The Rabbit RIO Chip User's Manual describes the communication modes in more detail.

Where Do I Go From Here?
If the sample program ran fine, you are now ready to go on to other sample programs and to develop your 
own applications. Application Note AN415, RIO Programmable I/O Kit, discusses how to use the Prototyp-
ing Board and explains the sample programs and Rabbit RIO function calls. The source code for the sample 
programs is provided to allow you to modify them for your own use. The RCM4100 User's Manual on the 
Dynamic C CD also provides complete hardware reference information and describes the software function 
calls for the RCM4110 RabbitCore module, and the Rabbit RIO User's Manual provides complete reference 
information for the Rabbit RIO chip.
Troubleshooting
If Dynamic C cannot find the target system (error message "No Rabbit Processor Detected."):

• Check that the RCM4110 is powered correctly — the red power LED on the Prototyping Board should be 
lit when the RCM4110 is mounted on the Prototyping Board and the AC adapter is plugged in.

• Check both ends of the programming cable to ensure that they are firmly plugged into the PC and the 
PROG connector, not the DIAG connector, is plugged in to the programming port on the RCM4110.

• Ensure that the RCM4110 module is firmly and correctly installed in its socket on the Prototyping Board.
If there are no faults with the hardware, select a different COM port within Dynamic C. On your computer, 
open Control Panel > System > Hardware > Device Manager > Ports and look at the list of available 
COM ports. In Dynamic C, select Options > Project Options, then select one of the available COM ports 
on the “Communications” tab, then click OK. Press <Ctrl-Y> to force Dynamic C to recompile the BIOS. If 
Dynamic C still reports it is unable to locate the target system, repeat the above steps for another available 
COM port. You should receive a Bios compiled successfully message once this step is com-
pleted successfully.
If a program compiles and loads, but then loses target communication before you can begin debugging, it is 
possible that your PC cannot handle the default debugging baud rate. Try lowering the debugging baud rate.

• Locate the Serial Options dialog in the Dynamic C Options > Project Options > Communica-
tions menu. Choose a lower debug baud rate.

If there are any other problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Semiconductor Technical Bulletin Board at www.rabbit.com/support/bb/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.

NOTE: If you purchased your RIO Programmable I/O Kit through a distributor or through a Rabbit 
Semiconductor partner, contact the distributor or partner first for technical support.

Installing Dynamic C®

Insert the CD from the RIO Programmable 
I/O Kit in your PC’s CD-ROM drive. If the 

un the 
t directory of 
ynamic C 

ic C.
Rabbit and Dynamic C are registered trademarks of Rabbit Semiconductor Inc.

Visit our online Rabbit store at www.rabbit.com/store/ for 
the latest information on peripherals and accessories that 
are available for the Rabbit RIO chip.

installation does not auto-start, r
setup.exe program in the roo
the Dynamic C CD. Install any D
modules after you install Dynam
RIO Programmable I/O Kit
The RIO Programmable I/O Kit is intended to demonstrate how to expand an embedded control system 
design by adding additional I/O and other features. The Kit provides a Prototyping Board with a Rabbit 
RIO chip already installed and configurable header locations to allow you to develop your own appli-
cation using the Dynamic C function calls and sample programs included with the Kit.

Application Kit Contents
The RIO Programmable I/O Kit contains the following items:

• 2 CD-ROMs — Dynamic C® with complete product documentation on disk, and supplemental CD with 
sample programs and information related to the RIO Programmable I/O Kit.

• RCM4110 module.

• Rabbit RIO Prototyping Board.

• Universal AC adapter, 12 V DC, 1 A (includes Canada/Japan/U.S., Australia/N.Z., U.K., and 
European style plugs).

http://www.zworld.com/support/bb/index.html
http://www.rabbit.com/support/questionSubmit.shtml


Hardware Connections

Figure 3.  Prototyping Board and Programming Cable Setup

: Be sure to use the programming cable (part number 101-0542) supplied with the RIO 
grammable I/O Kit—the programming cable has blue shrink wrap around the RS-232 con-
er section located in the middle of the cable. Programming cables with red or clear shrink 
p from other Rabbit Semiconductor kits are not designed to work with RCM4110 modules.

ther end of the programming cable to a COM port on your PC.

: Some PCs now come equipped only with a USB port. It may be possible to use an RS-232/
 converter (Part No. 540-0070) with the programming cable supplied with the RIO Pro-
mable I/O Kit. Note that not all RS-232/USB converters work with Dynamic C.
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1.  Prepare the Prototyping Board for 
Development
Snap in four of the plastic standoffs supplied in the bag 
of accessory parts from the RIO Programmable I/O Kit 
in the holes at the corners as shown.

2.  Attach Module to Prototyping Board
Turn the RCM4110 module so that the mounting holes 
of the RCM4110 line up with the corresponding holes 
on the Prototyping Board. Insert the metal standoffs as shown in Figure 2, secure them from the bottom of 
the Prototyping Board using the 4-40 × 3/16 screws, then insert the module’s header J3 on the bottom side 
into header socket RCM1 on the Prototyping Board.

Figure 2.  Install the RCM4110 Module on the Prototyping Board

NOTE: It is important that you line up the pins on header J3 of the RCM4110 module exactly with 
socket RCM1 on the Prototyping Board. The header pins may become bent or damaged if the pin 
alignment is offset, and the module will not work. Permanent electrical damage to the module may 
also result if a misaligned module is powered up.

Figure 1.  Insert Plastic Standoffs
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Press the module’s pins gently into the Prototyping Board header socket—press down in the area above 
the header pins. For additional integrity, you may secure the RCM4110 to the standoffs from the top 
using the remaining two 4-40 × 3/16 screws.

3.  Set Jumpers
Jumpers were placed at the factory on Prototyping Board headers J2, J7, J8, J9, and J15 as shown in Figure 3 
to set up the Prototyping Board for the SPI serial mode used with the sample programs. Application Note 
AN415, RIO Programmable I/O Kit, describes other configuration options.

4.  Connect Programming Cable
The programming cable connects the RCM4110 to the PC running Dynamic C to download programs 
and to monitor the RCM4110 module during debugging.

Connect the 10-pin connector of the programming cable labeled PROG to header J1 on the RCM4110 
as shown in Figure 3. Be sure to orient the marked (usually red) edge of the cable towards pin 1 of the 
connector. (Do not use the DIAG connector, which is used for a normal serial connection to Serial Port A.)

Once all the other connections have been made, you can connect power to the Prototyping Board.

First, prepare the AC adapter for the country where it will be used by selecting the appropriate plug. 
The RIO Programmable I/O Kit presently includes Canada/Japan/U.S., Australia/N.Z., U.K., and 
European style plugs. Snap in the top of the plug assembly into the slot at the top of the AC adapter as 
shown in Figure 3, then press down on the plug until it clicks into place.

Connect the AC adapter to 3-pin header J1 on the Prototyping Board as shown in Figure 3 above. The 
connector may be attached either way as long as it is not offset to one side—the center pin of J1 is 
always connected to the positive terminal, and either edge pin is ground.

Plug in the AC adapter. The power LED on the Prototyping Board above the power connector at J1 
should light up. The RCM4110 and the Prototyping Board are now ready to be used.

NOTE: If you need to reset the RCM4110, disconnect, then reconnect the power supply.



Hardware Connections
1.  Prepare the Prototyping Board for 
Development
Snap in four of the plastic standoffs supplied in the bag 
of accessory parts from the RIO Programmable I/O Kit 
in the holes at the corners as shown.

2.  Attach Module to Prototyping Board
Turn the RCM4110 module so that the mounting holes 
of the RCM4110 line up with the corresponding holes 
on the Prototyping Board. Insert the metal standoffs as shown in Figure 2, secure them from the bottom of 
the Prototyping Board using the 4-40 × 3/16 screws, then insert the module’s header J3 on the bottom side 
into header socket RCM1 on the Prototyping Board.

Figure 2.  Install the RCM4110 Module on the Prototyping Board

NOTE: It is important that you line up the pins on header J3 of the RCM4110 module exactly with 
socket RCM1 on the Prototyping Board. The header pins may become bent or damaged if the pin 
alignment is offset, and the module will not work. Permanent electrical damage to the module may 
also result if a misaligned module is powered up.

Press the module’s pins gently into the Prototyping Board header socket—press down in the area above 
the header pins. For additional integrity, you may secure the RCM4110 to the standoffs from the top 
using the remaining two 4-40 × 3/16 screws.

3.  Set Jumpers
Jumpers were placed at the factory on Prototyping Board headers J2, J7, J8, J9, and J15 as shown in Figure 3 
to set up the Prototyping Board for the SPI serial mode used with the sample programs. Application Note 
AN415, RIO Programmable I/O Kit, describes other configuration options.

4.  Connect Programming Cable
The programming cable connects the RCM4110 to the PC running Dynamic C to download programs 
and to monitor the RCM4110 module during debugging.

Connect the 10-pin connector of the programming cable labeled PROG to header J1 on the RCM4110 
as shown in Figure 3. Be sure to orient the marked (usually red) edge of the cable towards pin 1 of the 
connector. (Do not use the DIAG connector, which is used for a normal serial connection to Serial Port A.)

Figure 1.  Insert Plastic Standoffs
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Figure 3.  Prototyping Board and Programming Cable Setup

NOTE: Be sure to use the programming cable (part number 101-0542) supplied with the RIO 
Programmable I/O Kit—the programming cable has blue shrink wrap around the RS-232 con-
verter section located in the middle of the cable. Programming cables with red or clear shrink 
wrap from other Rabbit Semiconductor kits are not designed to work with RCM4110 modules.

Connect the other end of the programming cable to a COM port on your PC.

NOTE: Some PCs now come equipped only with a USB port. It may be possible to use an RS-232/
USB converter (Part No. 540-0070) with the programming cable supplied with the RIO Pro-
grammable I/O Kit. Note that not all RS-232/USB converters work with Dynamic C.

5.  Connect Power
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Once all the other connections have been made, you can connect power to the Prototyping Board.

First, prepare the AC adapter for the country where it will be used by selecting the appropriate plug. 
The RIO Programmable I/O Kit presently includes Canada/Japan/U.S., Australia/N.Z., U.K., and 
European style plugs. Snap in the top of the plug assembly into the slot at the top of the AC adapter as 
shown in Figure 3, then press down on the plug until it clicks into place.

Connect the AC adapter to 3-pin header J1 on the Prototyping Board as shown in Figure 3 above. The 
connector may be attached either way as long as it is not offset to one side—the center pin of J1 is 
always connected to the positive terminal, and either edge pin is ground.
Plug in the AC adapter. The power LED on the Prototyping Board above the power connector at J1 
should light up. The RCM4110 and the Prototyping Board are now ready to be used.

NOTE: If you need to reset the RCM4110, disconnect, then reconnect the power supply.



RIO Programmable I/O Kit
The RIO Programmable I/O Kit is intended to demonstrate how to expand an embedded control system 
design by adding additional I/O and other features. The Kit provides a Prototyping Board with a Rabbit 
RIO chip already installed and configurable header locations to allow you to develop your own appli-
cation using the Dynamic C function calls and sample programs included with the Kit.

Application Kit Contents
The RIO Programmable I/O Kit contains the following items:

• 2 CD-ROMs — Dynamic C® with complete product documentation on disk, and supplemental CD with 
sample programs and information related to the RIO Programmable I/O Kit.

• RCM4110 module.

• Rabbit RIO Prototyping Board.

• Universal AC adapter, 12 V DC, 1 A (includes Canada/Japan/U.S., Australia/N.Z., U.K., and 
European style plugs).
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Once the RCM4110 is connected as described in the preceding pages, start Dynamic C by doub
the Dynamic C icon on your desktop or in your Start menu. Dynamic C uses the serial port sp
installation.
If you are using a USB port to connect your computer to the RCM4110, choose Options > P
Options and check “Use USB to Serial Converter” in “Serial Options.” Click OK to save the

Run a Sample Program
Use the File menu to open the sample program ROTATELED.C in the Dynamic C SAMPLES\
Press function key F9 to compile and run the program.The four LEDs on the Prototyping Board
and off in a rotating sequence, and the Dynamic C STDIO window will open on your PC to disp
of the Rabbit RIO chip’s Channel 1.
This sample program uses Channel 1 with the Rabbit RIO chip operating in the SPI clocked se
cation mode. The Rabbit RIO Chip User's Manual describes the communication modes in mo

Where Do I Go From Here?
If the sample program ran fine, you are now ready to go on to other sample programs and to de
own applications. Application Note AN415, RIO Programmable I/O Kit, discusses how to use
ing Board and explains the sample programs and Rabbit RIO function calls. The source code f
programs is provided to allow you to modify them for your own use. The RCM4100 User's M
Dynamic C CD also provides complete hardware reference information and describes the softw
calls for the RCM4110 RabbitCore module, and the Rabbit RIO User's Manual provides comp
information for the Rabbit RIO chip.
Troubleshooting
If Dynamic C cannot find the target system (error message "No Rabbit Processor Det

• Check that the RCM4110 is powered correctly — the red power LED on the Prototyping Bo
lit when the RCM4110 is mounted on the Prototyping Board and the AC adapter is plugged

• Check both ends of the programming cable to ensure that they are firmly plugged into the P
PROG connector, not the DIAG connector, is plugged in to the programming port on the R

• Ensure that the RCM4110 module is firmly and correctly installed in its socket on the Proto
If there are no faults with the hardware, select a different COM port within Dynamic C. On yo
open Control Panel > System > Hardware > Device Manager > Ports and look at the li
COM ports. In Dynamic C, select Options > Project Options, then select one of the availab
on the “Communications” tab, then click OK. Press <Ctrl-Y> to force Dynamic C to recompile
Dynamic C still reports it is unable to locate the target system, repeat the above steps for anothe
Rabbit and Dynamic C are registered trademarks of Rabbit Semiconductor Inc.

020–0124 • 070715–C

• 10-pin header to DB9 programming cable with integrated level-matching circuitry.

• Getting Started instructions.

• Plastic and metal standoffs with 4-40 screws.

• A bag of jumpers and jumper wires for use on the 
Prototyping Board.

• Rabbit 4000 Processor Easy Reference poster.

• Registration card.

Visit our online Rabbit store at www.rabbit.com/store/ for 
the latest information on peripherals and accessories that 
are available for the Rabbit RIO chip.

COM port. You should receive a Bios compiled successfully message once this step is com-
pleted successfully.
If a program compiles and loads, but then loses target communication before you can begin debugging, it is 
possible that your PC cannot handle the default debugging baud rate. Try lowering the debugging baud rate.

• Locate the Serial Options dialog in the Dynamic C Options > Project Options > Communica-
tions menu. Choose a lower debug baud rate.

If there are any other problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Semiconductor Technical Bulletin Board at www.rabbit.com/support/bb/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.

NOTE: If you purchased your RIO Programmable I/O Kit through a distributor or through a Rabbit 
Semiconductor partner, contact the distributor or partner first for technical support.

Installing Dynamic C®

Insert the CD from the RIO Programmable 
I/O Kit in your PC’s CD-ROM drive. If the 
installation does not auto-start, run the 
setup.exe program in the root directory of 
the Dynamic C CD. Install any Dynamic C 
modules after you install Dynamic C.

http://www.zworld.com/support/bb/index.html
http://www.rabbit.com/support/questionSubmit.shtml
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