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PICDEM™ CAN-LIN 1

USER’S GUIDE
Preface
INTRODUCTION

This chapter contains general information about this manual and contacting customer 

support.

HIGHLIGHTS

Items discussed in this chapter are:

• About this Guide

• Warranty Registration

• Recommended Reading

• Troubleshooting

• Microchip On-Line Support

• Customer Change Notification Service

• Customer Support

ABOUT THIS GUIDE

Document Layout

This document describes how to use the PICDEM™ CAN-LIN 1 Development Board 

as a development system for the PICmicro® PIC18C658 and PIC18C858 

microcontrollers. The manual layout is as follows:

• Chapter 1: Introduction to the PICDEM™ CAN-LIN 1 Board – What the 

PICDEM CAN-LIN 1 Board is, what makes it a desirable development tool and 

what features are available.

• Chapter 2: Getting Started with the PICDEM™ CAN-LIN 1 Board – Describes 

how to connect and begin to use the PICDEM CAN-LIN 1 board.

• Chapter 3: Getting Started with the CANKing Software – Gives a brief 

overview of the CANKing host software and the concept of the pre-defined 

templates.

• Chapter 4: Using the CANKing Templates – Provides a more detailed 

description of the individual templates and how to use them.

• Chapter 5: Reconfiguring the PICDEM™ CAN-LIN 1 Hardware – Describes 

various multi-node configurations of the board, and how to customize certain 

features.

• Chapter 6: Troubleshooting – Provides information on solving common 

problems.
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• Appendix A: PICDEM™ CAN-LIN 1 Technical Information – Provides the block 

diagram and detailed schematics of the PICDEM CAN-LIN 1 board.

• Appendix B: FAQs on Configuring the PIC18CXX8 – Provides a list of the most 

commonly encountered issues when programming PIC18CXX8 microcontrollers, 

as well some solutions.

• Appendix C: PICDEM™ CAN-LIN 1 Software CD – Provides a summary of the 

software on the accompanying CD-ROM.

• Index – Cross-reference listing of terms, features and sections of this document.

• Worldwide Sales and Service – gives the address, telephone and fax number 

for Microchip Technology Inc. sales and service locations throughout the world.

Conventions Used in This Guide

This manual uses the following documentation conventions: 

Documentation Updates

All documentation becomes dated, and this user’s guide is no exception. Since 

MPLAB® IDE, MPLAB C1X and other Microchip tools are constantly evolving to meet 

customer needs, some actual dialogs and/or tool descriptions may differ from those in 

this document. Please refer to our web site to obtain the latest documentation available.

Table:  Documentation Conventions

Description Represents Examples

Code (Courier font):

Plain characters Sample code

Filenames and paths

#define START
c:\autoexec.bat

Angle brackets: < > Variables <label>, <exp>

Square brackets [ ] Optional arguments MPASMWIN [main.asm]

Curly brackets and pipe 

character: { | }

Choice of mutually exclusive 

arguments; An OR selection

errorlevel {0|1}

Lower case characters 

in quotes

Type of data “filename”

Ellipses... Used to imply (but not show) 

additional text that is not relevant to 

the example

list 
[“list_option..., 
“list_option”]

0xnnn A hexadecimal number where n is a 

hexadecimal digit

0xFFFF, 0x007A

Italic characters A variable argument; it can be either a 

type of data (in lower case characters) 

or a specific example (in upper case 

characters).

char isascii (char, 
ch);

Interface (Arial font):

Underlined, italic text 

with right arrow

A menu selection from the menu bar File > Save

Bold characters A window or dialog button to click OK, Cancel

Characters in angle 

brackets < >

A key on the keyboard <Tab>, <Ctrl-C>

Documents (Arial font):

Italic characters Referenced books MPLAB IDE User’s 

Guide
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Documentation Numbering Conventions

Documents are numbered with a “DS” number. The number is located on the bottom of 

each page, in front of the page number. The numbering convention for the DS Number 

is: DSXXXXXA,

where:

WARRANTY REGISTRATION

Please complete the enclosed Warranty Registration Card and mail it promptly. 

Sending in your Warranty Registration Card entitles you to receive new product 

updates. Interim software releases are available at the Microchip web site.

RECOMMENDED READING

This user’s guide describes how to use the PICDEM CAN-LIN 1 Development Kit. The 

data sheets contain current information on programming the specific microcontroller 

devices.

MPLAB® IDE User’s Guide (DS51025)

Comprehensive guide that describes installation and features of Microchip’s MPLAB 

Integrated Development Environment (IDE), as well as the editor and simulator 

functions in the MPLAB IDE environment.

MPASM™ User’s Guide with MPLINK™ and MPLIB™ (DS33014)

This user’s guide describes how to use the Microchip PICmicro MCU MPASM 

assembler, the MPLINK object linker and the MPLIB object librarian.

Technical Library CD-ROM (DS00161)

This CD-ROM contains comprehensive application notes, data sheets and technical 

briefs for all Microchip products. To obtain this CD-ROM, contact the nearest Microchip 

Sales and Service location (see back page) or download individual data sheet files from 

the Microchip web site (http://www.microchip.com).

Embedded Control Handbook (DS00711)

This handbook consists of several documents that contain a wealth of information 

about microcontroller applications. To obtain these documents, contact the nearest 

Microchip Sales and Service location (see back page).

The application notes described in these manuals are also obtainable from Microchip 

Sales and Service locations or from the Microchip web site 

(http://www.microchip.com).

PICmicro® Mid-Range MCU Family Reference Manual (DS33023) and

PICmicro® 18C MCU Family Reference Manual (DS39500)

These manuals explain the general details and operation of the mid-range and 

advanced MCU family architecture and peripheral modules. They are designed to 

complement the device data sheets.

Microsoft® Windows® Manuals

This manual assumes that users are familiar with the Microsoft Windows operating 

system. Many excellent references exist for this software program, and should be 

consulted for general operation of Windows.

XXXXX = The document number.

A = The revision level of the document. 
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TROUBLESHOOTING

See Chapter 6 for information on common problems.

MICROCHIP ON-LINE SUPPORT

Microchip provides on-line support on the Microchip web site at:

http://www.microchip.com

A file transfer site is also available by using an FTP service connecting to:

ftp://ftp.microchip.com

The web site and file transfer site provide a variety of services. Users may 

download files for the latest development tools, data sheets, application notes, 

user' guides, articles and sample programs. A variety of Microchip specific business 

information is also available, including listings of Microchip sales offices and 

distributors. Other information available on the web site includes:

• Latest Microchip press releases

• Technical support section with FAQs

• Design tips

• Device errata

• Job postings

• Microchip consultant program member listing

• Links to other useful web sites related to Microchip products

• Conferences for products, development systems, technical information and more

• Listing of seminars and events

CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip started the customer notification service to help customers stay current on 

Microchip products with the least amount of effort. Once you subscribe, you will receive 

email notification whenever we change, update, revise or have errata related to your 

specified product family or development tool of interest.

Go to the Microchip web site (www.microchip.com) and click on Customer Change 

Notification. Follow the instructions to register.

The Development Systems product group categories are:

• Compilers

• Emulators

• In-Circuit Debuggers

• MPLAB IDE

• Programmers

Here is a description of these categories:

Compilers – The latest information on Microchip C compilers and other language 

tools. These include the MPLAB C17, MPLAB C18 and MPLAB C30 C Compilers; 

MPASM and MPLAB ASM30 assemblers; MPLINK and MPLAB LINK30 linkers; and 

MPLIB and MPLAB LIB30 librarians.

Emulators – The latest information on Microchip in-circuit emulators. This includes the 

MPLAB ICE 2000.

In-Circuit Debuggers – The latest information on Microchip in-circuit debuggers. 

These include the MPLAB ICD and MPLAB ICD 2.
apRNPNO^-page 4  2003 Microchip Technology Inc.
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MPLAB – The latest information on Microchip MPLAB IDE, the Windows Integrated 

Development Environment for development systems tools. This list is focused on the 

MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager and general editing 

and debugging features.

Programmers – The latest information on Microchip device programmers. These 

include the PRO MATE® II device programmer and PICSTART® Plus development 

programmer.

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

• Distributors

• Local Sales Office

• Field Application Engineers (FAEs)

• Corporate Applications Engineers (CAEs)

• Systems Information and Upgrade Hot Line

Customers should call their distributor or field application engineer (FAE) for support. 

Local sales offices are also available to help customers. See the last page of this 

document for a listing of sales offices and locations.

Corporate applications engineers (CAEs) may be contacted at (480) 792-7627.

Systems Information and Upgrade Line

The Systems Information and Upgrade Information Line provides system users with a 

listing of the latest versions of all of Microchip’s development systems software 

products. Plus, this line provides information on how customers can receive the most 

current upgrade kits. The Information Line Numbers are:

1-800-755-2345 for U.S. and most of Canada. 

1-480-792-7302 for the rest of the world.
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USER’S GUIDE
Chapter 1. Introduction to the PICDEM™ CAN-LIN 1 Board
1.1 INTRODUCTION

The PICDEM™ CAN-LIN 1 Development Kit has been developed for the evaluation or 

development of CAN network nodes utilizing Microchip’s PIC18CXX8 family of 

microcontrollers. This tool is ideal for beginning CAN designers, as well as those new 

to the PIC18CXX8 family.

The Demonstration Board provides three nodes (two CAN and one LINbus) that can 

be configured in numerous ways through jumpers and component selection. The CAN 

nodes implement basic input and output functionality, and can send and receive CAN 

bus messages. The Host Software included with the kit allows fine manipulation of the 

PIC18CXX8 devices down to the bit level, as well as high-level control of the 

microcontroller. It also provides predefined templates for demonstration, evaluation 

and development uses.

1.2 HIGHLIGHTS

This chapter discusses:

• PICDEM CAN-LIN 1 Development Kit Contents

• Overview of the PICDEM CAN-LIN 1 Board

• PICDEM CAN-LIN 1 Board Features

• CANKing Host Software

1.3 PICDEM CAN-LIN 1 DEVELOPMENT KIT CONTENTS

Your PICDEM CAN-LIN 1 Development Kit contains the following items:

1. PICDEM CAN-LIN 1 Development Board, complete with three Microchip 

controllers (PIC18C658, PIC18C858 and PIC16C432) preprogrammed with 

demo firmware.

2. A universal power supply (110-230 VAC input, 12 VDC output) and power cable 

for the Development Board.

3. A male-to-female DB9 serial cable for use in communicating with the board.

4. The PICDEM CAN-LIN 1 CD-ROM with CANKing host software, User’s Guide 

and other supporting documents.

5. A warranty registration card.
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1.4 OVERVIEW OF THE PICDEM CAN-LIN 1 BOARD

Most demonstration or evaluation systems use a single microcontroller, and are 

designed to show off that controller’s features. While this makes sense in most 

situations, it also means that users must set up several boards to evaluate even a 

simple network of a few nodes. The drawbacks to this arrangement should be 

obvious.

In contrast, PICDEM CAN-LIN 1 provides three network nodes on one circuit board. 

By using a common power supply and allowing the nodes to be configured in multiple 

ways, the process of evaluating and developing network nodes can be significantly 

streamlined.

The three nodes on the PICDEM CAN-LIN 1 board are:

• Node0, a CAN node implemented with a 68-pin PIC18C658 microcontroller. This 

node interfaces to the external host computer through a standard serial (RS-232) 

interface, and is directly controlled by the host software. It monitors both the 

on-board and external CAN busses, and can be used for basic PIC18CXX8 

evaluation/development. 

• Node1, a CAN node implemented with an 84-pin PIC18C858 microcontroller. This 

node communicates with Node0 over the on-board CAN bus. It also implements 

the CAN-to-LINbus gateway to Node2 (below), and acts as the LINbus master 

node. Like Node0, Node1 can also be used for basic PIC18CXX8 

evaluation/development. 

• Node2, a LINbus slave node, is implemented with the 20-pin PIC16C432 

microcontroller with integrated LINbus transceiver. It communicates to Node1 via 

the LIN bus.

Both the CAN and LIN busses are routed off-board through a connector, which allows 

the board to be connected to an external bus.

1.4.1 Benefits of Using the PICDEM CAN-LIN 1 Board

Putting three nodes on one board gives the developer some definite benefits: 

MULTIPLE HARDWARE CONFIGURATIONS WITH ONE BOARD: Of course, the 

PICDEM CAN-LIN 1 board accommodates a large selection of CAN and LIN node 

combinations. In addition, users can implement any one of three oscillator 

configurations for the CAN nodes, or easily add other hardware to the board using the 

prototyping area and headers. 

Many of these configuration changes are performed with jumpers, while others require 

component additions or removals. The board configurations and jumper locations are 

discussed in detail in chapters 5 and 6.

EASIER CAN NODE EVALUATION: The CANKing host software included with the 

PICDEM CAN-LIN 1 Development Kit allows for fast evaluation of CAN node 

operation, as well as the CAN protocol. Using one of the included template sets, users 

can evaluate everything from bit-level status of registers to node operation and bus 

status. The host software and the templates are discussed in detail in Chapter 3 and 

Chapter 4.

ENHANCED CAN NODE DEVELOPMENT: Including two CAN nodes on the 

PICDEM CAN-LIN 1 board provides an additional tool for developing 

PIC18CXX8-based CAN nodes, either by themselves or together. For example, a user 

might use the controller in Node1 to prototype a CAN node, while using Node0 as a 

simple bus monitor (using the basic template). Node0 could also be used as a tool to 

set or verify bit timings, masks or filters.
apRNPNO^-page 8  2003 Microchip Technology Inc.
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The possibilities are not limited to what can be developed with just the nodes on the 

board, either. For example, Node0 can be included as part of a more complex 

developmental network of many CAN nodes, and serve as the “tap point” for 

monitoring the entire network.

1.5 PICDEM CAN-LIN 1 BOARD FEATURES

As mentioned, the PICDEM CAN-LIN 1 board consists of two CAN nodes 

(PIC18C658 and PIC18C858) and one LIN node (PIC16C432). Node0, implemented 

by the PIC18C658 controller, acts as the main node. It interfaces with the host 

software through a serial connection (RS-232), and either executes commands from 

the host system or passes them to Node1. Node0 also interfaces with the on-board 

LCD header. If an LCD is connected, Node0 can display text messages under host 

software control.

Node1, implemented by the PIC18C858, also acts as a CAN node and demonstrates 

a CAN-to-LIN bridge. This node is controlled via Node0, which relays commands for 

Node1 from the host system. Node1 receives these messages and performs the 

appropriate actions. This node also acts as a LIN master mode and provides 

CAN-to-LIN bridge functionality to Node2. As a LIN master, it receives messages from 

Node0 and relays them to the LIN slave node. 

Node2 is a LIN slave node implemented by the PIC16C432. This node contains an 

integrated LINbus transceiver. It waits for commands from Node1and performs the 

appropriate actions.

As configured from the box, the behavior of the CAN nodes is determined by its 

hardware configuration. While Node0 and Node1 both execute the exact same code, 

the function of the node is decided by its hardware configuration. When either node is 

reset, its firmware attempts to communicate with the external EEPROM. If the 

EEPROM is found, the code assumes the role of Node0, and uses the USART to 

communicate with the host system. If the EEPROM is not found, it assumes the role of 

Node1 and uses the USART for LIN bus communication. Since the EEPROM is 

hard-wired to the Node0 (PIC18C658) controller, this essentially guarantees that this 

controller will always be Node0.

Node0 and Node1 are connected via the on-board CAN bus, which is also available to 

an external CAN bus through a D-shell connector. Node1 and Node2 are connected 

via on-board LIN bus. Node1 uses a separate LIN transceiver while Node2 uses an 

integrated LIN transceiver. The board routes on-board LIN bus to 3-pin header for 

connection to external LIN devices.

The overall layout of the board is shown in Figure 1-1.
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FIGURE 1-1: THE PICDEM CAN-LIN 1 BOARD (TOP ASSEMBLY VIEW)

The main features of the board include:

1. Node0 Microcontroller: This is a socketed 68-pin PLCC PIC18C658 with 

integrated CAN module. It also controls the communications to the host 

computer (via RS-232), as well as the external serial EEPROM and the optional 

LCD module.

2. Node1 Microcontroller: This is a socketed 84-pin PLCC PIC18C858 with 

integrated CAN module. This node communicates with Node0 and any external 

CAN nodes over the on-board CAN bus. It also serves as the LIN master, and 

communicates to Node2 and other external LIN nodes over the on-board LIN 

bus.

3. Node2 Microcontroller: This is a 20-pin DIP PIC16C432 with integrated LIN 

bus transceiver. It acts as a LIN slave and transfers data to and from Node1.

4. Oscillators: Node0 and Node1 each support three different oscillator 

configurations (Crystal, RC and Canned). The board is factory-equipped with 

25 MHz canned oscillators for both of the CAN nodes. If a different oscillator type 

is required, the board hardware must be re-configured (see 5.3 “Oscillator 

Configurations” for more information). Node2 uses an RC oscillator only (not 

shown). It cannot be re-configured.

5. Reset Push Buttons: Each of the microcontrollers has its own RESET push 

button switch, tied to the MCLR pin. Pressing the switch causes a hard controller 

reset.

6. CAN Node User-Defined Switches: Two push button switches are connected 

to each the CAN nodes to simulate digital inputs. Their status can be monitored 

through the host software.
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7. CAN Node Potentiometers: These analog potentiometers (7a and 7b) are 

connected to Node0 and Node1, respectively. These potentiometers simulate 

analog inputs for their controllers, and control the brightness of the 

PWM-controlled LED on the other CAN node (i.e., the Node0 potentiometer 

controls the brightness of Node1’s LED, and vice versa). Their real-time status is 

also displayed by the host software.

8. Node2 Potentiometer: This analog potentiometer is connected to Node2. When 

Node2 is configured for “Poll Automatically” option, the real-time status of this 

potentiometer is displayed by the host software.

9. CAN Node LED Banks: Both Node0 and Node1 are connected to their own 

bank of nine LEDs: one 8-bit LED port and one PWM-controlled LED. The 8-bit 

LED shows the (digital) status of PORTD of the controller, and can be modified 

under software control. The output of the PWM-controlled LED is continuously 

variable, and is determined by the value of the other CAN node’s potentiometer 

(7a or 7b), as noted. For the LEDs to function, their associated LED Enable 

jumper (JP3 or JP4) must be installed.

10. Node2 LED Bank: An 8-bit LED port is connected to PORTB of the LIN slave 

node, and shows its (digital) status. The display can be modified under software 

control. The LED Enable jumper JP5 must be installed for the bank to function.

11. CAN Transceivers: The MCP2551 transceivers (one for each CAN node) 

convert the differential signal on the CAN bus to levels that are compatible with 

the PIC18 microcontrollers.

12. LIN Transceiver: The MCP201 transceiver converts the high-voltage signals 

from the LIN bus to levels compatible with the PIC16 microcontroller.

13. External EEPROM: A 24LC16 serial EEPROM is included for the use of 

developers in creating a full range of prototype devices. This is a 16 Kbit device 

which is programmable by a two-wire I2C interface. The EEPROM memory is 

controlled by Node0. Its contents may be read or modified via the host software 

interface. 

14. RS-232 (DB9F) Port: A standard D-shell connector provides a serial connection 

to control and monitor the Demonstration Board. Since it uses a standard 232 

level shifter, this connector can also be used as a standard serial port for 

prototype applications.

15. CAN Connector (DB9M): This connector allows the on-board CAN nodes to be 

connected to an external CAN bus.

16. LIN Connector (3-pin) Pad: A space is provided to add a 3-pin connector, 

allowing the on-board LIN node to connect with an external LINbus.

17. ICSP Connectors: Pads are provided to add two 6-wire RJ-11 jacks. When 

connected, they allow the CAN Node microcontrollers to be connected to an 

external programmer and programmed on the board.

18. Power Connector: Power (12 VDC) is supplied to the board from the power 

adapter through a 4-pin mini-DIN jack. Alternatively, external power can be 

provided through the 2-pin terminal block. On-board regulators provide separate 

+5 VDC sources for analog and digital circuits. Both inputs are protected from 

accidental polarity reversal. Direct 12 VDC is also available to appropriate 

circuits.

19. Power LED (Red): This is lit to show that power is being supplied to the 

Demonstration Board.
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20. LCD Connector: This 14-pin header allows the addition of a standard LCD 

controller module (such as Hitachi HD4478 or equivalent) to the demonstration 

board.

21. Prototype HeaderS: These connector pads are provided for users to directly 

access the I/O port signals for all the microcontrollers. As an option, headers may 

be installed in these locations.

22. MCU Prototype Area: This grid is provided for prototyping controllers that are 

not supported by the existing sockets. The area is provided with connections for 

analog and digital power (separate +5 VDC sources), VBAT for LIN (up to 

+12 VDC) and ground connections.

1.6 CANKing HOST SOFTWARE

Included with the Development kit is the CANKing host software. Developed by 

Kvaser AB, the CANKing package allows users to examine and control the board’s 

operation in detail, as well as monitor CAN node operations. Interfaces are 

implemented through a series of three pre-designed templates, which are grouped by 

functionality (CAN node evaluation and control, board-level control, etc.). CAN-related 

templates are designed around the CAN Kingdom upper-layer protocol primitives; 

previous experience with this CAN design system is helpful, but not strictly necessary.

Installation and overall operation of the host software is discussed in Chapter 3. The 

CANKing templates are detailed in Chapter 4.
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Chapter 2. Getting Started with the PICDEM™ CAN-LIN 1 Board
2.1 HIGHLIGHTS

This chapter will cover the following topics:

• Host Computer Requirements

• Using the PICDEM™ CAN-LIN 1 Board For the First Time

• Checking the Board in Evaluation Mode

2.2 HOST COMPUTER REQUIREMENTS

To communicate with and program the PICDEM™ CAN-LIN 1 Development Board, 

you must have a system that meets the following hardware and software 

requirements:

• PC-compatible system with an Intel 80486 class or higher processor, or 

equivalent

• A minimum of 16 MB RAM 

• A minimum of 5 MB available hard drive space 

• CD-ROM drive (for use with the accompanying CD)

• One available standard serial port, with a matching COM port available through 

the operating system

• Any 32-bit version of Microsoft Windows (Windows 95 or 98, Windows NT, 

Windows 2000 or Windows XP)

2.3 USING THE PICDEM CAN-LIN 1 BOARD FOR THE FIRST TIME

For evaluating the PICDEM CAN-LIN 1 board, the simplest configuration uses a host 

computer connected directly to the board using a crossover cable. Creating this setup 

involves the following steps:

1. Installing the CANKing Host Software

2. Connecting the PICDEM CAN-LIN 1 board to the host system

3. Starting the Host Software
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2.3.1 Installing the Host Software

The installation of the host software package is completely automated, and does not 

require any user intervention or configuration once the process is started. The process 

is identical for all 32-bit Windows operating systems. Users with Windows NT -based 

desktops (NT 4.0, 2000 and XP) should not need to have administrative rights to their 

systems for this installation. Closing all background applications before proceeding is 

helpful, but not required.

To install the host software:

1. Insert the PICDEM CAN-LIN 1 Software CD into your system’s CD-ROM drive.

2. Double-click on “My Computer”, then on the icon for the CD-ROM.

3. Double-click on the “wc32mchip_pic.exe” icon. Installation will proceed 

automatically, and take 1-2 minutes.

Alternatively, run the installation by selecting Run from the Start menu. At the dialog 

box, enter:

x:\wc32mchip_pic

where “x” is the drive letter of your CD-ROM.

The installation process will install the host software package, as well as the templates 

and help files. By default, all files are installed by default in the directory \Program 

Files\Microchip under the root level of your hard drive. A short cut for the host 

software is also installed under Programs from the Start menu (Programs > Microchip 

> CANKing). 

2.3.2 Connecting the PICDEM CAN-LIN 1 Board

The basic connections are shown in Figure 2-1.

1. Power down the host system. (This isn’t strictly necessary, but it’s always a good 

safety idea – particularly if you need to re-arrange cables or move the system.)

2. Unbox and unwrap the board, and set it on a non-conductive surface near the 

host system.

3. If they aren’t installed already, install the microcontrollers in their respective 

sockets. Check that they are completely seated, and that all pins are making 

contact.

Note: It is possible that some organizations may implement a desktop computer 

policy sufficiently restrictive to prevent the user from loading any software 

at all. In theory, this can be done with any 32-bit Windows operating 

system on a network – including Windows 95. If this describes your 

situation, contact your local Information Services provider for assistance 

in installing this software.

Note: Always use the suggested default path for installing the host software. 

Because of certain software dependence, it may not work correctly if 

installed elsewhere.
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FIGURE 2-1: CONNECTIONS BETWEEN THE PICDEM CAN-LIN 1 BOARD 

AND THE HOST COMPUTER

4. Connect the serial cable (supplied in the kit) to the RS-232 connector on the 

board, then to the open serial port on your computer.

5. Connect the mini-DIN plug of the power supply to the Power Input jack on the 

board.

6. Plug the power adapter into your wall socket or power strip.

7. Check the board. The green Power LED should light, and the Node0 port LEDs 

should briefly flash once. If they don’t, check all connections with the power 

supply and the board. For additional assistance, refer to Chapter 6 

("Troubleshooting").

8. Power up the host system.

Note: If your available serial port is a DB25 male connector, you will need to use

a DB25F-to-DB9M port adapter, sometimes known as an “external modem

adapter”. Check with your local electronics parts store or your Information

Services provider for additional information.

Host Computer

Serial Port
(COM1 or
COM2)

12 VDC from
Power Supply

PICDEM™ CAN-LIN 1 Board

Serial Cable

Serial Port

(DB9 to DB9)
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2.3.3 Starting the Host Software for the First Time

With the software installed and the PICDEM CAN-LIN 1 board connected, all you 

need to do is to actually start the host software and confirm communications.

1. From the Start menu, select Programs > Microchip > CANKing;

OR

From a command window (DOS window on Windows 95/98), navigate to the 

directory \program files\microchip, then enter:

wc32 

However it is started, the CANKing welcome dialog box appears (Figure 2-2).

FIGURE 2-2: THE CANKing WELCOME DIALOG

2. Select the “Start using CANKing” option. Optionally, to remove the dialog from 

future startups, check the “Don’t ask me again” box. Click on “OK”.

3. At the subsequent “Warning!” dialog, click on “OK, I Know What I’m Doing” to 

proceed. Optionally, check “Don’t show me this warning in the future” to remove 

this dialog from future startups.

4. At the next dialog box (Figure 2-3), select the “Template” option under “Create a 

New Project Using”. Click “OK”.

Note: The cautions against personal injuries in this dialog refer to those cases

where the PICDEM CAN-LIN 1 board is being used in the evaluation and

development of live automotive and industrial networks. Obviously, this

doesn’t apply to situations where the board is being used in isolation to

prototype network nodes.
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FIGURE 2-3: CREATING A NEW PROJECT

5. At the “Templates” dialog, select “PIC18+CAN Evaluation Board”. Click on “OK”.

6. A series of smaller windows and dialog boxes is launched as part of the 

Evaluation Board template (Figure 2-4). Go to the “CANKing for Windows” menu 

at the top of the screen, and select Options > PIC18+CAN... (you will need to 

close the “Tip of the Day” window at center screen first).

FIGURE 2-4: THE EVALUATION BOARD TEMPLATE AT LAUNCH 

(CANKing MAIN MENU BAR AT TOP LEFT)
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7. At the “Evaluation Board Options” dialog, select the following options from the 

appropriate drop-down menus:

• Clock Frequency: 25000 kHz (25 MHz)

• COM Baud Rate: 38400 bps

• COM Port: (the port that the board is connected to)

Under “Options for the Current Configuration”, check “Reset PIC18+CAN on

Open”.

Click “OK”.

8. In the Evaluation Board window (which launched along with the other windows 

of the Evaluation Board template), the “Connected” status indicator turns green, 

and a message indicating a successful serial connection appears.

Click on “Reset Board”. The green light stays on, and the message below it 

changes to “Eval Board is in Disable Mode” (Figure 2-5).

FIGURE 2-5: THE EVALUATION BOARD WINDOW, SHOWING A 

SUCCESSFUL CONNECTION

9. In the CAN Controller window, click on “Go on Bus.” The On Bus light turns 

green. At the same time, the message in the Evaluation Board window changes 

to “Eval Board is in Normal Mode”.

10. In the Evaluation Board window, click on “Setup Modules”. Output information 

from the board appears in the Output window.

The PICDEM CAN-LIN 1board is now ready to respond to control inputs from the host 

software.
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2.4 CHECKING THE BOARD IN EVALUATION MODE

While the board is connected to the host system and the host software is using the 

Evaluation template, it may be useful to verify its operation. This is also a good way to 

show off the board’s capabilities.

After following the instructions in 2.3 “Using the PICDEM CAN-LIN 1 Board for the 

First Time”, do the following:

1. Slowly turn the Node0 potentiometer clockwise and counterclockwise. The right 

most LED of Node1’s LED bank should brighten and dim. At the same time, the 

“Pot Value” displayed in the Node0 Eval Board window should increase and 

decrease, while the “PWM Intensity” indicator in the Node1 Eval Board window 

should increase and decrease by the same amount.

2. Slowly turn the Node1 potentiometer clockwise and counterclockwise. The right 

most LED of Node0’s LED bank should brighten and dim. At the same time, the 

“Pot Value” displayed in the Node1 Eval Board window should increase and 

decrease, while the “PWM Intensity” indicator in the Node0 Eval Board window 

should increase and decrease by the same amount.

3. Click on any of the LED buttons in either of the CAN node’s windows. The 

corresponding LED on the board should toggle on or off.

4. In the Node2 Eval Board window, select the “Count LEDs” check box. Both the 

LED buttons in the window, as well as the Node2 LEDs on the board, should start 

counting up in binary and in sync with each other.

If all of these tests worked, you are now ready to start working with the board.

Note: While this may seem anti-intuitive, using one node’s potentiometer to 

affect the other’s LED does prove a point. For this demonstration, we 

are showing that an analog input from one microcontroller can be 

communicated across the CAN bus to control the PWM output of the

other microcontroller.
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Chapter 3. Getting Started with the CANKing Software
3.1 HIGHLIGHTS

The items discussed in this chapter are:

• Software Overview

• Starting the Program

• Introduction to the Templates

• The Main Menu

• The Output Window

• Customizing Projects

3.2 SOFTWARE OVERVIEW

The CANKing Host Software provides a comprehensive interface to control the 

board’s operation. To make things easier, the program uses three distinct, pre-defines 

templates that perform specific functions.

3.3 STARTING THE PROGRAM

To run CANKing, select Programs > Microchip > CANKing. from the Start menu. 

Alternatively, double-click on the CANKing icon or shortcut. 

If you have not disabled them on the first use of the software, you will see the initial 

CANKing dialog and Warning window (see 2.3.3 “Starting the Host Software for the 

First Time” for details). if they appear, click “OK” at these dialogs to continue.

At the Open a Project or Template dialog (simply titled “CANKing for Windows”), select 

the “Template” option for creating a new project. (The other options listed are not 

available in this version of CANKing, and should be grayed out.) Click “OK”. 

At the “Templates”, select the appropriate template and click “OK” to launch it. You can 

also directly launch the template by double-clicking on its icon.

If you have an alternate template or project you wish to use, select the “Open an 

Existing Project” option at the Open a Project dialog. A standard Windows dialog 

allows you top browse for the desired folder. Custom projects and templates are 

covered in more detail in 3.7 “Customizing Projects”.
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3.4 INTRODUCTION TO THE TEMPLATES

Much of the host software’s versatility comes from its use of pre-defined templates. 

Because of the potential complexity of managing a microcontroller at the bit level – let 

alone a network protocol such as CAN – the problem of organizing all the information 

and controls that a user might need to evaluate and manage becomes a major 

challenge. CANKing simplifies matters by grouping all the necessary controls for a 

particular type of task into a template. Launching the template activates the necessary 

individual control or monitor windows that are required for the task. Users have the 

option to close or re-open particular windows as needed.

The individual templates and their controls are covered in detail in Chapter 4 ("Using 

the CANKing Templates"). A brief overview is given below.

3.4.1 PIC® Register View Template

The PIC Register template allows low-level control of Node0. It is typically used to 

evaluate and test the PIC18CXX8 at the register and bit level. All of the registers 

required for complete configuration of the CAN module are available in this template.

3.4.2 Basic Template

The Basic Template is a high-level tool which focuses on CAN bus traffic. It is typically 

used to observe the PIC18CXX8 while on the bus. The development of a CAN node 

based on Node1 can be evaluated by using this template with Node0.

3.4.3 PIC18+CAN Evaluation Board Template

The Evaluation Board template provides real-time control of the entire board as a 

demonstration tool. It allows users to control the LEDs for each of the nodes, and 

monitor in real-time the status of the user push buttons and potentiometers.

3.5 THE MAIN MENU

Launching any of the templates, or opening any existing CANKing project, always 

places a common toolbar at the top of the screen. The overall operation of CANKing is 

controlled from here. The menu options available are, with a very few exceptions, 

universal across all of the templates.

The File menu implements a standard set of Windows options. Users can create a 

new project, save an existing project, open or reopen an existing saved project, close 

the existing project without exiting CANKing and exit CANKing entirely.

The View menu allows the user to selectively open and close any of the windows and 

dialogs available within the template. By default, each template opens only some of 

the windows available to it. All of the windows available within a template are listed in 

the View menu, allowing the user to select only those that are needed (or all windows, 

if required).

The Messages menu is context-sensitive. Depending on the template, it either opens 

(or shifts focus to) a specific configuration or message window, or selects the format 

for the next CAN message to be sent. This is covered in more detail in 

4.5 “Template-Specific Variations in the Main Menu”.

The Options menu sets program-wide operational options for CANKing. The 

PIC18+CAN... selection configures hardware and communication options with the 

board (see Figure 2-3). The Global... selection configures software options for 

CANKing’s operation, such as the displayed numeric base of data and auto-save on 

exit.
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The Window menu lists the open windows and dialogs, and lets the user bring any 

one of the windows to the foreground. Unlike the View menu, this menu only shows 

those windows which are active.

The Help menu provides access to indexed and interactive on-line product help, as 

well as Internet links to Kvaser’s CANKing web site. Context-sensitive help is also 

available by pressing F1.

The main menu toolbar (Figure 3-1) is the same for all templates. It provides standard 

Windows toolbar buttons for creating a new project, and opening and saving an 

existing project. Icons are also provided to go on and off the CAN bus; they are always 

present, but functional only in the Basic and Evaluation templates.

FIGURE 3-1: THE CANKing MAIN MENU

3.6 THE OUTPUT WINDOW

Common to both Basic and PIC18+CAN Evaluation templates is an output window, 

which displays the messages that are received and transmitted by Node0. This 

window can be reconfigured to display messages in different formats. The formats are 

changed using a combination of the Message Formatter dialog box and the right 

mouse button.

The Message Formatter window (titled “Select Formatter”) selects one or more of 

several pre-defined formats for the window. The format type may be specific to a 

particular usage (e.g, a King’s page interpreter or a LINbus message interpreter) or a 

generic text format. More than one formatter may be selected, and their order of 

display may be arranged at will. Many of the formats can be fine-tuned with their own 

configuration options. For additional information, see 4.3.3 “Select Formatters 

Window”.

Using the right mouse button in this window brings up a menu with several options:

• Options allows the user to set the font used in the window, as well as the 

maximum number of lines available in the window’s buffer.

• Fixed Positions effectively assigns a slot for each message identifier. As 

messages with the same ID are received or transmitted, they overwrite the 

contents of the previous message with the same ID. Used in conjunction with the 

delta time feature, the frequency of each message type can be observed.

• Copy to Clipboard copies the contents of the window’s buffer to the Windows 

clipboard.

• Clear empties the window and its buffer.

Create New Project

Open Existing Project

Save Project

Go On Bus Go Off Bus
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FIGURE 3-2: TYPICAL OUTPUT WINDOW (STANDARD TEXT FORMAT 

SHOWN)

3.7 CUSTOMIZING PROJECTS

The templates furnished with the CANKing host software provide a quick way to 

connect to the PICDEM™ CAN-LIN 1 board and examine its operation. As you gain 

experience with the board and the software, however, you may want to customize 

your environment. For example, you may want to launch a different set of controls 

than those that a particular template uses as its default. Alternatively, you may want to 

use different communications settings. The host software accommodates these needs 

by allowing users to save CANKing projects with their particular settings, preserving 

both hardware and window configurations.

To save a configuration, use the File > Save As menu option. CANKing allows you to 

save either as a project (.wcc file extension), or a new template (.wct extension). A 

standard Windows dialog permits you to browse folders for the desired location.

To open a previously-saved project, either choose the “Open an Existing Project” from 

the dialog box, or use the File > Open menu option. A standard Windows dialog box 

permits you to browse folders for the desired file.
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Chapter 4. Using the CANKing Templates
4.1 HIGHLIGHTS

The items discussed in this chapter are:

• PIC® Register View Template

• The Basic Template

• PIC18+CAN Evaluation Board Template

• Template-Specific Variations in the Main Menu

4.2 PIC REGISTER VIEW TEMPLATE

This template allows low-level control of Node0. It is typically used to evaluate and 

test the PIC18CXX8 microcontroller at the bit level. All of the registers required for 

complete configuration are available in this template.

Values for buffer and control registers can be changed on both the byte and bit levels. 

To modify the register on a byte level, enter the value in the boxes next to the register 

names. Notice that the bit values will reflect the entered byte values.

To modify the registers at the bit level, double-click the desired bit. The bit will toggle 

for each double click and the byte representation will be reflected next to the register 

name. The bit boxes are only modifiable when unshaded. Shaded bit boxes are read 

only bits.

FIGURE 4-1: PIC REGISTER VIEW TEMPLATE (WHOLE-SCREEN VIEW 

SHOWING THE AVAILABLE WINDOWS AT STARTUP)
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4.2.1 PIC18+CAN Evaluation Board

This window is functionally available in all three templates, but is named and 

configured in a slightly different manner for each. In each template, it displays the 

current communication status with the board. When a successful connection is 

detected, the “Eval Board Status” LED turns green and displays a “connected” 

message. The window also shows the current COM port setting and any log 

messages as the host software communicates with the board.

In the PIC Register template, the window provides three control buttons. “Reset 

Board” causes a reset of the board’s firmware, and erases all previous settings. “Save 

Reg” saves the current register values as a hex file; a standard Windows dialog allows 

the user to browse for the file location. “Load Reg” restores previously-saved register 

values from a hex file, and also uses a Windows dialog to search for the file’s location.

FIGURE 4-2: PIC18+CAN EVALUATION BOARD WINDOW 

(REGISTER TEMPLATE VERSION, BOARD NOT 

CONNECTED)

4.2.2 PIC18+CAN Message Filters

This window is used to set up and test mask and filter combinations with different 

message identifiers. Each mask and filter can be tested without actually writing the 

configuration to Node0. This is done to allow the user to test different configurations 

against message identifiers that would appear on the bus. When the desired mask 

and filter combinations are achieved, the values can be written to the Node0 by 

clicking the ‘Write’ button.

Note: The masks and filters can be written only when the Node0 is in

configuration mode.
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FIGURE 4-3: MESSAGE FILTER WINDOW

4.2.3 PIC18+CAN Physical Layer

The Physical Layer window is where the CAN bus rate is configured. The user has 
bit-level control of the three BRGCON registers (BRGCON1, BRGCON2 and BRGCON3), 
which sets up all items required for CAN bit timing including the time quanta (TQ), bit 
segments, the synchronization jump width (SJW), and the baud rate prescaler (BRP).

The calculated bit rate is shown at the bottom of the window. For this calculation to be 
valid, the oscillator value must be correct. To change the oscillator value, select 
Options->PIC18+CAN... from the main menu.

The BRGCON registers can be modified only when Node0 is in configuration mode. The 
bit will be shaded and cannot be modified in other modes of operation.

FIGURE 4-4: PHYSICAL LAYER WINDOW
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4.2.4 PIC18+CAN Receive Buffer

This window contains all of the buffer contents for the receive buffers including 

RXBnCON, the identifier registers and the data registers.

RXB0CON and RXB1CON are the only registers in this window that are not read-only, as 

indicated by the unshaded bit locations. These two registers set up the receive modes 

and enables or disables the hardware double-buffer function.

The Receive Buffer windows allows users to select one buffer to view at a time. 

Multiple Receive Buffer windows can be opened for simultaneous viewing by holding 

down the Shift key while selecting the Receive Buffer option from the Windows menu 

(Messages > PIC18+CAN Eval Board > Receive Buffer).

FIGURE 4-5: RECEIVE BUFFER WINDOW

4.2.5 PIC18+CAN Status Window

The Status Window displays the contents of the CANSTAT register, the COMSTAT 

register, and the counts for the receive and transmit error counters. The condition of 

the registers are also shown (for example, a CANSTAT value of 80h displays the 

condition as Configuration mode with no interrupts pending).

The window also contains controls to clear overrun conditions for each of the receive 

buffers.

FIGURE 4-6: PIC18+CAN STATUS WINDOW
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4.2.6 PIC18+CAN Transmit Buffer

This window controls the buffer contents for the three transmit registers including 

TXBnCON, the identifier registers and the data registers.

Like the other register windows, the Transmit Window maps the byte values to the bit 

boxes. Entering data into the CAN ID box maps to multiple registers (SIDH, SIDL, 

EIDH and EIDL). For example, entering ‘1FFFFFFF’ in the CAN ID box maps all ‘1’s to 

SIDH, SIDL, EIDH and EIDL.

Like the Receive Buffer, the Transmit Buffer window allows users to select one buffer 

to view at a time. Multiple Transmit Buffer windows can be opened for simultaneous 

viewing by holding down the Shift key while selecting the Receive Buffer option from 

the Windows menu (Messages > PIC18+CAN Eval Board > PIC18+CAN Transmit 

Buffer).

FIGURE 4-7: TRANSMIT BUFFER WINDOW
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4.2.7 PIC18+CAN Configuration

This window displays and can directly control the contents of the CAN control and 

peripheral interrupt registers (CANCON, CIOCON, PIE3, PIR3 and IPR3). These are the 

control and flag registers for the PIC18C658 microcontroller.

A complete discussion of the function of these registers is beyond the scope of this 

manual. Interested readers are referred to the PIC18CXX8 Data Sheet (DS30475) for 

more information.

FIGURE 4-8: .PIC18+CAN CONFIGURATION WINDOW

4.3 THE BASIC TEMPLATE

The Basic Template is a high-level tool which focuses on CAN bus traffic. The user 

only has high-level control of Node0 (i.e., no direct register control) which includes:

• Configuring the bus rate

• Changing modes of operation (Configuration and Normal)

• Configuring a transmit register (the register number is predefined)

• Transmitting messages

• Resetting Node0

Other functions of the basic template are receiving messages, saving transmitted 

messages, starting timed transmissions and observing the bus loading. Details of 

these functions can be found later in this section under the details of the individual 

windows.

This template would typically be used as a simple bus monitor that could be used to 

evaluate the PIC18CXX8 on a CAN bus, or assist in development by monitoring how 

Node1 is operating.

By default, the Basic template configures Node0 to receive ALL messages. The user 

has the option to maintain Node0 configurations when switching templates by 

selecting Options > PIC18+CAN... and deselecting the “Reset PIC18+CAN on 

Opening” check box. Keep in mind that deselecting this box may create unforeseen 

problems if the Node0 was not configured properly previously.
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FIGURE 4-9: THE BASIC TEMPLATE (WHOLE-SCREEN VIEW SHOWING 

THE AVAILABLE WINDOWS AT STARTUP)

4.3.1 PIC18+CAN Evaluation Board

This window is similar in function to the Evaluation Board window in the PIC Register 

template (4.2.1 “PIC18+CAN Evaluation Board”) in displaying the current 

communication status of the board. For the Basic template, there is only one control, 

the “Reset Board” button; it resets the firmware and writes power-on default values to 

all of Node0’s CAN registers.

FIGURE 4-10: PIC18+CAN EVALUATION BOARD WINDOW 

(BASIC TEMPLATE VERSION)
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4.3.2 PIC18+CAN Controller

This window provides information about the status of the bus including nominal bus 

loading, status of node (on or off the bus), and bus bit rate. The tabs at the top of the 

window select between “Bus Statistics” and “Bus Parameters” pages.

On the “Bus Statistics” page, the bus loading, bus parameters and bus status can be 

viewed. The bus loading shows the nominal load on the CAN bus as a percentage 

and as a number as well as the total number of messages sent and received. The bus 

parameters reflect the parameters set in the Bus Parameters view (i.e., Bit rate, 

number of TQ, bit segment lengths and the location of the sample point). The Bus 

Status shows the mode of operation and error states; this is also where the controls to 

put the board “On Bus” (Normal Operation) or “Off Bus” (Configuration mode) are 

located.

Options on the “Bus Parameters’ page allow the user to configure the bus rate, the 

sample point, the Synchronization Jump Width (SJW) and switching between Normal 

and Listen Only modes of operation.

FIGURE 4-11:  PIC18+CAN CONTROLLER WINDOW
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4.3.3 Select Formatters Window

This window determines the format of the displayed data in the output window. 

CANKing provides a number of pre-defined general and specialized format options for 

data display. Many of these formats can in turn be fine-tuned with specific 

configuration options. The default is “Standard Text Format” which displays the 

message data as normal data. 

To add a formatter for the output window, select an option from the “Available 

Formatters” spin box, and click on the “Use” button. Alternatively, you can double-click 

on the item. The formatter is successfully selected when it appears in the “Active 

Formatters” window and its check box is selected.

To de-activate a formatter, select the item from the Active Formatters window and 

click the “Remove” button. You can also temporarily de-activate an option by 

deselecting the check box next to it.

To change the order that formatters are applied to the output window, select a 

formatter in the Active Formatters window and click on the “Up” or “Down” buttons.

The properties of the formatter can be changed by pressing the Properties button 

while the selection is highlighted in the Active Formatter list. The properties of the 

Standard Text Format are the numeric base of the display (octal, decimal or 

hexadecimal) and whether or not to display the message time stamp as a running total 

or as delta time. Many of the other formatters have their own unique configuration 

properties (e.g., filter limits, message interpreters).

FIGURE 4-12:  MESSAGE FORMATTERS WINDOW

4.3.4 Output Window

The output window is discussed in detailed in 3.6 “The Output Window”.
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4.3.5 History List

This window is used to collect transmitted messages for saving to a file. It is not 

opened by default when opening a new template, but by selecting View > History List 

from the main menu. Once opened, every transmitted message is captured in the 

History List window for saving to a file if desired. Each line consists of Identifier, Data 

Len, Data Byte D0 through Data Byte D7. One or more messages can be selected for 

retransmission. There is also a button for sending all the captured messages. 

The History List window works in conjunction with the Timed Transmission window. 

Messages can be retransmitted once, or continually at defined intervals. See the 

Timed Transmission window (4.3.6 “Timed Transmission”) for more details.

FIGURE 4-13: HISTORY LIST WINDOW

4.3.6 Timed Transmission

The Timed Transmissions window is used to send the messages in the history list, 

either once or continually at timed intervals.

The One Shot mode sends the selected (in the History List window) messages one 

time each time the send buttons are pressed in the History List window.

The Cyclic selection sends the selected messages at regular intervals (from 1 ms to 

10 s). The interval is set with the fixed-interval spin box.

The other Message Timing selections (Just-in-Time and Manual) are not available in 

this version of the software.

FIGURE 4-14: TIMED TRANSMISSION WINDOW
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4.4 PIC18+CAN EVALUATION BOARD TEMPLATE

For most users, this is the very first template used when the PICDEM™ CAN-LIN 1 

board is first set up and configured. It provides real-time control of the board’s 

interactive features, and serves as the demo application for the on-board controls. 

The individual Board Evaluation windows allow users to, among other things, toggle 

the LEDs and monitor the real-time status of the push button switches and 

potentiometers.

FIGURE 4-15: THE EVALUATION BOARD TEMPLATE (WHOLE-SCREEN 

VIEW SHOWING THE AVAILABLE WINDOWS AT STARTUP)

4.4.1 Putting the Board in Evaluation Mode

Unlike the other templates, the PIC18+CAN Evaluation Board template requires 

additional action by the user beyond a firmware reset. This involves initializing that 

section of the firmware which allows interactive control of the board’s features, which 

are not available when operating with the other templates. The initial setup described 

in 2.3 “Using the PICDEM CAN-LIN 1 Board for the First Time” describes the process 

in detail. If the board is already connected, however, it is only necessary to do the 

following:

1. Open a new project using the Evaluation Board template.

2. In the “PIC18+CAN Controller” window, click “Go on Bus”.

3. In the PIC18+CAN Evaluation Board window, click “Setup Modules”. This 

command causes multiple CAN messages to be transmitted and initializes all 

nodes on the board.

The interactive features of the board are now available.
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4.4.2 PIC18+CAN Evaluation Board Window

As with its counterparts in the other templates, this window displays the current 

communication status with the board. In this template, there are two control buttons. 

“Reset Board” resets the firmware and writes power-on default values to all CAN 

registers. “Setup Modules” initializes the firmware for the interactive (demonstration) 

mode. 

FIGURE 4-16: PIC18+CAN EVALUATION BOARD WINDOW 

(EVALUATION BOARD TEMPLATE VERSION)

4.4.3 Node0 Eval Board (Control) Window

This window controls the interactive features on the Node0. Once initialized, this 

window displays the correct status for the user-defined devices connected to Node0. 

Node0 has the most interactive features, which means that this control window is the 

largest of the three. From top to bottom, the controls are:

• Pot Value: This indicator is updated in real-time to display the approximate 

position of the Node0 potentiometer. The value is also displayed in numerical 

format, ranging from 0 to 1000 (approximately). 

• PWM Intensity: This indicator shows the output of the PWM module in relative 

terms, from minimum to maximum. It also shows the value numerically, ranging 

from 0 to 1000 (approximately); this value is controlled by, and should match that 

of, the Node1 potentiometer in the Node1 Eval Board window. The relative value 

should also correspond to the brightness of the ninth LED, which is controlled by 

the PWM module’s output.

• Push Button Status: The two indicators (btn0 and btn1) show the status of the 

node’s user-defined push buttons. Pressing the buttons on the board will change 

the indicators.

• LED Status: These eight buttons control and indicate the status of the first 8 

LEDs of the LED bank (the ninth LED is controlled by Node1’s potentiometer). 

Clicking on any of the buttons will toggle the corresponding LED on or off. The 

LED Enable jumper (JP3) must be installed for this feature to work.
apRNPNO^-page 36  2003 Microchip Technology Inc.



Using the CANKing Templates
• LCD: If a compatible LCD display is attached at the header, a message can be 

written to it by using this area. To send a line of text, type into the “Text” text box 

(up to 7 characters), then click “Send”. To erase the display, click “Clear”.

• EEPROM: The on-board serial EEPROM can be read from and written to from 

this area. To write, enter a valid address in the “Address” text box, enter data 

values into one or more of the “Content” boxes, then click “Write”. To read, enter a 

valid address in “Address”, then click “Read”.

FIGURE 4-17: NODE0 EVAL BOARD CONTROL WINDOW
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4.4.4 Node1 Eval Board (Control) Window

This window controls Node1, the PIC18C858 CAN and LIN master node. When the 

board is properly initialized, this window will also display the correct “Module Status”.

The interactive features are:

• Pot Value and PWM Intensity: These function identically to their counterparts for 

the Node0 Eval Board control window, except these refer to Node1. The PWM 

intensity displayed and brightness of the ninth LED is controlled by the Node0 

potentiometer, the value of which is displayed in the Node0 Eval Board window.

• Push Button Status: These are identical in function to Node0.

• LED Status: These are also identical to Node0.The LED Enable jumper (JP4) 

must be installed for this feature to work.

FIGURE 4-18: NODE1 EVAL BOARD CONTROL WINDOW
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4.4.5 Node2 Eval Board (Control) Window

This window shows real-time status of Node2, the LIN slave node.

Its features are:

• Poll Automatically: When this check box is selected, the status of the Node2 

potentiometer is monitored in real-time and shown on the “Pot Value” display. Like 

the other nodes, the value is also reported numerically.

• Count LEDs: Checking this box causes the Node2 LEDs to count up in binary 

sequence (least significant digit on the left). The LEDs on the board and the Eval 

window display count synchronously.

• LED Status: Like the other nodes, the LEDs for Node2 can also be individually 

toggled on and off. For this feature (and the "Count LEDs") to work, the LED 

Enable jumper (JP5) must be installed. 

FIGURE 4-19: NODE2 EVAL BOARD CONTROL WINDOW

4.4.6 PIC18+CAN Controller

This window is identical to the PIC18+CAN Controller window in the Basic Template 

(4.3.2 “PIC18+CAN Controller”).

4.4.7 Select Formatters

This window is identical to the Message Formatters window in the Basic Template 

(4.3.3 “Select Formatters Window”). 

4.4.8 History List

This window is identical to the History List window in the Basic Template 

(4.3.5 “History List”). 

4.4.9 Timed Transmission

This is identical to in form and function to the Timed Transmission window in the Basic 

Template (4.3.6 “Timed Transmission”). 

4.4.10 Output Window

The output window is discussed in 3.6 “The Output Window”. 
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4.5 TEMPLATE-SPECIFIC VARIATIONS IN THE MAIN MENU

For the most part, the options available from the CANKing main menu are identical in 

all three template views. The few exceptions are described below. Only two menu 

items will be discussed in this section, as the others are self explanatory.

Messages Menu

In the Basic and PIC18+CAN Evaluation templates, the Messages menu selects the 

CAN message type to be transmitted. Each option opens a dialog box for configuring 

the message; the dialog is unique to the message type. 

Two message options are available: Universal or CAN Kingdom. The Universal option 

allows the user to send standard generic-format messages using a normal (up to eight 

byte), integer, long integer, 32-bit floating point or string page format. The CAN 

Kingdom option lets the user transmit a message that adheres to the CAN Kingdom 

higher layer protocol in one of 20 pre-defined King’s page formats, or a default letter 

format.

In the PIC Register template, the Messages menu provides alternate access to the 

various buffer and register configuration windows; these are available as submenu 

options from the single menu option (PIC18+CAN Eval Board).

Options Menu

All of the templates offer the Global and PIC18+CAN... options in the Options menu. 

These are used to configure communications with the board and global features of 

CANKing, and are discussed in 3.5 “The Main Menu”.

The Basic and P Evaluation templates also include the King’s Pages option. Selecting 

this allows the user to set a default King’s envelope and city/group address.

The options menu contains the configurable properties of both the hardware and the 

software.

The default numeric base is selected by Options > Global. Auto-save switches are 

also contained here.

Options > PIC18+CAN... is where the COM port is selected, and where the oscillator 

frequency is set in software. This menu also contains a switch that determines 

whether or not the Node0 controller will be reset on file open. This feature is for those 

users who want to switch between templates without changing the PIC18CXX8 

configuration (e.g., masks and filters are set to receive ALL messages in the Basic 

template unless this box is deselected).

Note: The oscillator frequency must be set in software to match the hardware so 

the software can configure the bit timing registers correctly. The formulas 

for bit timing contain a oscillator frequency.
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Chapter 5. Reconfiguring the PICDEM™ CAN-LIN 1 Hardware 
5.1 HIGHLIGHTS

This chapter covers the following:

• Node Configurations

• Oscillator Configurations

• Jumper Settings

• Restoring the PICDEM™ CAN LIN 1 Firmware

5.2 NODE CONFIGURATIONS

The PICDEM CAN LIN 1 board can be operated in many different configurations; only 

a few of the possibilities are listed here. Most of these can be implemented without 

any changes to the board; some may require the addition of some components or 

wiring. Access to the external LIN bus will require the addition of a LIN bus connector 

at the pads provided for J4 (item 16 in Figure 1-1). 

5.2.1 Two CAN Nodes, One LIN Node, Embedded System

This is the default configuration. The two CAN nodes (Node0 and Node1) are 
connected via the on-board CAN bus, while Node1 and Node2 are connected via the 
on-board LIN bus. There are no external CAN or LIN bus connections.

This configuration can be used for evaluation or development. For design evaluation, 
use one of the three templates to monitor or control the board. For development, use 
Node1 for the development of applications; Node0 can then be used with the 
CANKing software to monitor the development node. If required, Node1 may also 
communicate with Node2.

5.2.2 Two CAN Nodes, One LIN Node, Distributed System

In this configuration, external CAN and LIN bus devices can be connected to the 
on-board bus.

This configuration can be used for evaluation or development, using a similar 
approach as an embedded system configuration (above).

5.2.3 Two CAN Nodes, Embedded System

In this configuration, Node2 is deactivated by removing the PIC16C432 controller from 
its socket (with the power off, of course). If required, the circuit traces between the 
Node1 USART pins and the standalone LIN bus transceiver may be cut, and an extra 
RS-232 line driver may be added.

In development mode, Node0 can be used to monitor Node1. 

5.2.4 Two CAN Nodes, Distributed System

This configuration connects both on-board CAN nodes to an external CAN bus.

In evaluation mode, Node0 can be used to monitor the external bus. In development 

mode, Node0 can be used to monitor both Node1 and the external bus.
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5.3 OSCILLATOR CONFIGURATIONS

The PICDEM CAN-LIN 1 Board is designed to accommodate three different types of 

oscillators for the PIC18CXX8-based nodes:

• Crystal-controlled oscillator

• RC oscillator

• Self-contained oscillator module (“canned” oscillator)

There are two oscillator sections on the board, one for each of the CAN controllers. As 

shipped from the factory, the board is configured with two 25 MHz canned oscillators. 

If a different clock frequency is desired, it is only necessary to remove the existing 

oscillator modules and insert new ones. 

To implement the other options, it will be necessary for users to make changes to the 

board.

5.3.1 Crystal Oscillator

The on-board oscillator module(s) (Y2 and/or Y3) must be removed from their 

sockets.

Either one (or both) of the CAN controllers can be configured to use a crystal 

oscillator. Pads Y1 and Y4 (for Node0 and Node1, respectively) have been provided 

to add a crystal. Depending on frequency and crystal used, capacitors may also need 

to be added at pads C24/C25 (Node0) and C30/C31 (Node 1). It is the user’s 

responsibility to select values for these components to obtain a frequency compatible 

with the controller. If the RC oscillator option has been previously used, it will be 

necessary to remove the RC network components.

5.3.2 RC Oscillator

The on-board oscillator module(s) (Y2 and/or Y3) must be removed from their 

sockets.

The RC network for the oscillator is not provided, and must be added by the user. 

Each CAN controller has pads provided for an RC network. Pads R21/C27 (for 

Node0) and R22/C29 (for Node1) are provided for the addition of these components. 

It is the user’s responsibility to select values for these components to obtain a 

frequency compatible with the controller.

5.4 JUMPER SETTINGS

There are several jumpers provided for configuring the hardware operation of the 

PICDEM CAN-LIN 1 board. Their functions are listed in Table 5.1, and locations are 

shown in Figure 5-2.

Table 5.1:  Jumper Description

Number Board ID Function

1 JP2 Connects 120 ohm terminating resistor to the CAN bus

2 JP3 LED Enable for Node0

3 JP4 LED Enable for Node1

4 JP5 LED Enable for Node2
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FIGURE 5-2: JUMPER LOCATIONS

5.5 RESTORING THE PICDEM CAN-LIN 1 FIRMWARE

As shipped from the factory, the microcontrollers on the PICDEM CAN-LIN 1 board 

are pre-programmed with special firmware. This provides the code that makes the 

interactive Evaluation mode possible, and enables communication with the CANKing 

host software.

As users develop their own CAN applications, it is likely that the controllers will be 

re-programmed with new firmware. Should it ever become necessary to return the 

board to its original state, it will be necessary to restore the original firmware. 

To make this process easier, the required source and hex files for the firmware have 

been included on the PICDEM CAN-LIN 1 Software CD, in the Firmware folder. To 

reprogram the microcontrollers directly with the original firmware, use these hex files:

• cannode.hex: for Node0 and Node1 devices (PIC18C658/858)

• linnode.hex: for the Node2 device (PIC16C432)

Users should follow the procedure appropriate for their device programmer and 

development environment.

1

2

3

4
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Chapter 6. Troubleshooting
6.1 HIGHLIGHTS

This chapter discusses the following:

• Common issues with the PICDEM™ CAN-LIN 1 Board, and how to solve them

6.2 COMMON PROBLEMS

1. The Power LED is not lit

Check the PICDEM CAN-LIN 1 board for power:

• Verify that the power supply is plugged in, and the wall outlet has power. If battery 

connection is used, verify that the correct polarity is used.

• Check that voltage is available (12VDC) at the plug. If the original power supply is 

not being used, check for appropriate voltage (12VDC).

• Check that the regulated voltage (5VDC) is available at the connectors at the 

prototype area of the board.

2. The host software cannot communicate with the board

Check that the board is receiving power (see issue 1 above)

Check the serial cable for proper connections to the board and the computer. Verify 

that the cable is connected to the correct serial port on the computer. If necessary, 

verify the serial cable by swapping in another cable that is known to be good.

Verify through Windows Device Manager (accessed through the System applet in the 

Control Panel) that the selected COM port is recognized by the operating system, and 

is working.

Verify that you are using the correct serial port. Check that the COM port you have 

selected in the terminal software is actually the physical port that the serial cable is 

connected to.

Verify that the Node0 LEDs flash briefly on reset or power-up of the board.

If you are using the optional LCD module, verify that the text “PIC CAN” is briefly 

displayed on reset or power-up, and an underscore cursor is displayed.

3. The board is operational, but neither of the CAN nodes are recognized on

an external network.

See Appendix B ("FAQs on Configuring the PIC18CXX8") for the most common CAN 

troubleshooting hints.
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Appendix A. PICDEM™ CAN-LIN 1 Board Technical Information
A.1 HIGHLIGHTS

This chapter will cover the following topics:

• PICDEM™ CAN-LIN 1 Block Diagram

• PICDEM CAN-LIN 1 Board Schematics

A.2 BLOCK DIAGRAM

FIGURE A-1: PICDEM CAN-LIN 1 DEVELOPMENT BOARD FUNCTIONAL 

BLOCK DIAGRAM
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A.3 PICDEM CAN-LIN 1 BOARD SCHEMATICS

FIGURE A-1: BOARD SCHEMATIC, PART 1 (NODE0 MICROCONTROLLER AND

ASSOCIATED PARTS)
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FIGURE A-2: BOARD SCHEMATIC, PART 2 (NODE1 MICROCONTROLLER AND

ASSOCIATED PARTS)
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FIGURE A-3: BOARD SCHEMATIC, PART 3 (NODE2 MICROCONTROLLER, LIN AND

CAN TRANSCEIVERS, EEPROM)
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FIGURE A-4: BOARD SCHEMATIC, PART 4 (USART, OSCILLATOR OPTIONS AND

POWER SUPPLY)
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FIGURE A-5: BOARD SCHEMATIC, PART 5 (LEDS AND LCD DISPLAY OPTION)
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FIGURE A-6: BOARD SCHEMATIC, PART 6 (OPTIONAL PROTOTYPE HEADERS AND 

CONNECTORS)
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TABLE A-1: SIGNALS USED IN THE PICDEM CAN LIN 1 SCHEMATIC

TABLE A-2: LCD CONTROLLER HEADER

Signal Name Function

CAN_H, CAN_L Differential high and low CAN bus signals

ICSP_1_VPP or 

ICSP_2_VPP

ICSP programming voltage and Reset for the designated 

controller:

1 – CAN Node0 (PIC18C658)

2 – CAN Node1 (PIC18C858)

LINBUS Differential LIN bus signal

MCLR_3 Reset signal for LIN Node (PIC16C432)

SW_1_n or SW_2_n Push button input from switch n for the designated controller:

1 – CAN Node0 (PIC18C658)

2 – CAN Node1 (PIC18C858)

RXn_1, RXn_2 or RXn_3 Bit n of Port X for the designated controller:

1 – CAN Node0 (PIC18C658)

2 – CAN Node1 (PIC18C858)

3 – LIN Node (PIC16C432)

VBAT LIN bus battery voltage (+9 to +12 VDC)

Pin Signal Pin Signal

1 GND 2 +5 V

3 VEE 4 RS

5 R/W 6 E

7 NC 8 NC

9 NC 10 NC

11 DB4 12 DB5

13 DB6 14 DB7
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Appendix B. FAQs on Configuring the PIC18CXX8
B.1 HIGHLIGHTS

This section discusses some of the most frequently-asked questions (FAQs) on 

configuring and programming PIC18CXX8 microcontrollers.

B.2 FAQS

Q: Why doesn’t the development tool successfully communicate on an external 

bus?

A: There are several possible reasons why this happens. The following are the most 

common problems:

Q: Why does the node acknowledge messages in the Basic template, but not 

display them?

A: The PIC18CXX8 filters are not matching the incoming messages. This can be 

caused because the “Reset PIC18+CAN on Open” is deselected causing the old 

register contents (masks and filters) to remain unchanged when switching 

templates.

Press reset or select the “Reset PIC18+CAN on Open” box and reopen the 

template.

Q: Why can’t I enter values in the Physical Layer window?

A: The PIC18CXX8 is not in Configuration mode. The three BRGCON registers are 

only modifiable while in Configuration mode. Change modes.

Condition Fix

The PIC18CXX8 is off the bus 

(not in Normal mode).

Basic template – “Go on Bus” button in 

the “Bus Status” window.

The COM port is not configured correctly. Make sure COM port selection is correct 

(Options > PIC18+CAN...).

The bus rate is not set to match the bus. Basic template – Set the bus rate in the 

Bus Status window.

Register template – change BRGCON 

registers.

The oscillator frequency not set to match 

hardware (Fosc is required in bit rate 

formula).

Set the oscillator frequency (Options > 

PIC18+CAN...).

Board is not connected to the external 

bus.

Connect to the external bus using the 

DB9 labeled CAN. Pinouts: CANH - pin 7, 

CANL - pin2.
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Q: Why don’t the mask and filter registers change after pressing the Write 

button?

A: The PIC18CXX8 is not in Configuration mode. Masks and filters are changeable 

only in Configuration mode.

Q: How do I enter extended IDs into a field?

A: Lead off the number with an ‘x’, which indicates an extended frame (e.g., x12345).
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Appendix C. PICDEM™ CAN-LIN 1 Software CD
C.1 HIGHLIGHTS

This chapter summarizes the contents of the PICDEM™ CAN-LIN 1 Software 

CD-ROM.

C.2 WHAT’S ON THE CD

The PICDEM CAN-LIN 1 CD includes the following software tools and support 

documentation. 

CANKing Host Software

The entire utility is contained in the self-extracting installer file wc32mchip_pic.exe. 

Executing this file will install the CANKing software described in Chapter 3, and the 

pre-defined templates covered in Chapter 4.

PICDEM CAN-LIN 1 Firmware

The firmware for the Demonstration Board’s microcontrollers are located in the 

Firmware folder. The device-specific files are located in the subfolders CANNode (for 

PIC18CXX8 devices) and LINNode (for PIC16C432). In addition to the hex files for 

device programming, assembler and C language source files are provided for creating 

custom projects. 

All necessary project, header and linker files are also included, so that users with 

MPLAB may begin to create custom projects immediately.

Support Files for Microchip PICmicro Microcontrollers with CAN

Also provided is a complete library of support information for Microchip’s line of 

microcontrollers with CAN functionality. This includes:

• The latest data sheet for the PIC18CXX8 family of microcontrollers;

• The In-Circuit Serial Programming specification for the PIC18CXX8 family;

• Application Note 738, "PIC18C CAN Routines in ’C’", which presents a library of 

CAN functions;

• Application Note 853, "PIC18CXX8 CAN Driver with Prioritized Transmit Buffer", 

which provides an assembler-based firmware driver for a CAN node; and

• Sales and support literature for the PIC18CXX8 family.

The application notes are provided with a complete set of the source code files 

discussed in each document, allowing the user to begin working with the CAN utilities 

immediately.

PICDEM™ CAN-LIN 1 User’s Guide

This single file is the electronic version of this Development Kit manual, provided in 

Adobe® Acrobat® format.

Note: The MPLAB Integrated Development software is not included with the 

PICDEM CAN-LIN 1 Kit. Users who do not have MPLAB may download it 

without charge from the Microchip web site (www.microchip.com).
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